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Osmose O-Calc® Pro Plugins and Standalone 

Applications Overview 
 

About Osmose O-Calc® Pro Plugins and Standalone 

Applications 

Osmose O-Calc® Pro is a powerful pole loading calculation platform, but at 

the same time is an intuitive and easy to user application.  While the 

calculations within O-Calc® Pro are complex and extensive, the user 

interface is designed for simplicity and ease of use.  The O-Calc® Pro 

platform extends this structural load analysis in a simple, straightforward 

manner with the use of O-Calc® Pro Plugins and Standalone applications.  

These are extensions and additions tools of the O-Calc® Pro platform that 

further increase the completion of complex tasks using tools that are 

designed to be used by non-structural engineering personnel at utilities.   

O-Calc® Pro plugins are typically extensions that either integrate data from 

front end field data collected information, integrate pole loading calculations 

into back end operational support systems, or manipulate the O-Calc® Pro 

models in particular ways.  The O-Calc® Pro plugin architecture is so 

powerful, that particularly any conceivable feature or function can be added. 

O-Calc® Pro standalone applications are known, existing features that have 

been separated from the O-Calc® Pro software and packaged as standalone 

applications.  This helps the user perform tasks, such as determining tensions 

and sags on a particular conductor, without having to fully model a pole 

within O-Calc® Pro.      

This O-Calc® Pro Plugin and Standalone Application User’s Guide gives a 

brief working description of a number of plugins and applications that have 

been developed by Osmose and are shipped with the O-Calc® Pro 

application.  This document does not describe how to create your own O-

Calc® Pro plugin or application.  
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Working With the O-Calc® Pro Plugins 
 

Understanding Plugins  

Plugin Overview  

O-Calc® Pro plugins are add-ins to the O-Calc® Pro platform that extends 

the functionality of O-Calc® Pro.  How the O-Calc® Pro functionality is 

enhanced or changed is a function of the plugin has been created.  The list 

below gives a quick description of the intent of the plugin, while later 

sections of this document give detailed step-by-step instructions on how each 

particular plug-in works.   

Available Plugins  

The following plugins are available: 

Plugin Name Description 

Add Pole as New Version Add Pole as New Version allows you to 

import an existing .pplx file into your current 

O-Calc session as a new version of your 

current model.  

Analysis Export Plugin Analysis Export Plugin allows you to export 

analysis data in .CSV format to be imported 

in another application. 

Clipboard Capture Plugin Clipboard Capture Plugin provides an 

integrated method to capture span lengths 

and angles from Google Earth. 

Collada Export Plugin Collada Export Plugin allows you to export 

3D View as a mesh file for import into CAD 

or another application. 

ET Truss Selector Plugin ET Truss Selector Plugin is an automated 

tool that enables the user to select the proper 

ET Truss for either poles that are overloaded 

or need to have an effective pole class 

upgrade. 

External Tools Plugin External Tools Plugin allows you to run 

other programs from within O-Calc Pro. 

FEM Export Plugin FEM Export Plugin allows you to export the 

dimensions and loads of Finite Element 

Model (FEM) into a text file for review or to 

be used in another application. 
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GPS Plugin GPS Plugin allows you to capture GPS 

coordinates for machines that have a GPS 

receiver and can then be used to populate the 

poles coordinates. 

Inventory Edit Plugin Inventory Edit Plugin allows you to edit 

numerous object(s) attributes within one 

window.   

JSON Import Export Plugin JSON Import Export Plugin allows you to 

import a JSON file (instead of a .pplx file) or 

export a .pplx file to JSON file format. 

Load Explore Plugin Load Explore Plugin allows you to create an 

HTML report for the various loads and 

moments for each component attached to the 

pole. 

Location Service Plugin Location Services Plugin allows you to 

populate a structure’s latitude and longitude 

coordinates using location services. 

O-Calc LE Plugins O-Calc LE plugins include the 

Configuration, Import, Management, and 

Wizard plugins. These allow you to utilize 

the O-Calc LE mobile device web 

application.  

For more information, please review separate 

O-Calc LE Documentation found in the Help 

user root folder.  

Open from QR Code Plugin The Open from QR Code Plugin allows you 

to generate a unique QR code for the pole 

model and open it from an image of the QR 

code. 

Photo Edit Plugin Photo Edit Plugin allows you to use a 3D 

party application to edit photos that are 

attached to a structure.  

Pole Browser Plugin Pole Browser Plugin creates a new tab with a 

list of PPLX files which has a summary of 

pole information, and a thumb nail list of 

associated images.  PPLX files can be 

selected from this window and automatically 

be opened in the Inventory Window. 

Scripting Plugin Scripting Plugin allows you to run scripts 

that allow you to manipulate pole data for 

simplicity. 



Plugins and Standalone Applications                    Confidential User’s Guide 
 

10                                   ©2018 Osmose Utilities Services, Inc.                 

Shape File Plugin Shape File Plugin Creates a new tab in which 

the user can include shape files and a number 

of PPLX files to give a geospatial view of 

the pole models. 

Show Pole On Google 

Earth Plugin 

Show Pole on Google Earth Plugin Using 

Google Earth allows you to view a large 

number of poles on a map.  As well as 

opening poles from the map.   

(enables the display of PPLX models on 

Google Earth as individual poles or series of 

pole model locations) 

Slack Integration Plugin Slack Integration Plugin Integrates O-Calc 

Pro process into the Slack messaging 

application. 

STL Generator Plugin STL Generator Plugin Export 3D View as a 

STL file for import into another application. 

Voice Control Plugin Voice Control Plugin allows you to use the 

built in Microsoft Windows Speech 

Recognition engine to control specific 

actions within O-Calc Pro with your voice. 

 

Step-by-Step Plugin Descriptions 

Add Pole as New Version 

The Add Pole as New Version Plugin allows you to import a previously 

created .pplx file as a new version of the current .pplx file that you are 

working with. To enable and use the Add Pole as New Version Plugin, 

complete the following steps: 

Note:  A pole needs to be loaded in order to use this plugin.  

1. Select the Add Pole as New Version Plugin from the Options>Manage 

Plugins menu and select Apply. 

2. Select Yes to restart the application and apply you’re changes. 

3. Select File>Add Pole as New Version.  
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4. In the windows explorer window that opens, navigate to the .pplx file you would 

like to bring in as a version.  

5. Select the .pplx file, and click Open. 

6. In the Inventory Pane, verify that a version has been added.  

 

Analysis Export Plugin 

The Analysis Export Plugin allows you to export analysis data into CSV 

format so the data can be imported into another application.  To enable and 

use the Analysis Export Plugin, complete the following steps: 

Note:  A pole needs to be loaded in order to use this plugin.  

1. Select the Analysis Export Plugin from the Options>Manage Plugins 

menu and select Apply. 

2. Select Yes to restart the application and apply you’re changes. 

3. Select Tools>Export Analysis Data.  

 

Note: A structure needs to be loaded in order to export analysis data. 

Select the export you would like to complete: 
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A. Basic Analysis Data – Will export standard Analysis Report 

information into a CSV file.  It will list the name of each 

parameter associated with the pole model and the corresponding 

value for that parameter.  

B. Sweep Analysis Data – Will export information into CSV format 

about the capacity utilization of the pole as a function of the 

height above groundline (by default in 36 inch increments) and 

as a function of wind angle in 10 degree increments. 

C. Guy Tension Data – Will export information about the tension of 

each guy on the modeled pole as a function of wind angle in 10 

degree increments into CSV format. 

4. Browse to the location you would like to save the CSV file, enter the 

File Name and select Save.  

Clipboard Capture Plugin 

The Clipboard Capture Plugin allows you to populate latitude and longitude 

coordinates from other data sources (e.g. Google Earth) via the clipboard. To 

enable and use the Clipboard Capture Plugin, complete the following steps: 

Note:  The example below uses the Google Earth application; you may use other 

data sources as well. 

1. Select the Clipboard Capture GPS Plugin from the Options>Manage 

Plugins menu and select Apply. 

2. Select Yes to restart the application and apply you’re changes. 

3. Open the structure that you would like to copy coordinates to. 

4. Establish the location within Google Earth. 

5. Select Edit< Copy View Location in Google Earth. 

 

6. Enter the GPS Location Name in Google Earth. 

 

7. Select OK. 
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Note:  Multiple GPS location names can be stored by O-Calc Pro.  To add 

another GPS Location repeat steps 4 – 7.  

8. In O-Calc Pro select Edit>Pole Coordinates. 

 

9. Select the Choose GPS Clip Loc button. 

 

10. Select the GPS Location Name that has the coordinates you would like 

copied into the Geo Location Latitude and Longitude fields.  

 

 

11. Select OK.  

Note: Select Clear Stored Location to clear the stored coordinates from the 

clipboard.  Closing the application will also clear the stored coordinates. 

12. To auto-calculate the location end of span using a GPS Clip Location, 

select the Ganged Geometry object .   
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Note: Selecting a span(s) in the Inventory Window will highlight the span(s) in 

the Top View Window. 

 

13. Select the Lat Lon button. 

 

14. Select the GPS Clip Location for the end of span. 

 

The Ganged Geometry Editor Angle and Span Length are 

automatically updated using the selected GPS Clip Location. 
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15. Select OK. 

Collada Export Plugin 

The Collada Export Plugin allows you to export the 3D View as a MESH 

file.  This provides you with the ability to import the 3D View into another 

application such as a 3D Graphic CAD program.  To enable and use the 

Collada Export Plugin, complete the following steps: 

1. Select the Collar Plugin from the Options>Manage Plugins menu and 

select Apply. 

2. Select Yes to restart the application and apply you’re changes. 

3. Select File>Export to COLLADA. 

 

Note: A structure needs to be loaded in order to enable the Export to COLLADA 

option. 

4. Browse to the location you would like to save the MESH file, enter the 

File Name and select Save. 

 

ET Truss Selector Plugin 

The Osmose ET-Truss Selector Plugin automatically selects the proper ET-

Truss (extended and tapered truss) based on either the overloaded model or 

the user-defined increase in effective pole class.  This is an incredible useful 

tool for pole owners who are performing system hardening projects.  To 

enable and use the Osmose ET-Truss Selector Plugin, complete the following 

steps: 

Additional information can be obtained from the following location:  

http://www.osmose.com/content/pages/et-truss 

1. Select the ET Truss Selector Plugin from the Options>Manage 

Plugins menu and select Apply. 

2. Select Yes to restart the application and apply you’re changes. 

3. Open the structure that you would like to use the ET Truss Selector 

with. 

4. Select Tools>Osmose ET-Truss ® Selector. 

http://www.osmose.com/content/pages/et-truss
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5. Select the ET Truss Size from the drop down list. 

  

 

Size Display Description 

 Width in inches 

 
Thickness 

 Kips 

 

Note: Select the Auto button to have the ET Truss Solution automatically 

populate the minimal value. 

Overload Point 

ET Truss 
Configuration 

ET Truss Options 
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Note: Select the Allow 2X option to enable the selector to try using 2 ET Trusses 

if a single ET Truss solution is not found.  

6. Select the Length of the ET Truss. 

Note: The Length should be at least one foot about the Height of Overload. 

7. Select the Count of the ET Trusses 

8. Adjust the Max fit deg if needed. 

ET Truss Options Description 

 The Apply ET Truss to Pole 

option will apply the solution to 

the currently loaded structure. 

 The Send to Osmose for 

Analysis option will send the 

solution to Osmose for analysis. 

 The ET Truss Report option 

will display the current solution 

in report format. 

 

External Tools Plugin 

The External Tool plugin allows you to run additional programs from within 

O-Calc Pro.  It also permits you to pass parameters from one application to 

another.  To enable and use the External Tools Plugin, complete the 

following steps: 

1. Select the External Tools Plugin from the Options>Manage Plugins 

menu and select Apply.  

2. Select Yes to restart the application and apply you’re changes. 

3. Select Tools>External Tools>Edit Tools List.  

 

4. Add the application that you would like to run within O-Calc Pro to the 

Edit Tools List. 
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5. Select File>Save to save your modifications. 

6. Close and reopen the O-Calc Pro application. 

7. Select Tools>External Tools>(menu title you entered in the 

configuration file) to open the application. 

 

 

FEM Export Plugin 

The Finite Element Model (FEM) plugin allows you to create a text file of 

the dimensions and loads for each finite element within the model.  To 

enable and use the FEM Plugin, complete the following steps: 

1. Select FEM Export from the Options>Manage Plugins menu and 

select Apply.  

2. Select Yes to restart the application and apply you’re changes. 

3. Select File>FEM Model Export. 

Menu title and 
application to be 
opened when 
selected 
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Note: A structure needs to be loaded in order to enable the FEM Model Export 

option. 

4. Browse to the location you would like to save the file, enter the File 

Name and select Save. 

GPS Plugin 

The GPS Plugin allows you to populate a structure’s latitude and longitude 

coordinates from a device.  To enable and use the GPS Plugin, complete the 

following steps: 

1. Select the GPS Plugin from the Options>Manage Plugins menu and 

select Apply.  

2. Select Yes to restart the application and apply you’re changes. 

3. Select File>GPS>Port to configure the GPS device port. 

 

4. Select File>GPS>Baud to configure the GPS device baud. 
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5. To verify the GPS connection select File>GPS>Status. 

 

 

6. Open the structure that you would like to capture the GPS coordinates 

for.  

7. To start the GPS device select File>GPS>Start GPS. 

 

8. Select Edit>Pole Coordinates. 
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9. Select the Get Coordinate button. 

 

The GPS coordinates are automatically populated with the latitude and 

longitude obtained by the GPD device. 

 

10. Select OK. 

11. To stop the GPS device select File>GPS>Stop GPS. 

Inventory Edit Plugin 

The Inventory Edit Plugin is used to rapidly edit numerous object(s) 

attributes within one window.  The plugin will open a full screen window 

that displays all the objects and their attributes in edit mode making it very 

efficient to edit numerous attributes quickly.   To enable and use the 

Inventory Edit Plugin, complete the following steps: 

1. Select the Inventory Edit Plugin from the Options>Manage Plugins 

menu and select Apply.  

2. Select Yes to restart the application and apply you’re changes. 

3. Select Edit>Whole Inventory Edit. 
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Note: A structure needs to be loaded in order to enable the Whole Inventory 

Edit option. 

 

4. Complete any modification to the attributes. 

Note: Attributes that are not editable in the Data Entry Panel or that need 

administrative privileges will not be editable in the Inventory Edit Form. 

5. Select the X in the upper right hand corner to save and close the 

Inventory Edit Form window. 

JSON Import Export Plugin 

The JSON plugin allows you to import a JSON file (instead of a .pplx file) or 

export a .pplx file to JSON file format.  To enable and use the JSON 

Import/Export Plugin, complete the following steps: 
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1. Select the JSON Import Export Plugin from the Options>Manage 

Plugins menu and select Apply.  

2. Select Yes to restart the application and apply you’re changes. 

3. To export the current .pplx file to a .spiff file, select File>SPIFF Export. 

 

Note: A structure needs to be loaded in order to enable the SPIFF Export 

option. 

Note:  Images attached, or embedded, to the .pplx file are not exported.   

4. Browse to the location you would like to save the SPIFF file, enter the 

File Name and select Save. 

5. To import a SPIFF file, select File>SPIFF Import. 

 

6. Browse to the SPIFF file you would like to import, select Open. 

The file is automatically opened in O-Calc Pro. 

Load Explore Plugin 

The Load Explorer Plugin creates a report that contains reference 

information on every applied load on the currently loaded structure.  To 

enable and use the Load Explore Plugin, complete the following steps: 

1. Select the Load Explorer Plugin from the Options>Manage Plugins 

menu and select Apply.  
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2. Select Yes to restart the application and apply you’re changes. 

3. Select Tools> Load Explorer. 

 

Note: A structure needs to be loaded in order to enable the Load Explorer 

option. 

Note:  The report may take a moment to load. 

Once the Load Explorer option has been selected the report will 

automatically be loaded.  The report will also be saved to your temp 

folder as Loads.html. 
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Location Service Plugin 

The Location Services Plugin allows you to populate a structure’s latitude 

and longitude coordinates using location services.  To enable and use the 

Location Service Plugin, complete the following steps: 

1. Select the Location Services Plugin from the Options>Manage 

Plugins menu and select Apply.  

2. Select Yes to restart the application and apply you’re changes. 

Note: You will be prompted to setup a default location if one is not already 

setup. 

3. Open the structure that you would like to capture the GPS coordinates 

for. 

4. Select Edit>Pole Coordinates. 

 

5. Select the Get Coordinate button. 

 

The GPS coordinates are automatically populated with the latitude and 

longitude obtained by the GPD device. 

 

6. Select OK. 
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Open from QR Code Plugin 

The Open from QR Code Plugin allows you to open a pplx file based on the 

structures unique QR Code.   

Example:  If your .pplx files are on a shared network you can send someone 

the QR Code of a structure you would like them to review.  The QR Code 

can be emailed, screen captured, captured with a digital photo or captured via 

webcam, etc... 

To enable and use the Open from QR Code Plugin, complete the following 

steps: 

1. Select the Open From QR Code Plugin from the Options>Manage 

Plugins menu and select Apply.  

2. Yes to restart the application and apply you’re changes. 

3. To copy the QR Code of the currently loaded structure, select File>Open 

from QR Code>Copy QR Code of this pole to clipboard. 

Note:  The structure needs to be saved in order to have a QR Code. 

 

The QR Code is copied to the Office Clipboard and can be pasted into 

other applications such as email, Microsoft Word or Excel for future use.   

Note: The QR Code can also be viewed in the QR Code Report. 

 

4. To automaitcally get the QR code from the Office Clipboad and open the 

.pplx file, select File>Open from QR Code>Get QR Code from 

clipboard and open. 



Plugins and Standalone Applications                    Confidential User’s Guide 
     

 ©2018 Osmose Utilities Services, Inc. 27 

 

Photo Edit Plugin 

The Photo Edit Plugin allows you to modify photos that are attached to a 

currently loaded structure using your built in photo editing application.  To 

enable and use the Photo Edit Plugin, complete the following steps: 

1. Select the Photo Edit Plugin from the Options>Manage Plugins menu 

and select Apply.  

2. Select Yes to restart the application and apply you’re changes. 

3. Open the structure that has images you would like to modify. 

4. Select the Measure Tab. 

Note: If multiple images are attached to the strucutre select the image you 

would like to modify. 

5. Select Image>Photo Edit. 

 

The image is automatically opened in your default image editing 

application. 

6. Complete any modifications to the selected image. 

7. Save the modification and close the image editing application. 

The image is automatically updated in the Measure Tab in O-Calc Pro. 
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Pole Browser Plugin 

The Pole Browser Plugin allows you to easily browse through all your .pplx 

files. The Pole Browser Plugin displays the structures capacity level, basic 

structure information and displays all images attached to the structure. To 

enable and use the Pole Browser Plugin, complete the following steps: 

1. Select the Pole Browser Plugin from the Options>Manage Plugins 

menu and select Apply.  

2. Select Yes to restart the application and apply you’re changes. 

3. Select the Pole Browser tab. 

 

 

  

 

 

 

4. Select the Browse button  and browse to the location of the .pplx 

files you would like to browse. 

5. Use the up/down arrows to set the threshold for the % of Capacity.  

 

 

 

 

 

A new tab is created when 
the plugin is enabled 

.pplx path 
% of capacity 
threshold 

At or Over 
Capacity 

Acceptable 
Capacity 

Near Capacity 
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The following table describes the default color representation for the 

Pole Capacity. 

Display Color Description 

Green Acceptable Capacity 

Yellow  Near Capacity 

Red At or Over Capacity 

6. Double click on the structure you would like loaded in the Inventory 

Window.  

Scripting Plugin 

The scripting plugin allows you to run scripts that allow you to manipulate 

pole data for simplicity.  The scripting plugin is the same scripting that is in 

Microsoft Excel. 

An instructional video and additional information can be obtained from the 

following locations:  

https://www.youtube.com/watch?v=mJASmApV9qM 

http://o-calcpro.com/wiki/category/scripting/ 

To enable and use the Scripting Plugin, complete the following steps 

1. Select the Scripting Plugin from the Options>Manage Plugins menu 

and select Apply.  

2. Select Yes to restart the application and apply you’re changes. 

Shape File Plugin 

The Shape File Plugin Creates a new tab in which the user can include shape 

files and a number of PPLX files to give a geospatial view of the pole 

models. 

Additional instructions can be obtained from the following instructional 

video: 

https://www.youtube.com/watch?v=Pn5cmVS8KwE 

To enable and use the Shape File Plugin, complete the following steps: 

1. Select the Shape File Plugin from the Options>Manage Plugins menu 

and select Apply.  

2. Select Yes to restart the application and apply you’re changes. 

 

 

 

 

 

https://www.youtube.com/watch?v=mJASmApV9qM
http://o-calcpro.com/wiki/category/scripting/
https://www.youtube.com/watch?v=Pn5cmVS8KwE


Plugins and Standalone Applications                    Confidential User’s Guide 
 

30                                   ©2018 Osmose Utilities Services, Inc.                 

 

 

 

Toolbar Menu Options 

The toolbar menu provides you with a variety of operations and 

options. 

 

 

File.  The following options 

are available from the File 

menu: 

New Project.  Select the 

New Project option to start a 

new project. 

Open Project.  Select the 

Open Project option to open 

Easy GIS Project File. 

Save Project.  Select the 

Save Project option to save 

the current project. 

Save Project As.  Select the 

Select Project As to save the 

current project under a 

different name. 

Add Shape File.  Select the 

Add Shape File option to 

open a shape file. 

 

Landbase Layer 
Display 

Description of 
Selected Landbase 

Layer 

Map 
Display 

Toolbar 

Shapefile Tab 
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Save Map Image.  Select the 

Save Map Image to save the 

currently displayed map 

image. 

Print Map.  Select the Print 

Map option to print the 

currently displayed map 

image. 

 

View.  The following 

options are available from 

the View menu: 

Hide Layer List.  Select the 

Hide Layer List option to 

hide the landbase layer list 

and the landbase layer 

description.  The map will 

resize to cover the whole 

area.  

Note: The Hide Layer List 

option will change to Show 

Layer List when selected.  

Zoom to Fit.  Select the 

Zoom to Fit option to revert 

the map display back to 

default setting zoom level. 

  

 

Poles.  The following 

options are available from 

the Poles menu: 

Show Poles.  Select the 

Show Poles option to load 

the poles in the map. 

Clear Poles.  Select the 

Clear Poles option to remove 

the poles from the map. 

 

Options.  The following 

options are available from 

the Option menu: 

Map Background Color.  

Select the Map Background 

Color option to change the 

map background color.  

 

                                 



Plugins and Standalone Applications                    Confidential User’s Guide 
 

32                                   ©2018 Osmose Utilities Services, Inc.                 

Mercator Projection.  Select 

the Mercator Projection 

option to change the 

projection of the map. 

Render Quality.  Select the 

Render Quality option to set 

the rendering quality of the 

map. 

Use Native File Mapping.  

Select this option so that the 

shape file is displayed based 

in its native coordinate 

system, otherwise it will be 

translated based on a 

corresponding projection 

file. 

Display Shape Attributes 

Window.  Select the Display 

Shape Attributes Window 

option to display the share 

attributes window. 

View Attribute List.  Select 

the View Attribute List 

option to view the attribute 

list. 

 

3. Select File>New Project.  

4. Select File>Add Shape File, browse to the location of your shape file(s) 

and select the shape file you would like loaded. 

5. Select Poles>Show Poles, browse to the location of the .PPLX files you 

would like displayed on the map.  

Show Pole On Google Earth Plugin 

To enable and use the Show Pole on Google Earth Plugin, complete the 

following steps: 

1. Select the Show Pole on Google Earth Plugin from the 

Options>Manage Plugins menu and select Apply.  

2. Select Yes to restart the application and apply you’re changes. 

3. Select File>Show on Google Earth. 

Options Description 

Show Marker The currently loaded .structure is 

displayed as a marker in Google 

Earth. 
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Render Structure Renders the currently loaded 

structure in Google Earth. 

 

Batch Create Index Creates a batch index (.kml) file 

containing a group of structures 

from a specific location. 

Help Provides set-up and basic 

information.  

Show Marker 

To have the currently loaded structure represented as a marker in 

Google Earth, complete the following steps: 

1. Open the structure that you would like to show in Google Earth. 

Note: The structure’s Geo Coordinates need to set-up before the 

structure can be shown in Google Earth, Edit>Pole Coordinates.   

2. Select File>Show on Google Earth>Show Marker. 

Google Earth will automatically open and the currently loaded 

structure will be represented as a marker in Google Earth. 

Note: Left clicking on the marker will provide a link to open the 

structure in O-Calc Pro. 

Render Structure 

To render the currently loaded structure in Google Earth, complete 

the following steps: 

1. Open the structure that you would like to show in Google Earth. 

Note: The structure’s Geo Coordinates need to set-up before the 

structure can be rendered in Google Earth, Edit>Pole Coordinates. 

2. Select File>Show on Google Earth>Render Structure. 

Google Earth will automatically open and the currently loaded 

structure will be rendered in Google Earth. 

Batch Create Index 

To create a batch index file that contains a group of structures and to 

have their markers displayed in Google Earth, complete the 

following steps: 

1. Select File>Show on Google Earth>Batch Create Index. 

2. Browse to the location of the structures you would like to create 

a batch index (.kml) file of, and select the Select Folder button. 

3. Select Yes or No to include the sub-directories. 

4. Browse to the location you would like the file saved to, enter a 

name for the file and select Save. 
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Google Earth will automatically open and the currently loaded 

structure will be represented as a marker in Google Earth. 

Note: Left clicking on a specific marker will provide a link to open the 

structure in O-Calc Pro. 

Help 

To find general set-up information, complete the following steps: 

1. Select File>Show on Google Earth>Help. 

Slack Integration Plugin 

The Slack Integration Plugin Integrates O-Calc Pro processes into the Slack 

messaging application. 

An O-Calc Pro instructional video can be obtained from the following 

location: 

https://www.youtube.com/watch?v=BjphJ3oupgA 

To enable and use the Slack Integration Plugin, complete the following steps: 

1. Select the Slack Integration Plugin from the Options>Manage Plugins 

menu and select Apply.  

2. Select Yes to restart the application and apply you’re changes. 

STL Generator Plugin 

The STL Generator Plugin allows you to export the 3D View as an STL file.  

This provides you with the ability to import the 3D View into another 

application. To enable and use the STL Generator Plugin, complete the 

following steps: 

1. Select the STL Generator Plugin from the Options>Manage Plugins 

menu and select Apply.  

2. Select Yes to restart the application and apply you’re changes. 

3. Select File>Export to STL. 

 

Note: A structure needs to be loaded in order to enable the Export to STL 

option. 

https://www.youtube.com/watch?v=BjphJ3oupgA
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4. Browse to the location you would like to save the MESH file, enter the 

File Name and select Save. 

Voice Control Plugin 

The Voice Control Plugin allows you to use the built in Microsoft Windows 

Speech Recognition engine to control O-Calc Pro with your voice.  When 

this plugin is enabled you can interact with menu items and enter numbers 

using your voice.  

Note: The Microsoft Windows Speech Recognition engine needs to be configured 

properly in order for the Voice Control Plugin to work. 

To enable and use the Voice Control Plugin, complete the following steps: 

1. Select the Voice Control Plugin from the Options>Manage Plugins 

menu and select Apply.  

2. Select Yes to restart the application and apply you’re changes. 
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Standalone O-Calc® Pro Applications 
 

Understanding Standalone Applications 

Standalone Applicatin Overview  

O-Calc® Pro system has a number of features either directly built into the 

software or has extended features based on the O-Calc® Pro plugins 

architecture.  Some of these features have been created developed into 

applications that are separate from the O-Calc® Pro platform.  These 

standalone applications, as is a common theme within the O-Calc® Pro 

system, enable the user to be efficient in performing the pole loading 

analysis. While these are separate, standalone applications, they are still part 

of the overall platform.  For example,  using the Pole Browser application 

gives the user a thumb nail view of a list of PPLX files, but double clicking 

on any pole within the Pole Browser will launch the O-Calc® Pro application 

for this pole.  The list below gives a quick description of the intent of each O-

Calc® Pro Standalone Application, while later sections of this document give 

detailed step-by-step instructions on how each particular plug-in works.   

Available Standalone Applications 

The following standalone applications are available:  

Application Description 

Digital 

Measurement 

Technology 

(DMT) 

The Digital Measurement Technology (DMT) allows the 

measurement of pole features from image data. 

Image Split 

Merge 

The Image Split Merge application allows you to embed 

and un-embed images within PPLX files. 

Pole Browser The Pole Browser standalone application creates another 

O-Calc Pro window with a list of PPLX files, summary 

of pole information, and a thumb nail list of associated 

images.  PPLX files can be selected from this window 

and automatically be opened in O-Calc Pro. 

Sag Tension 

Calculator 

The Sag Tension Calculator allows you calculate and 

apply a Sag Tension to a span whose Tension Type is set 

to Static.   The Sag Tension Calculator can also be used 

for reference purposes without applying a sag tension 

calculation. 

Shape File 

Viewer 

The Shape File Viewer allows you to work with shape 

files and a number of PPLX files to give a geospatial 

view of the pole model. 
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Step-by-Step Standalone Application Descriptions 

 

Digital Measurement Technology (DMT) 

The DMT tool provides a variety of tools designed to allow the user to 

complete image measurements, review and enhance image data. 

1. Open the O-Calc Pro Bin directory and double click the DMTTool.exe.  

 

 

 

 

  

  

Toolbar 

Image View 
Window 

Navigation 
Pane 

Scale Tool Measurement Mode 
Selector 

Associated 
Images 

Current Image Path 

Displays the 
Viewport Data 

Label Descriptions 
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Toolbar Menu Options 

The toolbar menu provides you with a variety of operations and 

options. 

 

 

File.  The following options 

are available from the File 

menu: 

New.  Select the New option 

to clear the viewport label 

information from the Data 

panel. 

Load.  Select the Load 

option to load an .ODMT 

file. 

Save.  Select the Save option 

to save the current 

measurements. 

Select Image.  Select the 

Select Image option to select 

images to be opened in the 

DMT tool. 

Select PPLX File.  Select the 

Select PPLX File option to 

open an existing PPLX file. 

View / Print Report.  Select 

the View / Print Report 

option to view or print the 

DMT report. 

Copy Data.  Select the Copy 

Data option to copy the data 

to clipboard so that the data 

can be pasted directly into 

another application such as 

Microsoft Word, E-mail, etc. 

Copy Image.  Select the 

Copy Image option to copy 

the currently selected image 

to clipboard so that the image 

can be pasted directly into 

another application such as 

Microsoft Word, E-mail, etc.                                              
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Copy Viewport.  Select the 

Copy Viewport option to 

copy the selected image as it 

is currently displayed to the 

clipboard. The copied image 

can then be pasted directly 

into another application such 

as Microsoft Word, E-mail, 

etc. 

 

Edit.  The following options 

are available from the Edit 

menu: 

Undo.  Select the Undo 

option to undo the last 

measurement from the Data 

panel.  

Default Font Size.  Select 

the Default Font Size option 

to change the default 

viewport label font. 

Default Color.  Select the 

Default Color option to 

change the default viewport 

label font color. 

Load Description Set.  

Select the load Description 

Set option to load a custom 

description set. 

Reset Description Set.  

Select the Reset Description 

Set option to reset the 

description set. 

Auto-Next Description.  

Select the Auto-Next 

Description option to 

automatically advance to the 

next description once a 

measurement has been 

completed.  
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Tools.  The following 

options are available from 

the Tools menu: 

Save Image As.  Select the 

Save Image As option to 

save the current image as a 

variety of file types (JPEG, 

BMP, GIF or PNG). 

Copy Image to Clipboard. 

Select the Copy Image to 

Clipboard option to copy the 

current selected image to the 

clipboard so that the image 

can be pasted directly to 

other applications such as 

MS Word, E-mail, etc. 

Copy Viewport to 

Clipboard. Select the Copy 

Viewport to Clipboard 

option to copy the selected 

image as it is currently 

displayed to the clipboard.   

The copied image can then 

be pasted directly to other 

applications such as MS 

Word, E-mail, etc.  

Set Default Target Type. 

Select the Set Default 

Target Type option to select 

the Calibrated Visual Target 

(CVT) that was used in 

order to get accurate 

measurements. 

Change Current Image’s 

Target Type. Select the 

Change Current Image’s 

Target Type option to 

change the currently 

selected (displayed) images 

target type. 

Display EXIF Information.  

Select the Display EXIF 

Information option to 

display the metadata in the 

image. 
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View.  The following 

options are available from 

the View menu: 

Magnifier. Click the Mag 

option to show or hide the 

magnification window.  

With the magnification 

window displayed, move the 

mouse anywhere in the 

image to view that area in 

the magnification window.   

X Magnification. Select the 

magnification level to use 

with the Magnification 

Window. 

Smooth. Click the Smooth 

option to smooth hard edges 

of the image. 

Reset. Click the Reset 

option to undo any 

display/enhancement 

options that were selected.   

Show Label Background.  

Select the Show Label 

Background option to 

outline and enhance the 

label backgrounds. 

 
Zoom to Fit. Click the 

Zoom to Fit option to reset 

the image to its original 

size. 

 
Bright. Click the Bright 

option to brighten the 

image. 

 
Dim. Click the Dim option 

to darken the image. 

 
Invert. Click the Invert 

option to invert the colors of 

the image. 

 
Grayscale. Click the 

Grayscale option to set the 

image to black and white. 
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Contr + Click the Contr + 

option to set the contrast 

higher.   

Increasing the contrast will 

make dark tones darker and 

the light tones brighter.  

Using the Contrast option 

also affects the sharpness of 

the image. 

 
Contr - Click the Contr – 

option to set the contrast 

lower. 

 

Rotate.  Select the Rotate 

option to rotate the image 

90 degrees to the right or 

left. 

 

The DMT tool also provides several ways to navigate within the 

image by providing the following tools: 

Mouse Wheel You can use the mouse wheel to interact 

with the image.  To zoom in or out 

scroll the mouse wheel forwards or 

backwards.   To pan, click the mouse 

wheel down and drag the image to shift 

the location of the image.  

Associated Images All images that are associated or related 

to the selected feature are displayed as 

thumbnails on the upper right side of the 

Image View window.  Select a 

thumbnail to change which images 

measurements are going to be 

completed on. 

Navigation Pane Clicking a point in the Navigation Pane 

will center the image on that point in the 

Image View Window. 

Scale Tool   

Click different levels on the scale to 

zoom-in or zoom-out to see more details 

in an image. 
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Measure Mode Selector 

 

Click a Measure Mode to activate the 

measurement tool for the selected mode.  

Only task of the selected type will be 

available to measure.  Note the Image 

must be Calibrated before the Measure 

Mode tools are available.  

 

Setting the Calibration  

When an image, .odmt file or a .pplx file is initially opened the 

Calibration Mode is selected by default.  The Calibration 

measurement needs to be completed once on each image before any 

other measurements are taken on that image.  To complete the 

Calibration measurement, complete the following steps:  

1. Select the image you will use to set the Calibration. 

Note: When setting the calibration the cursor will change to a 

measurement sight   enabling you to get a precise measurement. 

2. The Calibration Mode requires 3 – 4 measurements, based on 

the target type.  Place the measurement sight where the first 

calibration point is and click the left mouse button.  A red plus 

sign  marks your first calibration measurement. 

3. Using the measurement sight set the remaining calibration point 

locations.  

 

Once all the Calibration measurements are completed the next 

mode will automatically be selected.  At this point you can select 

any of the available modes to complete measurements on. 
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Note:  If you need to redo the calibration measurements after they have 

been set, select the Calibration Mode and complete steps 2 and 3 as 

directed above.  At this time there is no cancel or undo options for the 

Calibration Mode.    

Note:  If you change the Calibration measurement any measurements 

you have completed need to be redone.   

Overview of the Measurements Mode Selector 

To complete measurements you will need to select the corresponding 

Mode.   Each Mode uses a different visual tool to help you complete 

the measurements.   

Mode Selected Visual Tool 

Calibrate Calibrate.  Click the Calibrate Mode and 

the cursor will change to a measurement 

sight  for an accurate measurement.  

Height Mode Height Mode. Click the Height Mode and 

the cursor will change to crosshairs  for 

an accurate measurement of height relative 

to groundline. 

Arbitrary (Arbitrary 

Length) Mode 

Arbitrary Mode. Click the Arbitrary Mode 

and the cursor will change to crosshairs   

for an accurate measurement between two 

points in the plane of the target.  

Cond Dia 

(Conductor 

Diameter) Mode 

Cond Dia Mode. Click the Cond Dia Mode 

and draw a line to accurately determine the 

conductor size.  

Angle Mode Angle Mode. Click the Angle Mode and the 

cursor will change to crosshairs  to 

accurately calculate angles.   

Height Mode Measurements  

The height is relative to the groundline of the pole.  To complete a 

Height measurement, complete the following steps:  

1. Select the Height Mode. 

 

2. From the Label Description list select the Height Task you 

would like the measurement associated with. 
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3. Place the crosshairs at the point you want the Height 

measurement to be taken at.   

4. The Height measurement is automatically displayed. 

Note: If you need to retake the measurement after it has been set, 

completed steps 1 thru 3 as directed above.    

Arbitrary Mode Measurements  

To complete an Arbitrary measurement between two points in the 

plane of the target, complete the following steps:  

1. Select the Arbitrary Mode. 

 

2. From the Label Description list select the Arbitrary Task you 

would like the measurement associated with. 

3. Place the crosshairs at the point you want the Arbitrary 

measurement to start. 

4. Hold down the left mouse button and draw a line to where the 

Arbitrary measurement ends. 

5. The Arbitrary measurement is automatically displayed. 

Note:  If you need to retake the measurement after it has been set, 

completed steps 1 thru 4 as directed above. 

Cond Dia Mode Measurements  

The Cond Dia (Conductor Diameter) is used to collect wire sizes.  To 

complete a Conductor Diameter measurement, complete the 

following steps:  

1. Select the equipment in the Inventory Window that you want to 

measure the diameter of. 

2. Select the Cond Dia Mode. 

 

3. From the Label Description list select the Conductor Diameter 

Task you would like the measurement associated with. 

4. Place the cursor on the middle of the Conductor whose diameter 

you want to measure. 
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5. Hold down the left mouse button and drag along the conductor 

until the yellow line is the same width as the conductor then 

release the mouse button. 

6. The Conductor Diameter measurement is automatically 

displayed. 

Note: If you need to retake the measurement after it has been set, completed 

steps 1 thru 5 as directed above.  

Angle Mode Measurements  

To assist you in measuring an Angle, complete the following steps:  

1. Select the Angle Mode. 

 

2. From the Label Description list select the Angle Task you would 

like the measurement associated with. 

3. Place the crosshairs at the point you want the Angle 

measurement to start. 

Note:  The Angle measurement is a three point process.  After the 

Angle measurement is complete the Angel measurement is displayed for 

reference purposes only. 

4. Click the left mouse button and draw your first line, click the left 

mouse button again and draw your second line. 

 

5. The Angle measurement is automatically displayed. 

Note: If you need to retake the measurement, completed steps 1 thru 5 

as directed above 
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Working with the Image Split Merge  

To use the Split Image Merge application, complete the following steps:  

1. Open the O-Calc Pro Bin directory and double click the 

ImageSplitMergePPLX.exe. 

 

 

Image Split Merge Tab Description 

Split / Move Images tab The Split / Move Images option 

will un-embed all images in .pplx 

files. 

Merge Images tab The Merge Images option will 

embed images into .pplx files. 

Check Images tab The Check Images option will 

check all .pplx files in a specified 

location to verify image links are 

adequate.  

Split / Move Images 

To embed remove images from all PPLX files within a certain 

location, complete the following steps:  

Note:  This option would be used to limit the size of the PPLX files.  

If PPLX files are delivered with embedded images this tool will 

allow you to un-embed those images (images will still be displayed 

in the PPLX file but will no longer be embedded). 

1. Select the Split / Move Images tab. 
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2. Select the browse button   and browse to the location of the 

original PPLX files. 

3. Check if you would like subfolders included. 

4. Select the browse button   and browse to the location of the 

destination PPLX folder. 

5. Select the browse button   and browse to the location of the 

destination image folder. 

6. Select the Split / Move PPLX Files button. 

7. Select OK to the confirmation message. 

Merge Images 

To embed images into PPLX files, complete the following steps:  

1. Select the Merge Images tab. 

 

1. Select the browse button   and browse to the location of the 

original PPLX files.  

2. Check if you would like subfolders included. 

3. Select the browse button   and browse to the location of the 

original PPLX files. 

4. Select the Merge PPLX Files button.  

A confirmation message will display if all the image links are 

good, select OK to the confirmation message. 
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Check Images 

To verify the image links for a group of PPLX files, complete the 

following steps:  

1. Select the Check Images tab. 

 

2. Select the browse button   and browse to the location of the 

PPLX file to be verified.  

3. Check if you would like subfolders included in the verification. 

4. Select the Check PPLX Files button.  

A confirmation message will display if all the image links are 

good, select OK to the confirmation message. 

If there are any missing PPLX links, Notepad will 

automatically open with a list of all the missing PPLX links. 

Working with the Pole Browser 

To Pole Browser application allows you to easily browse through all your 

.pplx files. It will display each structures capacity level, basic structure 

information and displays all images attached to the structure. 

1. Open the O-Calc Pro Bin directory and double click the 

OCalcPoleBrowser.exe.  

 

 

 

 

2. Select the Browse button  and browse to the location of the .pplx 

files you would like to browse. 

3. Use the up/down arrows to set the threshold for the % of Capacity.  

.pplx path 
% of capacity 
threshold 
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The following table describes the default color representation for the 

Pole Capacity. 

Display Color Description 

Green Acceptable Capacity 

Yellow  Near Capacity 

Red At or Over Capacity 

4. Double click on the structure you would like loaded in the Inventory 

Window.  

Working With the Sag Tension Calculator 

The Sag Tension Calculator is a visual tool used to alter the sag tension 

calculations for references purposes only.  Complete the following steps to 

use the Sag Tension Calculator:  

1. Open the O-Calc Pro Bin directory and double click the 

SpanTensionSagCalculator.exe. 

2. The Span Tension Sag Calculator opens with default settings 

automatically loaded. 

 

 

 

 

 

 

 

 

Bolded directories 
have image files in 
the.  
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Sag Tension Calculator Options 

 

The Sag Tension Calculator provides you with a variety of 

operations and options. 

 

File. The following options are 

available from the File menu: 

New. Select New to create a new 

span tension sag calculation. 

Open. Select Open to open and 

existing span tension sag 

calculation file. 

Save.  Select the Save option to 

save any changes or additions. 

Save As.  Select Save As to save 

the current calculations under a 

different name, format or location. 

Exit.  Select the Exit option to 

close the Sag Tension Calculator 

Mode to apply 
calculation to  

Initial Sag Measurement Status Bar 

Chart Auto Scaled 
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View. The following options are 

available from the View menu: 

Options.  

English Units. Select the English 

Units option to change the unit 

convention to English. 

Metric Units.  Select the Metric 

Units option to change the unit 

convention to Metric. 

Flat Visual Style. Select the Flat 

Visual Style to display the 

interface in a flat visual style. 

Reports. Select Open to open and 

existing span tension sag 

calculation file. 

Report. Select the Report option to 

display the Span Tension Sag 

Calculation in report format.  

Export to CSV. Select the Export 

to CSV option to export the Span 

Tension Sag Calculations to a 

.CSV file. 

 

3. Complete your attribute modifications. 

4. Enter the Initial Sag measurement. 

Working With the Shape File Viewer   

The Shape File Viewer allows you to work with shape files and a number of 

PPLX files to give a geospatial view of the pole models. 

Additional instructions can be obtained from the following instructional 

video: 

https://www.youtube.com/watch?v=Pn5cmVS8KwE 

To open the Shape File Viewer application, complete the following steps: 

1. Open the O-Calc Pro Bin directory and double click the 

ShapeFileViewer.exe.  

 

 

 

https://www.youtube.com/watch?v=Pn5cmVS8KwE
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Toolbar Menu Options 

The toolbar menu provides you with a variety of operations and 

options. 

 

 

File.  The following options 

are available from the File 

menu: 

New Project.  Select the 

New Project option to start a 

new project. 

Open Project.  Select the 

Open Project option to open 

Easy GIS Project File. 

Save Project.  Select the 

Save Project option to save 

the current project. 

Save Project As.  Select the 

Select Project As to save the 

current project under a 

different name. 

Add Shape File.  Select the 

Add Shape File option to 

open a shape file. 

Save Map Image.  Select the 

Save Map Image to save the 

currently displayed map 

image. 

Landbase Layer 
Display 

Description of 
Selected Landbase 

Layer 

Map 
Display 

Toolbar 

Shapefile Tab 
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Print Map.  Select the Print 

Map option to print the 

currently displayed map 

image. 

 

View.  The following 

options are available from 

the View menu: 

Hide Layer List.  Select the 

Hide Layer List option to 

hide the landbase layer list 

and the landbase layer 

description.  The map will 

automatically resize.  

Note: The Hide Layer List 

option will change to Show 

Layer List when selected.  

Zoom to Fit.  Select the 

Zoom to Fit option to revert 

the map display back to 

default setting zoom level.  

 

Poles.  The following 

options are available from 

the Poles menu: 

Show Poles.  Select the 

Show Poles option to load 

the poles in the map. 

Clear Poles.  Select the 

Clear Poles option to remove 

the poles from the map. 

 

Options.  The following 

options are available from 

the Option menu: 

Map Background Color.  

Select the Map Background 

Color option to change the 

map background color.  

Mercator Projection.  Select 

the Mercator Projection 

option to change the 

projection of the map. 

Render Quality.  Select the 

Render Quality option to set 

the rendering quality of the 

map. 
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Use Native File Mapping.  

Select this option so that the 

shape file is displayed based 

in its native coordinate 

system, otherwise it will be 

translated based on a 

corresponding projection 

file. 

Display Shape Attributes 

Window.  Select the Display 

Shape Attributes Window 

option to display the share 

attributes window. 

View Attribute List.  Select 

the View Attribute List 

option to view the attribute 

list. 

 

2. Select File>New Project.  

3. Select File>Add Shape File, browse to the location of your shape file(s) 

and select the shape file you would like loaded. 

4. Select Poles>Show Poles, browse to the location of the .PPLX files you 

would like displayed on the map.  

 


