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Osmose O-Calc® Pro Overview 
 

 About Osmose O-Calc® Pro 

Osmose O-Calc® Pro automates the calculation of structural loading on new 

and existing utility poles.  Major applications of this innovative software are 

line design, pole replacement, and joint-use loading issues. 

In many cases, non-structural personnel at a utility have to decide whether 

more cables can be added or larger conductors can be used on existing pole 

lines.  O-Calc® Pro was developed to help technical and non-technical staff 

alike perform structural load analysis in a simple, straightforward manner.  

The calculations within O-Calc® Pro are complex, but the operator interface 

is designed for simplicity of use.  In addition to technical load calculations 

and statistics, the application provides a configurable, three-dimensional 

visual rendering of each structure’s load conditions.  

O-Calc® Pro can be used to evaluate whether any structure within a line are 

already overloaded.  It can quickly assess the impact of re-conductoring for 

upgrading line performance.  The O-Calc® Pro analysis of stress along the 

length of a pole can be used to consider cost-effective alternatives to 

replacing overloaded poles.   

O-Calc® Pro is a valuable resource in evaluating structural load for joint use, 

safety, network reliability, and network planning purposes.  

 Osmose O-Calc® Pro Concepts 

Osmose O-Calc® Pro allows you to model a utility structure (wood, steel, 

concrete pole, or multi-pole structure) by defining the components of the 

structure using the Inventory Window or interactively constructing the 

structure through the 3D View.  Both methods can be used simultaneously.  

The model of the structure is created by adding equipment you manually 

define or by utilizing predefined components from the Master or User 

Catalogs. 

The various Master Catalogs are installed with the O-Calc® Pro application 

and each contains a predefined compiled list of common poles, structures, 

and/or equipment that are utilized in the field.  Master Catalogs also contain 

a complete listing of all the available Load Cases.  The User Catalogs are a 

series of folders in which you can compile your own list of poles or 

equipment that you’ve created.  You can then use the data in the User 

Catalog to build additional structures in the Inventory Window.  The Catalog 

Window within the O-Calc® Pro interface provides you with the tools to 

manage and interact with the catalogs. 
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Understanding the O-Calc® Pro Workspace 
 

O-Calc® Pro Workspace 

O-Calc® Pro provides you with a variety of options enabling you to interact 

with new data or existing data. 

                   

 

 

Workspace Windows Description 

Toolbar Toolbar.  Provides numerous options to 

interact with the data in O-Calc® Pro. 

Selected LoadCase Selected LoadCase. Displays the 

LoadCases that are currently loaded in the 

Inventory Window. 

Display Layouts Display Layouts.  Enables you to swiftly 

switch between different window layouts. 

Top View Display Top View Display.  Displays a top view of 

the structure with span angels. 

Quick Search Quick Search.  Allows you to easily find 

and execute menu items. 

Schematic Display 

 

Schematic Display.  Displays the major 

equipment on the structure and the 

elevation. 

Capacity Display Capacity Display.  Summarizes the 

structure’s capacity as currently loaded. 
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HeatMap Display HeatMap.  Provides a colored two-

dimensional representation of specific load 

values for the current structure. 

Data Entry Display Data Entry Display.  Allows you to enter 

or change equipment attributes. 

Status Bar Status Bar. Display the path to the 

currently loaded PPLX file, the Capacity 

Summary Window calculation status and 

the user’s access level. 

Structure Type Structure Type. Display the currently set 

structure type. 
 

 

Default Tab Windows Description 

Catalogs Catalogs.  Repository of equipment and 

assemblies available to construct inventory. 

The catalogs are the primary way to build 

inventory. 

Inventory Display Inventory Display.  Displays the inventory 

of the structure as you construct it. 

3D View 3D View.  Displays a 3D view of the 

structure and the surroundings. 

Measure (Digital 

Measurement Technology 

(DMT)) 

Measure.  Allows the measurement of pole 

features from image data. 

Charts Charts.  Displays a predefined list of charts 

that can be used to help you complete a 

structure’s analysis. 

Reports Display 
 

Reports.  Displays a list of reports that can 

be used to help you complete a structure’s 

analysis. 
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O-Calc® Display Options 
 

Utilizing O-Calc® Pro Display Options  

Several advanced displays options and tools are provided within the O-Calc® 

Pro applications. 

Changing the Theme 

The View tool bar menu provides you with an ability to change the theme of 

your O-Calc® Pro display.  

1. On the main Toolbar, select View 

2. Hover the mouse over the Theme options to view possible choices 

3. Select either Light, Dark, Blue or Legacy. 

4. Restart the application for the changes to take effect.  

 

General Display Options  

The Options tool bar menu provides you with a variety of display options.  

 

 



Osmose O-Calc® Pro 5.3                                    Confidential User’s Guide 

16                  ©2018 Osmose Utilities Services, Inc. 

Capacity Display Auto Capacity Summary.  Select the 

Auto Capacity Summary option to 

automatically update the Capacity Window 

whenever data changes. 

Capacity Meter Display.  Select the 

Capacity Meter Display option to have the 

Capacity Window display in a metered 

format. 

Capacity Numeric Display.  Select the 

Capacity Numeric Display option to have 

the Capacity Window display in a numeric 

format. 

Factor of Safety Display. Select the factor 

of Safety Display option to have the 

Capacity Window display the Factor of 

Safety Values and active loadcase. 

Visualization Color 

Scheme 

Visualization Color Scheme.  Select the 

Visualization Color Scheme option to 

change the color representation throughout 

the application. 
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Info Tips and Data Inventory Info Tips.  Select the Inventory 

Info Tips option to see a subset of an 

object’s attributes when you hover over the 

object’s icon in the Inventory Window. 

Component Load Info Tips.  Select the 

Component Load Info Tips option to 

display what the percent of pole capacity 

that is consumed by the object components 

on the pole.  The tip will display as you 

hover over an object in the Inventory 

Window. 

Catalog Info Tips.  Select the Catalog 

Info Tips option to see an object’s 

attributes when you hover over the objects 

icon in the Catalog Window. 

Heat Map Segment Tips Enabled.  

Select the Heat Map Segment Tips 

Enabled option to see a subset of an 

object’s attributes.  The tip will display as 

you hover over an object in the HeatMap 

Window. 

Heat Map Moment and Load Details. 

Select the Heat Map Moment and Load 

Details option to display the full loading 

details for each element in the Heat map 

when the courser is hovered over the 

element. 

Show All Attributes in Info Tips. Select 

the Show All Attributes in Info Tips option 

to see an object’s editable attributes when 

you hover over the object’s icon in the 

Inventory Window. 

Expand All Attributes in Data Entry 

Panel.  Select the Expand All Attributes in 

Data Entry Panel option to display all of an 

object’s attributes in the Data Entry Panel 

Remember Attribute Filter Settings in 

DEP. Select the Remember Attribute Filter 

Settings option to always use the last filter 

selected in the Data Entry Panel, when 

selecting another object. 

Show TBD Item Status.  Select the Show 

TBD Item Status option to indicate TBD 

items in the Inventory window. 
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Options in 3D View Options in 3D View.  See 3D View 

Display Options. 

Units Convention Units Convention. See Change the Unit 

Convention. 

Backward Compatibility 

Mode 

Backward Compatibility Mode. Select 

the Backward Compatibility Mode option 

to save PPLX files in a format from a 

previous version of O-Calc® Pro.  The 

Backward Compatibility Mode also allows 

a person using a newer version of O-Calc® 

Pro to create a PPLX that can be 

conveniently used by a user of an older 

version of O-Calc® Pro. 

Enable / Disable Prompts Enable / Disable Prompts.  The Enable / 

Disable Prompts menu lists various 

prompts throughout the application that 

can be enabled or disabled. 

Manage Available Reports Manage Available Reports.  Select the 

Manage Available Reports option to 

enable or disable various reports on a user-

by-user basis. 

Misc Options Misc Options.  Select Misc Options to 

enable or disable several display options.  

Manage Plugins Manage Plugins.  Select the Manage 

Plugins option to enable or disable various 

plugins on a user-by-user basis.  See 

Manage Plugins. 
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Working Within the O-Calc® Pro Workspace 
 

Working with the Inventory Window  

Inventory Window Overview  

The Inventory Window provides you with the ability to construct a model of 

a utility pole. This model includes the structure, the equipment attached and 

its environment.  

Toolbar Menu Options  

The Inventory Window toolbar provides you with a variety of options. 

 

Filter Filter. Select the Filter option to only display the 

expanded inventory objects in the 3D View. 

Sort Sort.  Select the Sort option to sort the inventory object 

to match how they display on the pole from the pole tip 

to the ground. 

Query Query. Select the Query option to search the data within 

the Inventory Window. 

Edit Edit. Select the Edit option to edit the selected 

equipment attributes. 

Delete  Delete. Select the Delete option to delete the selected 

equipment.  Multiple pieces of equipment that have been 

selected can be deleted simultaneously. 

Shortcut Key: Select the Delete button on the keyboard. 

Add  Add. Select the Add option to add attachments to the 

selected equipment. 

Shortcut Key: Select the Insert button on the keyboard. 

Expand Expand. Select the Expand option to expand all the 

nodes in the Inventory tree. 

Collapse Collapse. Select the Collapse option to collapse all the 

nodes in the Inventory tree. 

Substitute  Substitute. Select the Substitute option to substitute the 

selected equipment.  Multiple pieces of equipment of the 

same type that have been selected can be substituted 

simultaneously. 

Shortcut Key: Select Alt + Insert on the keyboard. 
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Insul 

Rotation 

Insulator Rotation.  Select the Insul Rtn option to rotate 

an insulator to the appropriate angle for attached span 

angles. 

Set Owners Set Owners. Select the Set Owners option to set an 

insulator’s owner value when all spans have the same 

owner value. 

 

Note: To enable/disable the text that displays next to the Inventory Window toolbar, 

see Change the Inventory Window Toolbar Display. 

Note: When using the keyboard shortcut keys for Delete, Add and Substitute the 

Edit>Undo option can be used to undo any changes that have been made using these 

shortcut keys. 

Creating a Single Pole Structure 

Creating a Single Pole 

To create a new Wood, Steel, Concrete or Composite pole in the Inventory 

Window, complete the following steps: 

1. Select the structure type from the File>New Pole menu. 

  

Available single pole 
structure types 
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Note: Available tabs are dependent on corresponding structure types displayed 

in your catalogs. 

Master Catalog The Master Catalog tab displays 

a list of folders in the master 

catalog(s) that have selectable 

structure types that coincide with 

the new pole type you selected. 

User Catalog The User Catalog tab displays a 

list of folders in the user 

catalog(s) that have selectable 

structure types that coincide with 

the new pole type you selected. 

Attr Values The Attr Values tab displays an 

editable list of all the attribute 

values for the selected poles. 

Standards The Standards tab provides a 

quick way to manually select the 

species, length, and class of the 

pole you would like loaded in O-

Calc Pro based on the ANSI 05.1 

Standards. 

 

2. Select a pole from the Master Catalog, User Catalog or the Standards tab.  

Note: For additional information on catalogs see Working With the Catalog 

Window. 

3. Select the Attr Values tab to modify the selected poles attribute values. 
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4. Click OK. 

Note: Undo is not available when a pole is added 

 

Note:  If a default LoadCase has been set it displays automatically in the 

Inventory Window when the pole is created. To set a Default LoadCase see Set a 

Default Load Case.   

Setting the Depth of a Pole 

To set the depth of a pole, complete the following steps: 

1. Right click on the Pole you want to set the depth for. 

2. Select the Setting Depth of (Pole display name). 

 

3. Select the Mode from the drop-down list and enter the Depth in Feet. 

 

Note: The Depth in Feet field will automatically display the default pole depth 

when initially opened. The Mode moves either the pole and all its attachments to 

the new set depth or just the pole keeping the attachments at the same height 

above groundline. 

4. Select OK. 

Setting the Above Ground Length of a Pole 

To set the length of a pole, complete the following steps: 

1. Right click on the Pole you want to set the length for. 

2. Select the Length of (Pole display name). 
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3. Select the Mode from the drop-down list and enter the AGL in Feet. 

 

4. Select OK. 

Note: To undo the Setting Depth change, select Edit>Undo. Setting the Above 

Ground Length is the complimentary function to the Setting Depth. 

Setting the Length of a Pole 

To set the length of a pole, complete the following steps: 

1. Right click on the Pole you want to set the length for. 

2. Select the Length of (Pole display name). 
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3. Select the Mode from the drop-down list and enter the Length in Feet. 

  

Note: Changing the Length is typically for shorting the length because it has 

been stubbed in the field.  Note that the length attribute of the pole changes, but 

not the manufactured length so that other parameters of the pole, such as the 

circumference and taper remain unchanged. . 

 

Creating Additional Structure Types 

Creating Additional Structure Types 

To create a new Multi-Pole structure in the Inventory Window, complete the 

following steps: 

1. Select the structure type from the File>New Pole>Multi-Pole Structure. 

 

 

 

Note: If a default LoadCase has been set it displays automatically in the 

Inventory Window when the structure is created. To set a Default LoadCase see 

Set a Default Load Case. 

2. Select the Structure in the Inventory window then select the Add button 

 and select the pole you would like to add to the multi-pole 

structure.  

Structure 
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Note:  The list of available poles can also be accessed by right clicking on the 

multi-pole structure in the Inventory Window. 

 

 

Note: Available tabs are dependent on corresponding structure types displayed 

in your catalogs. 

3. Select a pole from the Master Catalog, User Catalog or the Standards tab. 

Note: For additional information on catalogs see Working With the Catalog 

Window. 

4. Select the Attr Values tab to modify the selected poles attribute values. 

5. Select OK. 

Note:  Complete step 2- 5 to add additional poles to the structure. 

Note: Undo is not available when a pole is added. 

6. Select a pole and modify the Offset value in the Data Entry Panel. 

 Available Poles 
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Note: For additional information on changing attributes in the Data Entry panel 

see Working With the Data Entry Window. 

Adding Attachments to a Structure 

Adding Equipment to a Pole 

To add equipment to a pole, complete the following steps: 

1. Select the Pole you want to add equipment to. 

 

2. Select the Add button  and select the equipment or elements to be 

added to the pole. 

Note: If the Divide Add Menu Items by Category option is unchecked in Misc 

Options, the resulting menu items appear as shown below. 

 

Note:  The list of available equipment can also be accessed by right clicking on 

the pole in the Inventory Window. See menu options instructions below. 

 

Note: If the Divide Add Menu Items by Category option is checked in Misc 

Options, the resulting menu items appear by category as shown below. 
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Note: Only one piece of equipment can be added at a time. 

 

Note:  Available tabs are dependent on corresponding equipment displayed in 

your catalogs or Inventory Window. 

3. To add a crossarm from the Catalog tabs or the Inventory tab select the 

appropriate tab and select the crossarm you want to add. 

Note: For additional information on catalogs see Working With the Catalog 

Window.  

4. Select the Attribute Values tab to modify the crossarm’s attribute 

values. 

5. Click OK. 

Note: To undo additions, select Edit>Undo. 
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Different types of equipment can have additional attachments (Example:  

A crossarm can have insulators attached to it).  To add additional 

attachments to equipment, complete the following steps: 

6. Select the equipment in the Inventory Window you want to add 

additional equipment to. 

7. Select the Add button  and select the equipment to be added from 

the equipment list. 

Note:  The list of available equipment can also be accessed by right clicking on 

the equipment you would like to add additional equipment to.   

 

Note: If multiple pieces of equipment are displayed in the list only one piece of 

equipment can be selected at a time. 

 

Note:  Available tabs are dependent on corresponding equipment displayed in 

your catalogs or Inventory Window. 

8. To add an insulator from one of the catalog tabs or the Inventory tab 

select the appropriate tab and select the insulator you want to add. 

Note: For additional information on catalogs see Working With the Catalog 

Window. 
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9. Select the Attribute Values tab to modify the insulator’s attribute 

values. 

10. Select OK. 

 

Note: To add additional attachments complete steps 6 – 10. 

Adding a Span Bundle to a Pole 

A span bundle is a composite span that typically includes a messenger strand 

with other spans lashed to it plus the cross-sectional configuration of the 

lashing.  The SpanBundle object represents the messenger strand.  To add a 

span bundle to an attached insulator you first need to create the span 

messenger wire.  To create the span messenger wire, complete the following 

steps: 

1. Select the insulator in the Inventory Window that you want to add a 

span bundle to. 

 

2. Select the Add button  and select the SpanBundle. 

Note: The Span Bundle option can also be accessed by right clicking on the 

Insulator in the Inventory Window.  

  

Note:  Only one Span Bundle can be added at a time.  
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Note:  Available tabs are dependent on corresponding Span Bundles displayed 

in your catalogs or Inventory Window. 

3. To add a Span Bundle from one of the Catalog tabs or the Inventory tab 

select the appropriate tab and select the Span Bundle you want to add. 

Note: For additional information on catalogs see Working With the Catalog 

Window. 

4. Select the Attribute Values tab to modify the Span Bundle attributes. 

5. Select OK 

Note: To undo additions, select Edit>Undo. 

Once the span bundle messenger wire has been created you need to add 

the spans.  Complete the following steps to add spans to the messenger 

wire: 

6. Select the Span Bundle in the Inventory Window. 

 

7. Select the Add button  and select Span. 

Note: The option to add spans can also be accessed by right clicking on the 

Span Bundle in the Inventory Window. 
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Note: Only one Span can be added at a time. 

  

Note: Available tabs are dependent on corresponding spans displayed in your 

catalogs and Inventory window. 

8. To add an insulator from the catalog tabs or the Inventory tab select the 

appropriate tab and select the insulator you want to add. 

Note: For additional information on the Catalog Window see Working With the 

Catalog Window. 

9. Select the Attribute Values Tab to modify the Span attributes. 

10. Select OK. 

Note:  To add additional spans to the span bundle complete steps 5 – 8. 

Note:  To undo additions, select Edit>Undo. 

Working with the Span Bundle Editor 

Use the Span Bundle Editor to quickly and efficiently edit the spans positions 

or add additional spans to a span bundle.  To open the Span Bundle Editor, 

complete the following steps: 

1. Right click on the Span Messenger wire you want to edit. 

2. Select Bundle Editor for (bundle display name). 



Osmose O-Calc® Pro 5.3                      Confidential                                                           User’s Guide 

©2018 Osmose Utilities Services, Inc.                                                                                                  33 

 

 

Span Bundle Editor Toolbar Options 

 

The Span Bundle Editor toolbar menu provides you with a variety of 

operations and options. 

 

 

File. The following options 

are available from the File 

menu: 

Reset View. Select the 

Reset View option to set the 

Span Bundle editor back to 

the default view. 

Save.  Select the Save 

option to save any changes 

or additions. This is a test  

Exit. Select the Exit option 

to close the Span Bundle 

Editor. 
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Edit. The following options 

are available from the Edit 

menu: 

Add Span.  Select the Add 

Span option to add a span to 

the span bundle. 

Layout Vertical. Select the 

Layout Vertical option to 

automatically reposition all 

the spans vertically under 

the messenger wire. 

Layout Pack Under. Select 

the Layout Pack Under 

option to automatically 

reposition all the spans 

under the messenger wire. 

Layout Pack Around. 

Select the Layout Pack 

Around option to 

automatically reposition all 

the spans around the 

messenger wire. 

Auto Pack. Select the Auto 

Pack option to have the 

spans packed as close as 

possible given their size and 

layout. 

Un-Collide.  Select the Un-

Collide option to position 

the spans so they are not 

overlaid. 

Dynamic Un-Collide.  

Select the Dynamic Un-

Collide option to 

automatically un-collide the 

spans while you’re dragging 

them into position. 

 
Circumscribe. Selecting 

the Circumscribe option 

tells you what the minimum 

circle would be that all the 

spans and messenger wire 

could fit into. 
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Show Labels. Select the 

Show Labels option to 

display the spans 

descriptions next to each 

span in the bundle. 

Adding a Span to a Span Bundle 

To add a span to the Span Bundle using the Span Bundle Editor, 

complete the following steps: 

1. Select Edit>Add Span. 

 

Note: Only one span can be added at a time. 

  

Note: Available tabs are dependent on corresponding spans displayed 

in your catalogs or Inventory Window. 

2. To add a span from the catalog tab or the Inventory tab select 

the appropriate tab and select the span you want to add. 

Note: For additional information on the Catalog Window see Working 

With the Catalog Window. 
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3. Select the Attribute Values tab to modify the Span attributes. 

4. Select OK. 

Note: The span is automatically add to the span bundle and is 

displayed in the Span Bundle Editor. 

Note: There is no Undo option available.  Select File>Exit to close the 

Span Bundle Editor without saving any modifications that have been 

completed.  

5. Select File>Save. 

Repositioning Spans in the Span Bundle 

The Span Bundle Editor offers three ways you can reposition spans 

within the editor.  To reposition span(s) in the span bundle using the 

Span Bundle Editor, use one of the following options: 

1. Select Edit and select a layout option from the Edit menu. 

2. Left click a span in the Span Bundle Display window and drag 

the span to a new location. 

3. Manually enter a horizontal and/or vertical value for a 

specific span in the Span Detail Table. 

Editing Spans in the Span Bundle 

To edit span attributes from within the Span Bundle Editor, complete 

the following steps: 

1. Right click on the span in the Span Bundle Display window. 

2. Select Edit Span from the drop down menu. 

 

3. Complete any modification to the Span Bundle attributes. 

 

4. Select OK. 

Note: There is no Undo option available.  Select File>Exit to close the 

Span Bundle Editor without saving any modifications that have been 

completed. 
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5. Select File>Save. 

Deleting Spans in the Span Bundle 

To delete a span within the Span Bundle Editor, complete the 

following steps: 

1. Right click on the span in the Span Bundle Display window. 

2. Select Delete Span from the drop-down menu. 

 

Select Yes to the confirmation message. 

Note: There is no Undo option available.  Select File>Exit to close the 

Span Bundle Editor without saving any modifications that have been 

completed. 

3. Select File>Save. 

Adding Damage and Decay to a Pole 

Poles that are not new may have damage or decay.  The 

WoodPoleDamageOrDecay object is utilized to reduce the overall strength 

of the pole based on any damage or decay on the pole.  To add damage or 

decay to a pole, complete the following steps: 

1. Select the Pole you want to add damage or decay to. 

 

2. Select the Add button  and select WoodPoleDamageOrDecay. 

Note: The Wood Pole Damage or Decay option can also be accessed by right 

clicking on the pole in the Inventory Window. 

 

Note:  Only one piece of damage or decay can be added at a time. 
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Note: Available tabs are dependent on corresponding Wood Pole Damages or 

Decays displayed in your catalogs or Inventory Window. 

 

3. To add damages or decay from the Catalogs tabs or the Inventory tab 

select the appropriate tab and select the damages or decay you want to 

add. 

Note: For additional information on catalogs see Working With the Catalog 

Window. 

4. Select the Attribute Values tab to modify the damage or decay’s 

attributes. 

5. Select OK. 

Note: To undo additions, select Edit>Undo. 

 

 

Adding a Node Junction to a Multi-Pole Structures 

The Node Junction in an object that helps facilitates connecting Lattice 

Sections to either individual poles or crossarms.  To add a Node Junction to a 

multi-pole structure in the Inventory Window, complete the following steps: 

1. Select the pole you want to add a Node Junction to. 
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2. Select the Add button  and select Node Junction. 

 

Note:  The Node Junction can also be accessed by right clicking on the pole in 

the Inventory Window. 

  

Note: Available tabs are dependent on corresponding node junction displayed in 

your catalogs or Inventory Window. 

3. To add a Node Junction from one of the Catalogs, select the appropriate 

tab and select the Node Junction you want to add.  

Note: For additional information on catalogs see Working With the Catalog 

Window. 

4. Select the Attribute Values tab to modify the Node Junction attribute 

values.  
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5. Select OK. 

Note: To add additional Node Junctions complete steps 1 – 5. 

 

Note: To undo additions, select Edit>Undo. 

Adding a Lattice Section to a Multi-Pole Structures 

To add a lattice section to a multi-pole structure in the Inventory Window, 

complete the following steps: 

1. Select the structure you want to add a Lattice Section to. 

 

2. Select the Add button  and select Lattice Section. 

 

Note:  The Lattice Section option can also be accessed by right clicking on the 

structure in the Inventory Window. 
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Note: Available tabs are dependent on corresponding Lattice Section(s) 

displayed in your catalogs. 

3. To add a Lattice Section from one of the Catalogs, select the appropriate 

tab and select the Lattice Section you want to add.  

Note: For additional information on catalogs see Working With the Catalog 

Window. 

4. Select the Attribute Values tab to modify the Lattice Section attribute 

values.  

5. Select OK. 

Note: To add additional Lattice Sections complete steps 1 – 5. 

 

Note: To undo additions, select Edit>Undo. 

Adding Material to a Lattice Section 

To add material to a lattice section in the Inventory Window, complete the 

following steps: 

1. Select the lattice section you want to add material to. 

2. Select the Add button  and select Material. 

 

Note:  Materials can also be added by right clicking on a lattice section in the 

Inventory Window. 
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Note: Available tabs are dependent on corresponding materials displayed in 

your catalogs. 

3. To add Material from one of the Catalogs, select the appropriate tab and 

select the Material you want to add.  

Note: For additional information on catalogs see Working With the Catalog 

Window. 

4. Select the Attribute Values tab to modify the Material’s attribute 

values.  

5. Select OK. 

Note: To add additional beams complete steps 1 – 5. 

 

Note: To undo additions, select Edit>Undo. 

Adding Beams to a Lattice Section 

To add beams to a lattice section in the Inventory Window, complete the 

following steps: 

1. Select the lattice section you want to add a beam to. 
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2. Select the Add button  and select Beam. 

 

Note:  Beams can also be added by right clicking on a lattice section in the 

Inventory Window. 

 

Note: Available tabs are dependent on corresponding beam displayed in your 

catalogs. 

3. To add a Beam from one of the Catalogs, select the appropriate tab and 

select the Beam you want to add.  

Note: For additional information on catalogs see Working With the Catalog 

Window. 

4. Select the Attribute Values tab to modify the Beam’s attribute values.  
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5. Select OK. 

Note: To add additional beams complete steps 1 – 5. 

 

Note: To undo additions, select Edit>Undo. 

Select Adding a Lattice Group to a Lattice Section 

To add a lattice group to a lattice section in the Inventory Window, complete 

the following steps: 

1. Select the lattice section you want to add a lattice group to. 

 

2. Select the Add button  and select Lattice Group. 

 

Note:  Lattice groups can also be added by right clicking on the lattice section 

in the Inventory Window. 
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Note: Available tabs are dependent on corresponding lattice groups displayed 

in your catalogs. 

3. To add a Lattice Group from one of the Catalogs, select the appropriate 

tab and select the Lattice Group you want to add.  

Note: For additional information on catalogs see Working With the Catalog 

Window. 

4. Select the Attribute Values tab to modify the Lattice Group’s attribute 

values.  

5. Select OK. 

Note: To add additional lattice groups complete steps 1 – 5. 

 

Note: To undo additions, select Edit>Undo. 

Adding Nodes to a Lattice Group 

To add node(s) to a lattice group in the Inventory Window, complete the 

following steps: 

1. Select the Lattice Group you want to add a Node to. 
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2. Select the Add button  and select Node. 

 

Note:  Nodes can also be added by right clicking on the lattice group in the 

Inventory Window. 

  

Note: Available tabs are dependent on corresponding nodes displayed in your 

catalogs. 

3. To add a Node from one of the Catalogs, select the appropriate tab and 

select the Node you want to add.  

Note: For additional information on catalogs see Working With the Catalog 

Window. 

4. Select the Attribute Values tab to modify the Node’s attribute values.  
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5. Select OK. 

Note: To add additional nodes complete steps 1 – 5. 

 

Note: To undo additions, select Edit>Undo. 

Editing Equipment Attributes 

To edit equipment attribute(s), complete the following steps: 

1. Select the equipment whose attribute you want to edit. 

 

2. Select the Edit button . 

Note:  The Edit option can also be accessed by right clicking on the equipment 

whose attributes need to be edited and selecting Edit (Pole or equipment 

display name). 
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Edit Icons Description 

 Allows you to select a value or extend 

the default list. 

 Allows you to change the vertical value 

based on mouse movement. 

 Allows you to increase or decrease the 

rotation value based on mouse 

movement. 

 Allows you to select a value from a 

predefined list. 

 Allows you to increase or decrease the 

value. 

 Allows you to toggle the value to Yes or 

No. 

 

Other Editable Icons that are available when different attachments are selected: 

Editable Icons Description 

 Allows you to change the horizontal 

value based on mouse movement. 

 Found within a Note attachment.  When 

selected a calendar option is enabled, 

allowing you to select a specific date for 

a selected attribute. 

 Found within a Note attachment.  When 

selected the selected Note is displayed 

in edit mode. 

 Allows you to select the color. 

 Allows you to open a table and change 

values within the table. 

(Example: When a pole’s Moment Cap 

attribute table icon is selected it 

provides a table allowing you to change 

the values of the Moment Capacity vs. 

Height) 

 

When entering data in the Data Entry Panel, there are several key words 

and calculation shortcuts that can be utilized. 
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DATA ENTRY SHORTCUTS DESCRIPTION 

UNITS 

FFF’II  

III” 

 

 

 

 

CTRL+U 

 

Unit Shortcuts: 

 

fff’ii allows you to enter values in feet and 

inches instead of decimal feet. 

(Example: Crossarm>Initial Height attribute 

enter 40’6) 

 

Ctrl+u enables a conversion tool that allows you 

to easily convert an input value. 

 
Enter an Input value, select the convert From, 

select the convert To and select OK. 

HEIGHTS 

TIP-NNN  (T-NNN) 

 

 

 

 

HAGL=NNN 

HA=NNN 
 

 

 

 

 

REF=+NNN 

REF =-NNN 

 

 

 

 

 

 

 

T@NNN 

 

C@NNN 

 

B@NNN 

Height Shortcuts: 

tip-nnn allows you to enter feet down from pole 

tip. 

(Example: tip-3 or t-3will place an object 3 feet 

down from the tip of the pole) 

 

hagl=nnn allows you to change the end drop 

and rise of a span based on the height above 

ground line at other pole. Entering ‘sag’ 

values as measured from height above 

ground line.  
(Example: hagl-38 or ha-38) 

 

ref=(+/-)nnn allows you to adjust ‘height of 

attachment’ of an object relative to another 

object by entering a height value.  

 

Must enter either a (+/-) sign before the 

number to move the object either above or 

below the reference object. 
 

t@nnn allows you to set the ‘height of 

attachment’ or ‘Install Height’ value to 

correspond to the top of an object.  

 
c@nnn allows you to set the ‘height of 

attachment’ or ‘Install Height’ value to 

correspond to the center point of an object. 

 

b@nnn allows you to set the ‘height of 

attachment’ or ‘Install Height’ value to 

correspond to the bottom of an object.  
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These shortcuts are useful for setting 

heights of equipment, like transformers, 

which are traditionally attached at the 

center point.  
 

ROTATIONS 

ABS=NNN° 

AB=NNN° 

 

 

ABS=~NNN° 

AB=~NNN° 

 

 

IND=NNN° 

 
 

REF=+NNN° 

REF=-NNN° 

Rotation Shortcuts: 

abs=nnn allows you to set absolute rotation 

(compass coordinates) to the entered value. 

(example: abs=90 or ab=90) 

 

abs=~nnn allows you to add 180 degrees to the 

entered value. 

(Example: abs=~90 or ab=~90) 

 

ind=nnn allows independent rotation of an 

object without effecting the real-world 

rotation of any attached objects. 

 

ref=(+/-)nnn allows you to adjust ‘rotation’ 

of an object relative to another object by 

entering a rotation value. 

 

Must enter either a (+/-) sign before the 

angle to rotate the object in a given 

direction from the reference origin angle. 
 

WIRES 

MOE= 

 

 

 

 

 

 

AWG=NNN 
 

Wire Shortcuts: 

moe= enables the Modulus of Elasticity 

Calculator.  The MOE value can be adjusted in 

the calculator and populated into the Data Entry 

panel. 
Note: For additional information on working with the 

Modulus of Elasticity Calculator, see Working with 

the Modulus of Elasticity Calculator. 

 

awg=nnn allows you to populate the standard 

diameter from the AWG Table. 

(Example: awg=10 will automatically populate 

the AWG Gauge 10 conductor diameter)  

CIRCUMFERENCES 

DIAM=NNN 

 

 

 

D=NNN 

 

 

RADIUS=NNN 

R=NNN 
 

Circumference Shortcuts: 

diam=nn allows you to enter the diameter which 

is then automatically be converted to 

circumference value. 

(Example: diam=12.5 or d=12.5 will 

automatically be converted to circumference 

value) 

 

 

radius=nnn allows you to enter the radius 

which is then automatically multiplied by 

two.  
(Example: radius=12.5 or r=12 ) 

EXPRESSIONS 

CTRL+E 

Expressions Shortcut: 
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 ctrl+e enables the Expression Evaluation which 

allows you to enter expression values and the 

results are automatically populated into the Data 

Entry panel. 

 
Enter the Expression and select OK. 

CALCULATOR 

CTRL+F 
 

Calculator Shortcut: 

ctrl+f enables the Calculator which allows you to 

enter calculations that are then automatically 

populated into the Data Entry panel. 

 
Enter a calculation and select OK 

 

3. Complete your edits to the equipment’s attributes.   

Note: Certain attributes are only editable in Administrative User Mode. 

4. Select OK. 

Note: To undo edits, select Edit>Undo. 

Editing the Reference Origin 

In the Edit tab are options to Set Origin Angle and Set Origin Elevation for 

an object on a pole: 

1. Select the object you want to use as the reference point and select the 

desired option; Set Origin Angle or Set Origin Elevation. 

 

2. Once selected, enter the value for the Reference Angle or Reference 

Height option. When entering the Reference Height value the specified 

value is displayed on the object in the 3-D screen. 
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3. Select Clear Reference Origin to clear the option and remove the value 

displayed on the object in the 3-D screen. 

Note: When using the Reference Height option the reference object is highlighted 

yellow. An orange marker is placed on the ground line compass in the 3-D view and 

the specified value is displayed on the screen for the corresponding Reference Angle. 

 

Note: When selecting the Reference Height, the value is also displayed in the 

Schematic window, as shown below. 
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Rotating Insulators to Match Span Angles 

To rotate an insulator to be appropriate for attached span angles, complete 

the following steps: 

1. Select the insulator you want to rotate. 

 

2. Select the Insulator Rotation button . 

The selected insulator is automatically rotated to the span angle. 

Note: The Rotate to Span Angle option can also be accessed by right clicking on 

the insulator to be rotated and selecting Rotate to Span Angle. 

Note: To undo the insulator rotation change, select Edit>Undo. 
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Change the Display Description  

To change the description that displays next to a pole or attached 

equipment’s icon in the Inventory Window, complete the following steps: 

1. Right click on the pole or attached equipment you want to change the 

display description of. 

 

 

2. Select Description of (pole or equipment display name). 

 

3. Enter the Description you would like to be displayed. 

  

Note: Select Clear to clear the description field and use the default value. 

4. Select OK. 

 

Note:  To undo the display description change, select Edit>Undo. 

Deleting Attached Equipment  

To delete equipment that is attached to a pole, complete the following steps: 

1. Select the equipment to be deleted. 
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Note: Multiple pieces of equipment can be deleted concurrently if they are all 

the same type of equipment.  Hold down the ctrl key to select more than one 

piece of equipment that is out of sequence.  Hold down the shift key to select 

several pieces of equipment that are next to each other.   

2. Select the Delete button .   

Note: Individual equipment can also be deleted by right clicking on the 

equipment to be deleted and selecting Delete (equipment). 

 

Note: To undo a deletion, select Edit>Undo. 

Substituting Attached Equipment 

To substitute attached equipment in the Inventory Window, complete the 

following steps: 

1. Select the equipment you would like to substitute. 

 

Note: Multiple pieces of equipment can be substituted concurrently if they are 

all the same type of equipment.  Hold down the ctrl key to select more than one 

piece of equipment that is out of sequence.  Hold down the shift key to select 

several pieces of equipment that are next to each other.  

2. Select the Substitute button . 

Note: The Substitute option can also be accessed by right clicking on the 

equipment that needs to be substituted and selecting Substitute (Equipment 

display name). 
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Note:  Available tabs are dependent on corresponding equipment displayed in 

your catalogs or Inventory Window. 

3. To substitute equipment from the Catalogs or the Inventory tab, select 

the appropriate tab and select the equipment you want to use as a 

substitution.  

Note: For additional information on catalogs see Working With the Catalog 

Window. 

 

4. Select the Attribute values tab to modify the equipment’s attributes. 
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Note:  To substitute equipment with equipment from the Catalog Window or in 

the Inventory Window select the appropriate tab and select the equipment you 

want to use as the substituted equipment.   For additional information on the 

Catalog Window see Working With the Catalog Window. 

5. Select OK. 

 

Note:  To undo the substitution change, select Edit>Undo. 

Substituting a Pole  

To substitute a pole in the Inventory Window O-Calc® Pro provides you 

with three options.  You can either manually select the substitute pole, select 

the substitute pole from the Catalog Window or you can use the Pole Solver 

option to help you select the substitute pole.  The pole solver option will 

display the minimum pole class and the estimated capacity that would be 

used based on the pole’s current load.  To substitute the current pole, 

complete the following steps: 

1. Select the pole you would like to substitute. 

 

2. Select the Substitute button . 

Note: The Substitute option can also be accessed by right clicking on the pole 

and selecting Substitute (Pole’s display name). 

 



Osmose O-Calc® Pro 5.3                                    Confidential User’s Guide 

58                  ©2018 Osmose Utilities Services, Inc. 

Note: Available tabs are dependent on corresponding equipment displayed in 

your catalogs or Inventory Window. 

Note:  Estimated Capacity will display Infinity% until a pole is selected. 

3. Use one of the following methods to select the substitute pole you want: 

Note: The Estimated Capacity percentage will automatically be updated 

dependent on your attribute selections. 

A. Manually select the substitute pole attributes from the Attribute 

Values or Standards tab. 

B. Select the substitute pole from a Catalog tab.  The attributes can 

still be modified if needed in the Attribute Values tab. 

Note:  For additional information on the Catalog Windows see 

Working With the Catalog Window. 

C. Select the Use Pole Solver button   to have O-Calc® 

Pro automatically select the minimum Pole Class that would 

provide you with a passing pole. 

4. Select OK. 

If there are attachments already on the pole the Height Adjustment 

window will automatically be displayed.  The Height Adjustment 

window allows you to adjust the substitute poles depth and the height of 

the attachments relative to groundline or the tip of the substitute pole. 

  

5. Modify the Pole Depth if required. 

6. Verify and change each primary attachment height if required.  

7. Select OK. 

Note:  To undo the substitution change, select Edit>Undo. 
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Adding a Note to the Pole or Attached Equipment 

To add a note and/or calculations to a pole or attached equipment in the 

Inventory Window, complete the following steps: 

1. Select the pole or pole attachment. 

 

2. Select the Add button  and select the Notes option. 

Note:  The Notes option can also be accessed by right clicking on the equipment 

you need to add a note to. 

 

3. Enter a description and the note context. 
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4. Select the Calculations tab. 

The Calculations tab provides a light weight spreadsheet that allows you 

to enter values such as numeric and string but it also allows you to enter 

basic calculations.  Numeric values can also be obtained from the 

selected equipment’s attributes or the selected equipment’s parent 

objects. 

Note: When working with the Measure Window numeric values can also be 

obtained from taking actual image measurements.  For additional information 

on this, see Adding Measurements Information to a Note. 

In addition to the basic notes menu options the Calculations tab provides 

the following menu options: 

 

Recalculate. Select the 

Recalculate option to 

update any formula 

calculations in the 

spreadsheet. 

Add Row. Select the Add 

Row option to add a row 

to the spreadsheet. 

Paste. Select the Paste 

option to paste values only 

or complete text from the 

Office Clipboard directly 

into the spreadsheet. 

Copy Sheet. Select the 

Copy Sheet option to place 

the sheet on the Office 

Clipboard for use in other 

applications. 

Item Attributes. Select 

the Item Attribute option 

to incorporate other values 

into the spreadsheet from 

the select equipment or a 

parent’s attributes. 

 
Formula Bar.  Use the 

Formula Bar to make it 

easier to view and edit a 

long formula or large 

amount of text in a cell.   

 

5. Enter data or calculations into the spreadsheet. 
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To incorporate attribute value from the equipment the note is attached to 

or from a parent item, perform the following steps.  Select the field you 

want the value populated into.  From the menu select Sheet> Item 

Attribute and choose the items whose attribute value you need displayed 

in the spreadsheet. 

 

 

Manually entered 
formula 

String values 
entered into the 
spreadsheet 
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6. Select File>Save. 

 

Note: To undo the addition of the Note, select Edit>Undo from the main 

toolbar. 

Editing a Note 

To edit a note or the calculations, complete the following steps: 

1. Select the note you want to edit. 

 

2. Select the Edit button  . 

Note:   The edit option for a note can also be accessed by right clicking on a 

note and either selecting Edit Note, Edit Note Contents or View/Print Note. 

Selected Crossarm 
Install Height 
attribute value 
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Note:  Basic changes to a Notes Description, Type, Owner, Author or Date can 

be made right from the Edit Window.  Content changes to a Note or 

Calculations need to be completed from within the Note Window. 

3. Select the Contents button . 

4. Complete your edits to the note contents or the calculations. 

5. Select File>Save. 

Note:  To undo the addition of the Note, select Edit>Undo from the main 

toolbar. 

Change the Note Type 

The note type field allows you to easily flag a structure as needing additional 

interaction. To change the note type, complete the following steps: 

1. Select the note you want to change the type. 

 

2. Select the Edit button . 

Note: The edit option for a note can also be accessed by right clicking on a note 

and either selecting Edit Note. 

 

3. Select the Note Type icon . 
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4. Select the Note Type from the predefined list. 

 

5. Select OK. 

 

Note:   To have TBD Notes highlighted in the Inventory Window, enable the 

option in Options>Info tips and Data>Show TBD Item Status. 

The Note icon in the Inventory Window will vary depending on what 

Note Type is selected. 

Note Type Icons Description 

 Normal 

 High Priority 

 TBD Initial 

Note: The note, the pole, and the 

object that the note is attached to will 

be highlighted red if Show TBD Item 

Status is enabled. 

 TBD Complete 

Note: The note, the pole, and the 

object that the note is attached to will 

be highlighted yellow if Show TBD 

Item Status is enabled. 

 TBD Accepted 

Note: The note, the pole, and the 

object that the note is attached to will 

be highlighted green if Show TBD 

Item Status is enabled. 

 

View or Print a Note 

To view or print a note, complete the following steps: 

1. Right click on the note you view or print. 

Note Type is set to 
TBD Initial 
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2. Select View / Print Note (note display name). 

 

The selected note will automatically display in the Reports window.  

 

Change the Description of a Note 

To change the description that displays next to a note icon in the Inventory 

Window, complete the following steps: 

1. Right click on the note you want to change the display description of. 

 

2. Select Description of (note display name). 
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3. Enter the Description you would like to be displayed. 

 

Note:  Select Clear to clear the description field and use the default value. 

4. Select OK. 

 

Note:  To undo the display description change, select Edit>Undo. 

Delete a Note 

To delete a note, complete the following steps: 

1. Select the note to be deleted. 

 

2. Select the Delete button . 

Note:  Notes can also be deleted by right clicking on the note to be deleted and 

selecting Delete (note display name). 
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Note: To undo a deletion, select Edit>Undo. 

Substitute a Note 

To substitute a note, complete the following steps: 

1. Select the note you would like to substitute. 

2. Select the Substitute button . 

 

Note: The Substitute option can also be accessed by right clicking on the note 

that needs to be substituted and selecting Substitute (Note display name). 

 

3. Enter a description, the note context and grid data. 

 

4. Select File>Save. 

Note:  To undo the substitution change, select Edit>Undo. 
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Adding a URI to the Pole or Attached Equipment 

To add a Universal Resource Identifier (URI) to a pole or attached equipment 

in the Inventory Window, complete the following steps: 

1. Select the pole or pole attachment. 

 

2. Select the Add button  and select the LinkedURI option. 

Note:  The Linked URI option can also be accessed by right clicking on the 

equipment you need to add a linked URI to. 

 

Note: To undo the addition of the URI, select Edit>Undo from the main toolbar. 

Editing a URI  

To edit a URI, complete the following steps: 

1. Select the URI you want to edit. 

 

2. Select the Edit button . 

Note:   The edit option for a URI can also be accessed by right clicking on a 

URI and either selecting Edit Link. 

Note:  Basic changes to a URI Description, Owner or Viewer can be made right 

from the Edit Window.  Content changes to a URI need to be completed from 

within the URI Window. 

3. Select the URI button . 

4. Select Edit URI. 
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5. Enter the URI you would like to use. 

 

6. Select Test to verify the entered URI is correct. 

7. Select OK. 

Note: To cancel the current URI, select the Cancel option.  The URI change can 

also be done by selecting Edit>Undo from the main toolbar. 

Setting the URI Viewer 

To set what viewer you want the URI opened in, complete the following 

steps: 

1. Select the URI you want to select a viewer for. 

 

2. Select the Edit button . 

Note:   The edit option for a URI can also be accessed by right clicking on a 

URI and either selecting Edit Link. 
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3. Select the Viewer button . 

 

4. Select Built in to have the URI link open within the application as a 

separate tab.  Select External to have the URI link open in a separate 

window outside of the application.  

Changing the Description of a URI 

To change the description that displays next to the URI icon in the Inventory 

Window, complete the following steps: 

1. Right click on the URI you want to change the display description of. 

 

2. Select Description of (URI display name) 

 

3. Enter the Description you would like to be displayed. 
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Note: Select Clear to clear the description field and use the default value. 

Opening a URI Link 

To open a URI Link, complete the following steps: 

1. Right click on the URI you want to open. 

 

2. Select View Linked Item. 

 

Delete a URI 

To delete a URI, complete the following steps: 

1. Select the URI to be deleted. 

 

2. Select the Delete button . 

Note:  URIs can also be deleted by right clicking on the URI to be deleted and 

selecting Delete (URI display name). 
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Note: To undo a deletion, select Edit>Undo. 

Adding Pole Coordinates 

To manually enter longitude and latitude coordinates to the pole currently 

loaded in the Inventory Window, complete the following steps: 

1. Select Edit>Pole Coordinates. 

 

2. Enter the Latitude. 

3. Enter the Longitude. 

4. Enter the Elevation. 

5. Select the Convention. 

 

6. Select OK. 

Note: Select the Cancel option to close the Geo Location window without saving 

the changes. 
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Sorting the Attached Equipment 

To sort the equipment in the Inventory Window so that it displays in a top 

down view of the pole, complete the following steps: 

1. Select the Sort button . 

Note:  To undo the sort operation, select Edit>Undo. 

Filtering the Attached Equipment 

To utilize the Filtering option in the Inventory Window, see Filtering the 3D 

View. 

Expand or Collapse the Tree View 

To expand or collapse the Inventory Window tree view, complete the 

following steps: 

1. Select the Collapse button  to collapse the Inventory Window 

tree view. 

OR 

Select the Expand button  to expand the Inventory Window 

tree view. 

Create a New Version of the Existing Pole 

While working with a pole or structure in the Inventory Window it may be 

beneficial to compare multiple versions of the pole or structure 

simultaneously.  O-Calc® Pro provides the ability to create multiple versions 

without losing any the functionality that O-Calc® Pro is known for.   

To create a new version of the existing pole in the Inventory Window, 

complete the following steps: 

1. Right click on the Pole you would like to create another version of. 

 

Note: A pole or structure needs to display in the Inventory Window to enable 

any of the Version options. 

2. Select New>Version of This Pole. 
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Note: To remove the new version, select Edit>Undo. 

The new version automatically becomes the active version in the 

Inventory Window.  The active version of a pole is always outlined in 

red  to easily identify which pole’s data is being displayed in O-Calc ® 

Pro.  The only exception to this is the Data Entry Window which will 

always display the currently selected pole.    

When saving a pole, all versions of the pole will be saved. 

Note: To create a version of a new base pole without any attachments in the 

Inventory Window, select Edit>New Version>(Pole Type). 

  

Note: When creating a new version of the existing pole any images that are 

associated with the existing pole will not be copied to the new version. 

 

Setting the Active Version  

To set which pole is the active version in the Inventory Window, complete 

the following steps: 

1. Right click on the Pole you would like to make the active version. 

 

New version of 
the pole 
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2. Select Set Active Version. 

 

 

Note: The selected pole is now outlined in red  indicating it’s the active 

version.  All the windows in O-Calc® Pro are automatically recalculated and 

updated to reflect the selected active version. 

Note: The Data Entry Window will always display the currently selected pole. 

Working with Stub Poles 

While working with a pole that has a span/head guy going to a proximal stub 

pole attachment in the Inventory Window it is often the case that you may 

want to perform analysis on the stub pole as well.  O-Calc® Pro provides a 

convenient method to perform stub pole analysis.  You can either create the 

stub pole as a completely new pole analysis or you can create the new pole as 

a version within the same pole analysis. 

Creating a New Pole Using Stub Pole 

To create the stub pole as a completely new pole within the 

Inventory Window, complete the following steps: 

1. Left click on the pole you would like to use to create a new pole.  

The new pole can either be the current pole in the Inventory 

Window or a pole from the Catalog. 

2. Hold down the left mouse button and drag and drop the selected 

pole onto the Span/Head Termination object in the Inventory 

Window. 
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Note: A new stub pole can also be added by right clicking on the 

Span/Head Termination, selecting Stub Pole as New Pole then 

manually selecting the new pole. 

 

 

Note: While dragging the selected pole to the Inventory Window the 

cursor will change to an invalid cursor .  As the equipment is placed 

over the Span/Head Termination object in the Inventory Window the 

cursor will change to indicate a valid move . 

3. Right click on Select Stub Pole as New Pole. 

  

Note: A stub pole needs to be displayed in the Inventory Window to 

enable this feature. 

 

 

Note:  A stub pole is guyed automatically, if a default Auto-guy 

assembly has been set. To disable the automatic guying of the new stub 

pole, see Enabling the Ability to Auto Guy a New Stub Pole. 

Note: Undo is not available for this operation. 

Creating a New Version of a Stub Pole  

To create a new pole as a version within the same pole within the 

Inventory Window, complete the following steps: 

1. Left click on the pole you would like to use to create a new 

version.  The new pole can either be the current pole in the 

Inventory Window or a pole from the Catalog. 

New Stub Pole 

 

Termination 
Stub Pole 
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2. Hold down the mouse button and drag and drop the selected pole 

onto the Span/Head Termination object in the Inventory 

Window. 

Note: A new pole version can also be added by right clicking on the 

Span/Head Termination and selecting Stub Pole as Version. 

 

 

Note: While dragging the selected pole to the Inventory Window the 

cursor will change to an invalid cursor .  As the equipment is placed 

over the Span/Head Termination object in the Inventory Window the 

cursor will change to indicate a valid move . 

3. Select Stub Pole as Version.(same as above) 

 

Note: A stub pole needs to be displayed in the Inventory Window to 

enable this feature. 

 

 

 

Note: To disable the automatic guying of the new stub pole, see 

Enabling the Ability to Auto Guy a New Stub Pole. 

Note: To remove the new version, select Edit>Undo. 

Note: The Data Entry Window will always display the currently 

selected pole. 

Opening an Existing Pole 

To open an existing pole in the Inventory Window, complete the following 

steps: 

1. Select File>Open Pole. 
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2. Browse to the location of the pole you wish to open and select the (pole 

name).pplx file and click Open. 

 

Save a Pole 

To save the pole in the Inventory Window, complete the following steps: 

1. Select File>Save Pole. 

 

2. Browse to the location where you will save the Pole and click Save. 

Save a Pole Using Save As  

To save a pole as a different file name, format or location, complete the 

following steps: 

1. Select File>Save Pole As. 

 

2. Browse to the location where you will save the Pole and click Save. 

Close an Existing Pole 

To close the current pole in the Inventory Window, complete the following 

steps:  

1. Select File>Close Pole. 

 

Note: If any changes have been made to the current pole you will be prompted 

to save your changes before closing the pole. 
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Previewing an Existing Pole 

To preview an existing pole(s) without having to load each one manually, 

complete the following steps. 

1. Select File> More Options>Preview Pole. 

 

 

Note: If you have an unsaved pole loaded in the Inventory Window you will be 

prompted to save your changes. 

2. Select the Browse button   and browse to the Directory that has the 

.pplx file(s) you would like to preview. 

3. Select OK. 

 

4. Select the .pplx file you would like to preview. 

Note: Select Open to open the selected .pplx file in edit mode instead of Preview 

Mode.  Select Cancel to close the Preview Pole window. 
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5. Select OK. 

 

The pole is automatically displayed in Preview Mode within O-Calc Pro. 

While previewing a pole in Preview Move several things are changed 

within O-Calc Pro to clarify that you are actually in Preview Mode.  A 

Preview Mode banner is displayed at the top of the 3D View window.  

The File menu is automatically switched to Preview and offers several 

preview options. 

Preview Toolbar Menu Options 

The Preview toolbar menu option provides you with a variety of 

options: 

 

Preview to New Pole. 

Select the Preview to New 

Pole option to convert the 

currently previewed pole 

to a new pole. 

Preview to New Version. 

Select the Preview to New 

Version option to convert 

the currently previewed 

pole to a new version. 

Open Previewed Pole. 

Select the Open Previewed 

Pole option to open the 

currently displayed 

preview pole and exit 

preview mode. 

 

Create a New Pole from a Previewed Pole 

To create a new pole from the pole you are currently previewing, 

complete the following steps: 
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1. Select Preview>Preview to New Pole. 

 

Note: Once Preview to New Pole is selected the Preview Mode is 

automatically closed.  

2. Complete any modifications to the new pole. 

3. Select File>Save to save the new pole. 

Create a New Version from a Previewed Pole 

To create a new version from the pole you are currently previewing, 

complete the following steps: 

1. Select Preview>Preview to New Version. 

 

Note: Once Preview to New Version is selected the Preview Mode is 

automatically closed.  

2. Complete any modifications to the new version. 

3. Select File>Save to save the new version. 

Open a Previewed Pole 

To open the pole you are currently previewing, complete the 

following steps: 

1. Select Preview>Open Previewed Pole. 

 

Note: Once Open Previewed Pole is selected the Preview Mode is 

automatically closed.  

2. Complete any modifications to the pole. 

3. Select File>Save. 

Close the Preview Mode 

To close the pole you are previewing and exit the Preview Mode, 

complete the following steps: 
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WARNING: Any changes to the pole you are previewing will NOT be 

saved. 

1. Select Preview>Close Preview.  

 

Working with the Pole Reviewer 

To quickly edit several poles sequentially or to locate .pplx files, complete 

the following steps. 

1. Select File> More Options>Pole Reviewer. 

  

Note: If you have an unsaved pole loaded in the Inventory Window you will be 

prompted to save your changes. 

2. Select the Browse button   and browse to the Directory that has the 

.pplx files. 

3. Select OK. 

 

Note:  The first pole in the Pole Reviewer list will automatically be displayed in 

the Inventory Window. 

4. Complete any modifications to the currently loaded pole and select Next 

to load the next .pplx file in the Inventory Window. 
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Note:  If the Auto Save option is deselected you will be prompted to save the 

changes to each .pplx file you change. 

5. Select the X in the upper right hand corner to close the Pole Reviewer 

window. 

E-Mail a Pole 

To send the current pole model file via e-mail to another individual, complete 

the following steps:  

Note:  The current pole does not need to be saved in order to use the e-mail 

option.Select File>More Options>E-Mail Pole To. 

 

 

1. Enter a valid e-mail sever (SMTP or Exchange).   

2. Enter senders e-mail address. 

3. Enter the recipients e-mail address. 

4. Enter a subject. 

5. Enter a message. 

6. Select OK. 

7. Select OK to the confirmation message. 

Note: E-mail connection is required. 

Set a Default File Name 

The Default File Name option provides you with the ability to use a reporting 

token to create a default file name to match a specific naming convention.  

To set a default file name, complete the following steps:  
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1. Select File>More Options>Set Default File Name. 

 

Note:  A pole does not need to be loaded in order to set a default file name. 

 

2. Enter the file name token you would like to use. 

 

Note: Select Help to view a list of valid tokens.  A token can be copy and posted 

from the valid token list into the Default File Name field.  

3. Select Test to preview what the default file name will display as.  

4. Select OK. 

Note: To cancel the current Default File Name, select the Cancel Option. 

After you set the Default File Name, the first time you save a pole the 

default file name token will automatically be displayed in the file name. 

Note:  Once the pole has been saved with a specified name, it will not update the 

file name the default File Name, unless a save Pole As… is performed. 
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Working with the Catalog Window  

Catalog Window Overview  

The Catalog Window provides you with the ability to efficiently assemble a 

pole and its common equipment in the Inventory Window.   The Catalog 

Window consists of two main areas.  The Master Catalog contains a 

compiled list of common poles, assemblies and equipment that are utilized in 

the field.  It also contains a complete listing of all the available Load Cases.  

The User Catalog is a folder in which you can compile your own list of poles 

or equipment that you’ve created.   You can then use the data in the User 

Catalog to build additional poles in the Inventory Window.  

 

Note:  Changes and addition can only be done in the Master Catalog when you are 

in Administrative User Mode.   Load Cases cannot be edited in the Master Catalog.  

 

 

 Default file name token 
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Catalog Window Toolbar Menu Options  

The Catalog Window toolbar provides you with a variety of option. 

 

Query Select the Query option to search the data within the current 

catalog. 

Add Select the Add option to add a sub folder to a User Catalog 

folder. 

Remove Select the Remove option to remove a selected folder or 

object within the User Catalog. 

Preview Select the Preview option to preview a pole in the Inventory 

Window from the selected catalog pole. 

New Pole Select the New Pole option to create a new pole in the 

Inventory Window from the selected catalog item. 

Collapse Select the Collapse option to collapse all the objects in the 

current Catalog window. 

 

Master Catalog Functions 

Set a Default Load Case  

Load cases are used to group a series of loads, boundary and safety 

conditions into load environments.  The master Catalog provides a 

dynamic listing of load cases broken down into categories.   

For each category, a default load case should be specified dependent 

on pole type.  This ensures that the correct load case is used each 

time a pole of that category/type is created.  Use the following steps 

to set a default load case for each category: 

1. Expand the Master Catalog folder. 

2. Expand the Load Cases folder until the catalog list you need is 

displayed. 

Note: A default Load Case can only be selected from the Master 

Catalog. 
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3. Right click on the Load Case you want to set as the default. 

 

 

4. Select Set as the default LoadCase and select the pole type. 

 

5. Select OK to the verification message. 

Note:  A default LoadCase can be set for each LoadCase category.  In 

addition one extra LoadCase is allowed to be set.  This extra LoadCase 

is the “Other” LoadCase.  Complete steps 1 – 5 to set the default 

LoadCases for each category.  The default Load Case can be changed 

at any time. 
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Set a Default Auto-Guy Assembly  

An Auto-Guy Assembly is used in the 3D View to properly guy a 

structure using a limited number of steps.   An Auto-Guy Assembly 

should consist of one guy and one anchor.  The Master Catalog 

provides a common listing of Guy and Anchor Assemblies.  A 

default Guy and Anchor Assembly should be specified so that the 

correct one is used each time the Auto-Guy option is used.  Use the 

following steps to set a default Auto-Guy assembly: 

1. Expand the Master Catalog folder. 

2. Expand the Assemblies> Guy and Anchor Assemblies folder. 

Note: A default Auto-Guy Assembly can be selected from the Master 

Catalog or the User Catalog.  To be considered an Auto-Guy Assembly 

the assembly must consist of only one anchor and one guy. 

 

3. Right click on the Guy & Anchor Assembly that you want to 

set as the default 
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4. Select Set as the default “Auto-Guy” assembly 

 

5. Select OK to the verification message. 

Note: The default Auto-Guy Assembly can be changed at any time. 

Creating a New Pole 

To create a new pole in the Inventory Window using a pole listed in 

a Catalog, complete the following steps: 

1. Expand the Catalog folder that has the pole you want. 

2. Expand the Poles folder until the catalog list you need is 

displayed. 

 

3. Select the pole to be added to the Inventory Window. 

 

4. Select the New Pole button . 
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5. The selected pole is automatically added to the Inventory 

Window. 

Note: The selected pole can also be added to the Inventory Window by 

right clicking on the selected pole and selecting New> Pole Using This 

Pole as Template. 

 

Note: Undo is not available when adding a pole. 

Adding Common Equipment to a Pole 

To add common equipment to a pole in the Inventory Window using 

equipment listed in a Catalog, complete the following steps: 

1. Expand the Catalog folder that has the equipment you want. 

2. Expand any of the equipment folders until the catalog list you 

need is displayed.  Select the equipment to be added to the 

Inventory Window. 

 

3. Hold down the mouse button and drag and drop the select 

equipment onto the pole in the Inventory Window. 

Note:  While dragging the selected equipment to the Inventory Window 

the cursor will change to an invalid cursor .  As the equipment is 

placed over the pole in the Inventory Window the cursor will change to 

indicate a valid move . 

Note:  To undo the equipment you added, select Edit>Undo. 

Note:  To set a default percent of maximum span tension to be applied 

to conductors when they are selected from the Master Catalog to be 

used in the Inventory Window, see Modifying Span’s Default Rated 

Strength Percentage. 
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Adding Load Cases to a Pole 

To add Load Cases to a pole in the Inventory Window using Load 

Cases listed a Catalog, complete the following steps: 

1. Expand the Catalog folder that has the Load Case you want. 

2. Expand the Load Cases folder until the catalog list you need is 

displayed. 

 

 

3. Select the Load Case to be added to the Inventory Window. 

 

4. Hold down the mouse button and drag and drop the selected 

Load Case onto the pole in the Inventory Window. 

Note:  To undo the Load Case you added, select Edit>Undo. 

Note:  While dragging the selected equipment to the Inventory Window 

the cursor will change to an invalid cursor .  As the equipment is 

placed over the pole in the Inventory Window the cursor will change to 

indicate a valid move . 
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User Catalog Functions 

Adding a Subfolder 

To add a subfolder to the User Catalog, complete the following 

steps: 

1. Right click on the User Catalog folder you want to create a 

subfolder for. 

 

2. Select Add Subfolder. 

 

3. Enter a catalog subfolder Name. 

 

4. Select OK. 

 

Note: Undo is not available. 

Note:  Once a subfolder has been added to the User Catalog additional 

folder can be added to that subfolder by selecting the Add button 

 or by right clicking on the subfolder and selecting Add 

Subfolder.  

Removing Subfolder  

To remove a User Catalog subfolder, complete the following steps: 

1. Select the User Catalog folder to be removed. 

 

2. Select the Remove button . 
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Note: The selected User Catalog folder can also be removed by right 

clicking on the folder and selecting Remove (name of the folder). 

3. Select Yes to permanently remove the selected folder. 

Note: There is no undo for this operation. 

Renaming a Subfolder  

To rename a User Catalog subfolder, complete the following steps: 

1. Right click on the User Catalog folder to be renamed. 

2. Select Rename Folder. 

 

3. Name the selected folder. 

 

4. Select OK. 

 

Note: There is no undo for this operation. 

Adding Equipment to a Subfolder  

To add equipment to a User Catalog subfolder, complete the 

following steps: 

1. Right click on the User Catalog subfolder that equipment will 

be added to. 

2. Select Add and select the equipment to be added from the 

equipment list. 
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Note: Only one piece of equipment can be selected at a time. 
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Note:  Available tabs are dependent on corresponding equipment 

displayed in your catalogs or Inventory Window. 

 

3. To add equipment from one of the Catalog tabs or the Inventory 

tab select the appropriate tab and select the equipment you want 

to add. 

Note: For additional information on catalogs or the Inventory Window 

see Working With the Catalog Window or Working With the Inventory 

Window. 

4. Select the Attribute Values tab to modify the equipment’s 

attribute values. 

5. Select OK. 

 

Note:  There is no undo for this operation.  To delete equipment from a 

User Catalog folder see Deleting Equipment in a Subfolder.  

Equipment can have several attachments (Example:  A crossarm 

can have insulators and spans attached to it).  To add additional 

attachments to equipment, complete the following steps: 

6. Right click on the equipment you want to add additional 

equipment to. 

7. Select Add Element and select the equipment to be added from 

the equipment list. 

 

Note: If multiple pieces of equipment are displayed in the list only one 

piece of equipment can be selected at a time. 
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Note:  Available tabs are dependent on corresponding equipment 

displayed in your catalogs or Inventory Window. 

8. To add additional equipment from one of the Catalog tabs or 

the Inventory tab select the appropriate tab and select the 

equipment you want to add. 

Note: For additional information on catalogs or the Inventory Window 

see Working With the Catalog Window or Working With the Inventory 

Window. 

9. Select the Attribute Values tab to modify the equipment’s 

attribute values. 

10. Select OK. 

 

Note: To add additional attachments to equipment complete steps 6 –

10. 

Note: There is no undo for this operation.  To delete equipment from a 

User Catalog folder see Deleting Equipment in a Subfolder. 
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Edit Equipment Attributes in a Subfolder  

To edit equipment attribute(s) in a User Catalog subfolder, complete 

the following steps: 

1. Right click on the equipment whose attribute(s) you want to 

edit. 

2. Select Edit (equipment display name). 

 

Note: For a complete list of the editable icon’s descriptions see Editing 

Equipment Attributes. 

3. Complete your edits to the equipment attributes. 

 

Note: Certain attributes are only editable in Administrative User 

Mode. 

4. Select OK. 

Note: There is no undo for this operation.   

Change the Display Descriptions  

To change the description that displays next to equipment icon in a 

User Catalog subfolder, complete the following steps: 

1. Right click on the equipment you want to change the display 

description of. 

2. Select Description of (equipment display name). 
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3. Enter the Description you would like to be displayed. 

 

Note:  Select Clear to clear the Description field and reset it to the 

default value. 

4. Select OK. 

 

Note:  There is no undo for this operation. 

Deleting Equipment in a Subfolder  

To delete equipment in a User Catalog subfolder, complete the 

following steps: 

1. Select the equipment to be deleted. 

 

 

2. Select the Remove button . 

Note: The selected equipment can also be removed from the subfolder 

by right clicking on the subfolder and selecting Remove (equipment 

display name). 
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Note:  There is no undo for this operation. 

Adding a Note to the Pole or Attached Equipment 

To add a note and/or calculations to the pole or attached equipment 

in the User Catalog, complete the following steps: 

1. Right click on the equipment you want to add a note to. 

 

2. Select the Add>Notes option. 

 

  

3.  Enter a description and the note context. 

 

4. Select the Calculations tab. 

The calculations tab is a light weight spreadsheet that allows you 

to enter values such as numeric and string but it also allows you 

to enter basic calculations.   

Content of note 

Note description 

Appearance editing tools 

Toolbar 
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In addition to the basic notes menu options the Calculation tab 

provides the following menu options: 

 

Recalculate. Select 

the Recalculate option 

to update any formula 

calculations in the 

spreadsheet. 

Add Row. Select the 

Add Row option to 

add a row to the 

spreadsheet. 

Paste. Select the Paste 

option to paste values 

only or complete text 

from the Office 

Clipboard directly into 

the spreadsheet. 

Copy Sheet. Select 

the Copy Sheet option 

to place the sheet on 

the Office Clipboard 

for use in other 

applications. 

 
Formula Bar.  Use 

the Formula Bar to 

make it easier to view 

and edit a long 

formula or large 

amount of text in a 

cell.   

 

5. Enter data or calculations into the spreadsheet. 

 

 

Manually Entered 

Fields 



Osmose O-Calc® Pro 5.3                      Confidential                                                           User’s Guide 

©2018 Osmose Utilities Services, Inc.                                                                                                  101 

  

 

6. Select File>Save. 

 

Note: There is no undo for this operation. 

Editing a Note 

To edit a note or the calculations, complete the following steps: 

1. Right click on the note you want to edit. 

 

2. Select the Edit (note description). 

 

 Manually entered 
formula 
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Note:  Basic changes to a Notes Description, Owner, Author or Date 

can be made right from the Edit Window.  Content changes to a Note 

need to be completed from within the Note window. 

3. Select the Contents button . 

4. Complete your edits to the note contents or the data in the grid. 

5. Select File>Save. 

Note:  There is no undo for this operation. 

Change the Note Type 

The note type filed allows you to easily flag a structure as needing 

additional interaction.  To change the note type, complete the 

following steps: 

1. Right click on the note you want to change the type 

 

2. Select the Edit (note description) 
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3. Select the Note Type button . 

4. Select the Note Type from the predefined list. 

 

 

5. Select OK. 

 

When a specific note type is selected the note icon in the 

Inventory window will automatically change to indicate the 

note’s status. 

Note Type Icons Description 

 Normal 

 High Priority 

Note Type 

Note type is set to TBD 
Initial 
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 TBD Initial 

Note: The note, the pole, and the 

object that the note is attached to will 

be highlighted red. 

 TBD Complete 

Note: The note, the pole, and the 

object that the note is attached to will 

be highlighted yellow. 

 TBD Accepted 

Note: The note, the pole, and the 

object that the note is attached to will 

be highlighted green. 

 

Change the Description of a Note 

To change the description that displays next to a note icon in the 

User Catalog, complete the following steps: 

1. Right click on the note you want to change the display 

description of. 

 

2. Select Description of (note display name). 

 

3. Enter the Description you would like to be displayed. 

 

Note:  Select Clear to clear the Description field and reset it to the 

default value. 

4. Select OK. 
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Note:  There is no undo for this operation. 

Note:  The description of the note can also be changed using the Edit 

Note option, see Editing a Note. 

 

Delete a Note 

To delete a note, complete the following steps: 

1. Select the note to be deleted. 

 

2. Select the Remove button . 

 

Note: There is no undo for this operation. 

Note:  Notes can also be deleted by right clicking on the note to be 

deleted and selecting Remove (note display name). 

Working With the 3D View 

About 3D View  

The 3D View is a three-dimensional interactive image of the Inventory 

Window.  As structures are created or displayed in the Inventory Window the 

3D View is automatically updated to reflect the changes to the Inventory 

Window.   Structures can also be created or updated in the 3D View.  Any 

changes or additions that are completed in the 3D View are automatically 

made in the Inventory Window.  
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Interacting with the 3D View Display  

The 3D View provides several ways to reposition the 3D View to better 

analyze the pole and the objects attached to the pole.   

Mouse Wheel You can use the mouse wheel to interact with the 

3D View.  To zoom in or out scroll the mouse 

wheel forwards or backwards.  

Right Mouse Click Clicking and holding down the right mouse button 

allows you to pan the 3D View to the left, right, up 

or down.  

Left Mouse Click Clicking and holding down the left mouse button 

allows you to either rotate the 3D View or move 

the 3D View vertically up and down.  Left mouse 

button click and moving mouse left-right will 

rotate the image.  Left mouse button click and 

moving mouse up or down will vertically move 

the viewing perspective of the 3D View down or 

up.   

 

3D View Display Options  

O-Calc ® Pro provides a variety of 3D tools designed to allow the user to 

review and interact with the 3D image. 
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Camera Display Camera Position.  The Camera 

Positon option provides a compact view of 

the compass control in 3D View. 

Perspective Camera.  The Perspective 

Camera in 3D View option displays the 3D 

View in Perspective view. 

Orthographic Camera.  Orthographic 

Camera in 3D View option displays the 3D 

View in Orthographic projections. 

Additional Light Source. The Additional 

Light Source is used to brighten the 3D 

View display.  
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Labels 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Label Elements in 3D View.  The 

Label Elements in 3D View option 

toggles the display of annotations for 

all the elements in the 3D View. 

Measure Cursor.  The Measure 

Cursor option toggles on or off the 

measure cursor as you move along the 

pole in 3D View to display the height 

for all the elements. 

Show Damage and Decay Markers. 

The Show Damage and Decay Markers 

option displays damage and decay 

markers in the 3D View. 

Show Compass in 3D View.  The 

Show Compass in 3D View option 

displays a Head-Up Display (HUD).  

The HUD display direction is based on 

the user’s perspective.  The HUD also 

provides the following information:  

 

Direction 

Elevation 

Camera zoom level 

Pan and tilt of the camera 

Visual compass at the bottom of the 

pole 

Display Wind Direction Arrow.  The 

Wind Direction Arrow displays the 

worst possible wind angle. 

 

Note:  You can override what displays for 

the Wind Direction by selecting the Load 

Case that is attached to the pole and 

enabling Override Wind. 

Display Wind Pressure.  The Display 

Wind Pressure option displays the 
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wind pressure on the wind direction 

arrow.  

Display Heights/ Ruler.  The Display 

Heights/ Ruler display a heights ruler 

in the 3D View. 

Height Filtering The Height Filtering option filters the 

objects that display in the 3D view 

according to height. 

Angle Filtering The Angle Filtering option filters the 

objects that display in the 3D view 

according to an angle. 

Visualization Render Deflection Path Bars.   The 

Deflection Path Bars displays the amount 

the pole is deflecting (bending).  

 

Note:  If Render Deflection Path Bars is 

enabled then Render Deflection Ghost Pole 

cannot be enabled.  Only one of these options 

can be enabled at a time.  

Note:  If Auto Capacity Summary is disabled 

you will need to manually update the Capacity 

Summary in order to update the Render 

Deflection Path Bars calculation.  For 

additional information on the Capacity 

Summary see Working With the Capacity 

Window .  

Render Deflection Ghost Pole.  The 

Render Deflection Ghost Pole shows the 

amount the pole is deflecting (bending) as 

a ghost of the existing pole.  

Note:  If Render Deflection Ghost Pole is 

enabled then Render Deflection Path Bars 

cannot be enabled.  Only one of these options 

can be enabled at a time.  
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Note:  If Auto Capacity Summary is disabled 

you will need to manually update the Capacity 

Summary in order to update the Render 

Deflection Ghost Pole calculation.  For 

additional information on the Capacity 

Summary see Working With the Capacity 

Window.  

Exaggerate Ghost Radius.  The 

Exaggerated Ghost Radius exaggerates the 

Deflection Ghost Pole view.  

Note:  The Exaggerated Ghost Radius only 

works with the Render Deflection Ghost Pole 

option. 

Show Cap Util on Ghost.  The ghost pole 

will be color coded heat map of the 

capacity utilization. 

Render Sweep Visualization. The Render 

Sweep Visualization displays a 2-

dimension, color coded heat map of the 

capacity utilization of the pole along the 

length of the pole as well as wind direction. 

Sweep Visualization 3D Surface. The 

Sweep Visualization displays a 3-

dimention, color coded heat map of the 

capacity utilization of the pole along the 

length of the pole as well as wind direction. 

Animate Selected Object 

(Flash) 

Animate Selected Object (Flash).  The 

Animate Selected Object option helps 

identify, in the 3D View, what object has 

been selected in the Inventory Panel.  The 

selected object in the Inventory Panel will 

change color and flash in the 3D View. 

Show 3D View When Pole 

Opened 

Show 3D View When Pole Opened. The 

Show 3D View When Pole Opened option 

automatically displays the 3D View when a 

pole is opened or created. 
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Working with the Compass in 3D View 

The 3D View compass provides an interactive compass that allows you to do 

numerous functions depending on where you click on the compass.   

 

 

 

 Toggle Bird’s Eye View. Select the Toggle 

Bird’s Eye View button to toggle the 3D 

View to an overhead view of the pole 

 Vertical Reposition.  Click the Up Arrow 

button and hold down the mouse button 

while moving the mouse left or right to 

vertically reposition the 3D View up or 

down. 

 Rotate.  Click the Rotate icon button and 

hold down the mouse button while moving 

the mouse left or right to rotate the 3D 

View clockwise or counterclockwise.  

 Zoom in Out.  Click the Zoom icon button 

and hold down the mouse button while 

moving the mouse left or right to zoom the 

3D View in and out. 

Camera Look Angle Camera Look Angle.  Select the Camera 

Look Angle to change the current cameral 

look angle. 

Camera Elevation Camera Elevation.  Select the Camera 

Elevation to change the current cameral 

elevation. 

 

Additional 3D View Menu Display Options  

In addition to the basic menu options that are available, holding down the ctrl 

key and right click on the 3D View background displays additional 3D View 

options. 

 

 

Camera Look Angle 

Camera Elevation 
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Save 3D View to File. Select the Save 3D 

View to File option to save the current 3D 

View as a variety of file types (JPEG, 

BMP, GIF or PNG) 

Copy 3D View to Clipboard. Select the 

Copy 3D View to Clipboard option to copy 

the current 3D View to the clipboard so 

that the 3D View can be pasted directly 

into other applications such as Microsoft 

Word, E-Mail, etc. 

Print 3D View. Select the Print 3D View 

option to print the currently displayed 3D 

View. 

Toggle Bird’s Eye View. Select the Toggle 

Bird’s Eye View to toggle the 3D View to 

an overhead view of the pole. 

Reset Camera Position. Select the Reset 

Camera Position to set the 3D View back to 

the default view. 

Cancel. Select the Cancel option to close 

the additional 3D View menu option pop-

up without taking any action.  

 

Creating a New Pole Using This Pole as Template 

To create a new pole as template in the Inventory Window using the current 

pole in the 3D View, complete the following steps: 

1. Right click the pole in the 3D View and select New> Pole Using This 

Pole as Template. 

 

Note:  The pole is automatically highlighted in yellow once selected.  

Note: Undo is not available when adding a pole using this pole as template 

feature. 
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Creating a New Pole Version of This Pole 

As mentioned above there are two ways to create an additional version of the 

pole model within an existing pplx file. To create a new version of the pole 

in the Inventory Window using the current pole in the 3D View, complete the 

following steps: 

2. Right click the pole in the 3D View and select New> Version of This 

Pole. 

Note:  The pole is automatically highlighted in yellow once selected.  

 
Note: Undo is not available when adding a version of this pole. 

Setting the Depth of a Pole 

To set the depth of a pole, complete the following steps: 

1. Right click the pole in the 3D View. 

2. Select the Setting Depth of (Pole display name). 

 

3. Select the Mode from the drop down list and enter the Depth in feet. 

 

Note: The Depth in Feet field will automatically display the default pole depth 

when initially opened. 
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4. Select OK. 

Setting the Above Ground Length in Feet of a Pole 

To set the length of a pole, complete the following steps: 

1. Right click on the Pole you want to set the length for. 

2. Select the Set Length and Depth option. 

3. Select Above Ground Length of (Pole display name). 

 

4. Select the Mode from the drop down list and enter the AGL in Feet. 

 

5. Select OK. 

Note: To undo the AGL Length change, select Edit>Undo. 

Setting the Length in Feet of a Pole 

To set the length of a pole, complete the following steps: 

1. Right click on the Pole you want to set the length for. 

2. Select the Set Length and Depth option. 

3. Select Length of (Pole display name). 
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4. Select the Mode from the drop down list and enter the Length in Feet. 

 

5. Select OK. 

Note: To undo the Length change, select Edit>Undo. 

 

Adding Equipment to a Pole 

To add equipment to a pole in the 3D View, complete the following steps: 

1. Right click the pole in the 3D View, select Add then select the 

equipment to be added to the pole. 

 

Note: Only one piece of equipment can be added at a time. 
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Note:   Available tabs are dependent on corresponding equipment displayed in 

your catalogs or Inventory Window. 

 

2. To add a crossarm from the Catalog tabs or the Inventory tab select the 

appropriate tab and select the crossarm you want to add. 

Note: For additional information on catalogs see Working With the Catalog 

Window. 

3.  Select the Attribute Values tab to modify the crossarm’s attribute 

values. 

4. Click OK.  

Note: To remove the added equipment, select Edit>Undo. 

Equipment can have several attachments (Example:  A crossarm can 

have insulators and spans attached to it).  To add additional attachments 

to equipment, complete the following steps: 

5. Right click on the equipment in the 3D View that you want to add 

additional equipment to. 

6. Select Add Element and select the equipment to be added from the 

equipment list. 
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Note: If multiple piece of equipment are displayed in the list only one piece of 

equipment can be selected at a time. 

 

Note:  Available tabs are dependent on corresponding equipment displayed in 

your catalogs or Inventory Window. 

7. To add an insulator from one of the catalog tabs or the Inventory tab 

select the appropriate tab and select the insulator you want to add. 

8. Select the Attribute Values tab to modify the insulator’s attribute 

values. 

Note: For additional information on catalogs see Working With the Catalog 

Window. 

9. Select OK. 

Note: To add additional equipment complete steps 1 – 9.  
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Adding a Span Bundle to a Pole 

To add a span bundle to an attached insulator in the 3D View you first need 

to create the span messenger wire.  To create the span messenger wire, 

complete the following steps: 

1. Right click on the insulator in the 3D View that you want to add a span 

bundle to and select Add Element > SpanBundle. 

 

Note: Only one Span Bundle can be added at a time. 

 

Note: Available tabs are dependent on corresponding Span Bundles displayed in 

your catalogs or Inventory Window. 

2. To add a Span Bundle from one of the Catalog tab or the Inventory tab 

select the appropriate tab and select the Span Bundle you want to add. 

Note: For additional information on catalogs see Working With the Catalog 

Window. 

3. Select the Attribute Values tab to modify the Span Bundle attributes. 

4. Select OK. 
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Note: To undo additions, select Edit>Undo. 

Once the span bundle messenger wire has been created you need to 

actually add the spans.  Complete the following steps to add spans to the 

messenger wire: 

5. Right click on the Span Bundle in the 3D View. 

6. Select Add>Span. 

 

Note: Only one Span can be added at a time. 

 

Note: Available tabs are dependent on corresponding spans displayed in your 

catalogs and Inventory window. 

7. To add an insulator from one of the catalog tabs or the Inventory tab 

select the appropriate tab and select the insulator you want to add. 

Note: For additional information on the Catalog Window see Working With the 

Catalog Window. 

8. Select the Attribute Values Tab to modify the Span attributes. 

9. Select OK. 

Note: To add additional spans to the span bundle complete steps 5 – 9. 

Note: To undo additions, select Edit>Undo. 
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Working with the Span Bundle Editor 

To quickly and efficiently edit the spans positions or add additional spans to 

a span bundle use the Span Bundle Editor.  To open the Span Bundle Editor, 

complete the following steps: 

1. Right click on the Span Messenger wire you want to edit. 

2. Select Bundle Editor for (bundle display name). 

 

 

 

 

Span Bundle Editor Toolbar Options 

The Span Bundle Editor toolbar menu provides you with a variety of 

operations and options. 

 

 

File. The following options 

are available from the File 

menu: 

Reset View. Select the 

Reset View option to set the 

 

 

 

 

 

 

Toolbar 

Span bundle 
display window 

Span Detail 
Table 

Span bundle 

messenger wire 

Each circle 
represents a 
span within the 
span bundle 

Span bundle 
information 

Selected spans 
information 
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Span Bundle Editor back to 

the default view. 

Save.  Select the Save 

option to save any changes 

or additions. 

Exit. Select the Exit option 

to close the Span Bundle 

Editor. 

 

Edit. The following options 

are available from the Edit 

menu: 

Add Span.  Select the Add 

Span option to add a span to 

the span bundle. 

Layout Vertical. Select the 

Layout Vertical option to 

automatically reposition all 

the spans vertically under 

the messenger wire. 

Layout Pack Under. Select 

the Layout Pack Under 

option to automatically 

reposition all the spans 

under the messenger wire. 

Layout Pack Around. 

Select the Layout Pack 

Around option to 

automatically reposition all 

the spans around the 

messenger wire. 

Auto Pack. Select the Auto 

Pack option to have the 

spans as close as possible 

given their size. 

Un-Collide.  Select the Un-

Collide option to position 

the spans so they are not 

overlaid. 

Dynamic Un-Collide. 

Select the Dynamic Un-

Collide option to 

automatically un-collide the 

spans while you’re dragging 

them into position. 
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Circumscribe.  Selecting 

the Circumscribe option 

tells you what the minimum 

circle would be that all the 

spans and messenger wire 

could fit into. 

 
Show Labels. Select the 

Show Labels option to 

display the spans 

descriptions next to each 

span in the bundle. 

Adding a Span to a Span Bundle 

To add a span to the span bundle using the Span Bundle Editor, 

complete the following steps: 

1. Select Edit>Add Span. 

 

Note: Only one span can be added at a time. 

 

Note: Available tabs are dependent on corresponding spans 

displayed in your catalogs or Inventory Window. 
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2. To add a span from the catalog tabs or the Inventory tab 

select the appropriate tab and select the span you want to 

add. 

Note: For additional information on the Catalog Window see 

Working With the Catalog Window. 

3. Select the Attribute Values tab to modify the Span 

attributes. 

4. Select OK. 

Note: The span is automatically added to the span bundle and is 

displayed in the Span Bundle Editor. 

Note: There is no Undo option available.  Select File>Exit to 

close the Span Bundle Editor without saving any modifications that 

have been completed. 

5. Select File>Save. 

Repositioning Spans in a Span Bundle 

The Span Bundle Editor offers three ways you can reposition spans 

within the editor.  To reposition span(s) in the span bundle using the 

Span Bundle Editor, use one of the following options: 

A. Select Edit and select a layout option from the Edit menu. 

B. Left click a span in the Span Bundle Display window and 

drag the span to a new location. 

C. Manually enter a horizontal and/or vertical value for a 

specific span in the Span Detail Table. 

Editing Spans in the Span Bundle 

To edit span attributes from within the Span Bundle Editor, complete 

the following steps: 

1. Right click on the span in the Span Bundle Display window. 

2. Select Edit Span from the drop down menu. 

 

3. Complete any modification to the Span Bundle attributes. 



Osmose O-Calc® Pro 5.3                                    Confidential User’s Guide 

124                  ©2018 Osmose Utilities Services, Inc. 

 

4. Select OK. 

Note: There is no Undo option available.  Select File>Exit to close the 

Span Bundle Editor without saving any modifications that have been 

completed. 

5. Select File>Save. 

Deleting Spans in the Span Bundle 

To delete a span within the Span Bundle Editor, complete the 

following steps: 

1. Right click on the span in the Span Bundle Display window. 

2. Select Delete Span from the drop down menu. 

 

3. Select Yes to the confirmation message. 

Note: There is no Undo option available.  Select File>Exit to close the 

Span Bundle Editor without saving any modifications that have been 

completed. 

4. Select File>Save. 

Automatically Adding a Down Guy to a Pole 

To properly guy a structure in O-Calc® Pro an Auto-Guy function has been 

added.  The Auto-Guy functionality allows you to automatically add both an 

anchor and a guy wire to a structure simultaneously.  The Auto-Guy function 

also allows you to manually change Anchor and/or Guy attributes such as the 

lead angle, lead length, attachment height, etc. to ensure the structure is 

guyed properly.  To use the Auto-Guy function in the 3D View, complete the 

following steps: 

1. Right click the area on the pole where you want the Down Guy placed. 
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2. Select Auto-Guy. 

 

Note: If a default Auto-Guy Assembly has not been set a warning message will 

display that the system will use the first assembly in the catalog.  To set a default 

Auto-Guy Assembly see Set a Default Auto-Guy Assembly. 

3. Verify and edit any Anchor attributes. 
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4. Select OK.  

 

The deflection of the pole is used to set the lead length.  The anchor and 

guy wire are automatically added to the pole.  The length angle is picked 

based off the worst wind angle on the pole before the anchor/guy 

assembly was added. 
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Automatically Add Extra Down Guys to an Anchor 

To automatically add extra down guys to an anchor already displayed in the 

3D View, complete the following steps: 

1. Left click on the Anchor that you want to add an additional down guy to 

in the 3D View. 

2. Right click the area on the pole where you want the additional down guy 

placed. 

 

3. Select Extra-Guy. 
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Note: Extra guy wires can be added to the pole as they are needed. 

 

Modifying a Down Guy into Another Type 

1. To change a down guy into another type of guy, complete the following 

steps: 

 

2. Select the Guy Wire in the Inventory or 3D View 

3. In the Data Entry Panel, select the drop-down arrow next to the “Type” 

Attribute 

4. Select the guying type you would like to use.  
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The Type attribute gives the user a number of options regarding the type of 

guying to be used” 

Down (Down Guy) A down guy is modeled as an anchor set at 

a given distance and angle away from the 

pole, with one or more attached guy wires.  

Span/Head (Span Guy) A span guy, also called a stub guy, or a guy 

to a stub pole, models a blue “stub pole” 

and one or more associated guy wires.  

Sidewalk (Sidewalk Guy) A sidewalk guy models an anchor set at a 

given distance and angle away from the 

pole with one or more attached guy wires 

connedted to one or more struts.  

 

Use of this type creates a new filter option 

in the data entry panel called Sidewalk.  

Crossarm (Crossarm Down Guy) A crossarm guy models a standard down 

guy, with the ability to make the attachment 

point a crossarm instead of the pole.  

CrossarmSpan (Crossarm Span Guy) A crossarmSpan guy models a standard 

span/head guy, with the ability to attach the 

guy wire to a crossarm instead of the pole.  

Pushbrace A pushbrace models a pole to support the 

structure being modeled, rather than an 

anchor/guy wire combination.  

 

The pole height and class of the push pole 

cannot be set.  

Truss (Truss Guy) A truss guy models a guy wire with several 

attachment points on the pole, rather than 

an attachment point connected to an anchor 

on the ground. This model also includes 

two struts.  

 

 Merging Struts (Strut Compression) 

O-Calc ® Pro offers the ability to combine comparable struts into one strut 

for analysis as a single entry.  The struts need to be placed on the pole on the 

same anchor and at almost the same height, angle, and length before they can 

be combined.  Once the struts are combined the forces by multiple wires on 

the same strut.  To combine comparable struts, complete the following steps: 

1. Select the guys you would like to merge in the Inventory Window. 
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Note: Multiple guys can be selected concurrently by holding down the ctrl key to 

select more than one guy that is out of sequence.  If the guys are next to each 

other hold down the shift key to select them. 

 

 

2. In the Data Entry window toggle the Merge Like Struts attribute to Yes. 

 

Note: All windows within O-Calc® Pro are automatically recalculated and 

updated to reflect the attribute selection.  
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Note: O-Calc ® Pro provides a Strut Evaluation Summary so you can easily evaluate the load applied 

to a sidewalk guy strut arm by the guy or guys impinging upon it.  To display the Strut Evaluation 

Summary see Viewing the Data in Reports. 

Modifying Span Drop Rise 

To modify the span drop rise of a span, complete the following steps: 

1. Select the span in either the Inventory or 3D View 

2. In the Data Entry panel, enter a value under the Edit Drop/Rise (Ft) 

attribute 
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*Note: When modifying the height of the pole, it is also possible to maintain the 

set heights of the opposite ends of the span created by entering an End 

Drop/Rise.  

 

Maintaining Span Height after Pole Modification 

To ensure the attachment heights of the opposite end of a span are 

maintained if the height of the pole is changed, follow the following steps: 

1. Select the pole in the Inventory or 3D View 

2. Right-Click on the pole and select Substitute Pole 

3. Select the new pole properties and select OK 

4. In the Height Adjustments Window that opens, check the box labeled 

Keep Span End Heights 

 

Change the Display Description  

To change the description that displays next to a pole or attached equipment, 

complete the following steps: 

5. Right click on the pole or attached equipment you want to change the 

display description of. 

6. Select Description of (pole or equipment display name). 
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7. Enter the Description you would like to be displayed. 

 

Note: Select Clear to clear the description field and use the default value. 

8. Select OK. 

Note:  To undo the display description change, select Edit>Undo. 

Deleting Attached Equipment  

To delete equipment that is attachment to the pole in 3D View, complete the 

following steps: 

1. Right click on the attached equipment to be deleted. 

2. Select Delete (pole or equipment display name).   

 

Note: To undo the deletion, select Edit>Undo. 

Substituting Attached Equipment 

To substitute attached equipment in the 3D View, complete the following 

steps: 

1. Right click on the attachment you would like to substitute. 

2. Select Substitute (equipment display name). 
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Note:  Available tabs are dependent on corresponding equipment displayed in 

your catalogs or Inventory Window. 

3. To substitute equipment from the catalog tabs or the Inventory tab 

select the appropriate tab and select the equipment you want to use as a 

substitute. 

Note: For additional information on the Catalog Window see Working With the 

Catalog Window. 

4. Select the Attribute Values tab to modify the equipment attributes. 

5. Select OK. 

Note: To undo the substitution, select Edit>Undo. 

Substituting a Pole  

To substitute a pole in the 3D View O-Calc® Pro provides you with three 

options.  You can either manually select the substitute pole, select the 

substitute pole from the Catalog Window or you can use the Pole Solver 

option to help you select the substitute pole.  The pole solver option will 

display the minimum pole class and the estimated capacity that would be 

used based on the pole’s current load.  To substitute the current pole, 

complete the following steps: 

1. Right click on the pole you would like to substitute. 

2. Select Substitute (pole’s display name). 
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Note: Available tabs are dependent on corresponding poles displayed in your 

catalogs or Inventory Window 

3. Use one of the following methods to select the substitute pole you want: 

Note: The Estimated Capacity percentage will automatically be updated 

dependent on your attribute selections. 

A. Manually select the substitute pole attributes using the Attr 

Values or Standards tab. 

B. To select the substitute pole from a Catalog select the 

appropriate tab and select the pole you want to use as a 

substitute.  The attributes can still be modified if needed. 
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Note: For additional information on the Catalog Window see Working 

With the Catalog Window. 

C. Select the Use Pole Solver button  to have O-Calc® 

Pro automatically select the minimum Pole Class that would 

provide you with a passing pole. 

4. Select OK. 

If there are attachments already on the pole the Height Adjustment 

window will automatically be displayed.  The Height Adjustment 

window allows you to adjust the substitute poles depth and the height of 

the attachments relative to groundline or the tip of the substitute pole. 

 

5. Modify the Pole Depth if required. 

6. Verify and change each primary attachments height if required. 

7. Select OK. 

Note: To undo the substitution change, select Edit>Undo. 

Create a New Version of the Existing Pole 

While working with a pole in the 3D View it may be beneficial to compare 

multiple versions of the pole simultaneously.  O-Calc® Pro provides the 

ability to create multiple pole versions without losing any of the functionality 

that O-Calc® Pro is known for. 

To create a new version of the existing pole in the 3D View, complete the 

following steps: 

1. Right click on the Pole in the 3D View that you would like to create 

another version of. 

Note: The pole will automatically be highlighted in yellow once selected. 
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2. Select New>Version of This Pole. 

 

Note: To remove the new version, select Edit>Undo. 

 

 

The new version automatically becomes the active version in the 3D 

View.  The active version of a pole is always outlined in red  in the 

Inventory Window to easily identify which pole’s data is being displayed 

in O-Calc ® Pro. 

When saving a pole, all the versions of the pole will be saved at that 

time.  

Repositioning Object in 3D View  

Objects can be reposition from within the 3D View by selecting the object to 

be repositioned and using the following shortcut keys:  

Angle Holding down the “A” key and selecting an 

object allows you use the mouse to rotate the 

object to reposition it.  

Vertical Holding down the “V” key and selecting an 

object allows you to use the mouse to reposition 

the object up or down.  

Horizontal Holding down the “H” key and selecting an 

object allows you to use the mouse to reposition 

the object to the left or the right.  (Use the “G” 

key option if the front of the object is facing 

you).  

Reverse Horizontal Holding down the “G” key and selecting an 

object allows you to use the mouse to reposition 

the object to the left or the right.  (Use the “H”  

keys if the back of the object is facing you) 
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Changing the Compass Angle in 3D View  

To manually change the compass angle in the 3D View and have the 3D 

View automatically snap to that orientation, complete the following steps:  

1. Click on the Angle in the 3D View Compass. 

Note: The compass angle can also be changed by right clicking on the compass 

and selecting Set Camera Look Angle. 

 

2. Enter the new compass angle (camera angle). 

 

Note: The current angle is automatically displayed. 

3. Select OK. 

Changing the Camera Elevation in 3D View  

To manually change the camera elevation in the 3D View and have the 3D 

View automatically snap to that orientation, complete the following steps:  

1. Click on the Elevation in the 3D View Compass. 

 

2. Enter the new camera elevation. 

 

Note: The camera elevation is automatically displayed. 

3. Select OK. 

 

 

Compass angle 

Camera Elevation 
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Resetting the Camera Position in 3D View  

To reset the 3D View back to the default view, complete the following steps:  

1. Select View>3D View>Reset Camera Position. 

 

The 3D View is automatically reset back to the default 3D view. 

Note: The camera position can also be reset by right clicking on the compass 

and selecting Reset Camera or holding down the ctrl key and right clicking on 

the 3D View background display and selecting Reset Camera Position.  

Changing to an Overhead View  

To change the 3D View to an overhead view or “Bird’s Eye View”, complete 

the following steps:  

1. Select View>3D View>Bird’s Eye View. 

 

The 3D View is automatically changed to the overhead view. 

Note: When the Bird’s Eye View option is selected the compass and basic 

movements such as rotating and panning are disabled.  

Note:  The overhead view can also be accessed by right clicking on the compass 

and selecting Bird’s Eye View or by holding down the ctrl key and right clicking 

on the 3D View background display and selecting Toggle Bird’s Eye View. 

 

Saving the 3D View   

To easily access the current 3D View at a later time you can save the current 

3D View to a .png file or place the 3D View on the clipboard.  

Place the 3D View on the Clipboard  

To place your current 3D View on the clipboard, complete the 

following steps: 

1. Select View> Save 3D View to> Clipboard. 
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Note: The 3D View is automatically placed on the clipboard for later 

use. 

Note: A Copy 3D View to Clipboard option is also available by holding 

down the ctrl key and right clicking on the 3D View background 

display. 

Save the 3D View  

To save your current 3D View to a .png file, complete the following 

steps: 

1. Select View> Save 3D View to> Image File. 

 

Note: To adjust the size of the 3D View image being saved select Saved 

Image Size. 

Note:  The Save 3D View to File option can also be accessed by 

holding down the ctrl key and right clicking on the 3D View 

background display. 

2. Browse to where you want to save the 3D View .png file and 

select Save. 

3. Select OK to the confirmation message. 

 

Print the 3D View  

To print the current 3D View, complete the following steps: 

1. Select View> Save 3D View to> Print 3D View. 
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Note: The 3D View is automatically printed to your default printer. 

Note:   The Print 3D View option can also be accessed by holding 

down the ctrl key and right clicking on the 3D View background 

display. 

Filtering the 3D View  

To filter the 3D View so that only the objects that are expanded in the 

Inventory Window display in the 3D View, complete the following steps:  

 

 

 

1. Select the Filter button   in the Inventory Window.  

 

 

 

 

 

 

 

 

 

 

 

 These two objects 
are collapsed in 
the Inventory 
Window but are 
displayed in the 
3D View. 
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2. To turn the filtering option off deselect the Filter button . 

Note:  The filtering option can also be turned off by selecting View>Reset All 

Filters or select the Filtering Notification  button and selecting the Reset 

All Filters option.  

Working with the Capacity Window 

Understanding the Capacity Window 

The Capacity Window displays a summary of the active poles capacity.  The 

summary provides you with a quick and easy to understand overview of the 

active pole capacity information.  The Capacity Window can be displayed in 

either a metered format, a more detailed summary view, or explicit for GO95 

load cases, a pole factor of safety view. 

About the Capacity Meter Display 

The Capacity Meter calculates the load capacity for the active pole.  The 

meter view displays the percent of the Pole Capacity, the Pole Stress and the 

guying adequacies.  

   

 

Enabling the Capacity Meter Display  

To enable the Capacity Meter Display, complete the following steps: 

1. To enable\disable the Capacity Meter Display option, select 

Options>Capacity Display>Capacity Meter Display. 

 
 

 

Pole Stress 

Chart 

% of Pole 
Capacity 
Gauge 

Guyed Status 
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Note: The Capacity Window will be in one of the three options.  A check mark 

will display next to the menu option that is the currently active option. 

Understanding the Capacity Meter Display  

The following tables describe the default color representations in the Pole 

Stress Chart and the Percent of Pole Capacity Gauge.  

Pole Stress Chart           % of Pole Capacity Gauge 

Display Color Description  Display Color Description 

Blue 0% Pole Stress  Green Acceptable Capacity 

Green …  Yellow Near Capacity 

Yellow  50% Pole Stress  Red At or Over Capacity 

Orange …    

Red 100% + Pole Stress    

Note:  Color Legend is also available from the Tools>View Color Legend. 

Note: The Capacity Meter display color schema can be changed by selecting a color 

schema from the Options>Visualization Color Scheme menu. 

 

         Acceptable Pole Capacity Example    Failed Pole Capacity Example 
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About the Detailed Capacity Display  

The Detailed Capacity Display calculates and displays the Maximum and 

Groundline moment, capacity utilizations, wind direction and guying 

adequacies for the active pole.   

  

Note: The appearance of the Detailed Capacity Display can be change to a flat style 

by selecting Options>Misc Options>Flat Visual Style. 

Enabling the Detailed Capacity Display  

To enable the Detailed Capacity Display, complete the following steps: 

1. Deselect Options>Capacity Display>Capacity Meter Display. 

 

Note: When the Capacity Meter Display is enabled the other two options are 

automatically disabled. Only one Display can be viewed at a time. 

Enabling the Factor of Safety Display  

To enable the Factor of Safety Display, complete the following steps: 

2. Deselect Options>Capacity Display>Factor of Safety Display. 
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Note: When the Factor of Safety Display is enabled the other two options are 

automatically disabled.  

 

Capacity Window Menu Display Options  

Right clicking on the Capacity Window background provides several 

options. 

 

Copy Image.   Select the Copy 

Image option to copy the current 

Capacity Window as an image to 

the clipboard so that the image of 

the Capacity Window can be 

pasted directly into other 

applications such as Microsoft 

Word, E-Mail, and Notepad etc.                                            

Copy Data.  Select the Copy Data 

option to copy the Capacity 

Window data to the clipboard so 

that the Capacity Window data can 

be pasted directly into other 

applications such as Microsoft 

Word, E-Mail, etc. 

Cancel. Select the Cancel option 

to close the Capacity Window 

menu option pop-up without taking 

any action. 
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Automatically Updating the Capacity Window  

To enable the Capacity Window to automatically be updated each time a 

change is made to the active pole, complete the following steps: 

1. To enable\disable the Auto Capacity Summary option, select 

Options>Capacity Display>Auto Capacity Summary. 

 

Note: When Auto Capacity Summary is enabled a check mark will display next 

to the menu option. 

Note:  To change the idle time interval between updates, see Set the Idle Time 

Interval.  

Manually Updating the Capacity Window  

If the Auto Capacity Summary option is disabled, you can manually update 

the Capacity Window by completing the following steps: 

1. Select View>Update Capacity Summary. 

 

 

Working with the Measure Window 

Measure Window Overview 

The Measure Window allows you to complete measurements using images 

that you have selected using the Osmose Digital Measurement Technology 

(DMT).  You can efficiently create measurements on heights, arbitrary 

lengths, conductor diameters or angles. 

Before any measurements are taken from an image the calibration needs to 

be set for that image.  See Setting the Calibration.  Once the calibration has 
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been set measurements can be completed.  As each measurement is 

completed the measurement is automatically updated in the Inventory 

Window, the 3D View, and the Data Entry Panel. 

The camera’s lens calibration needs to be set before any measurements can 

be taken.  To set a camera’s lens calibration see Working with the Lens 

Calibration Tool. 

Working with Images in the Measure Window  

Selecting Initial Images to Display  

To select the initial images needed to complete measurements, 

Reload complete the following: 

1. Select Edit>Pole Images>Select Images. 

Note: Images can only be added once a pole has been added to the 

Inventory Window. 

 

2. Select the Image Path Browse button  and navigate to the 

location where the images to be associated with the current pole 

are located and click OK. 
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3. Select the images to be associated to the current pole. 

Note: Hold down the ctrl key to select more than one image out of 

sequence.  Hold down the shift key to select a group of images that are 

next to each other 

4. Select OK. 

Selecting Additional Images to Display 

Additional images can be associated to the current pole at any time.   

To select additional images you need to complete measurements, 

complete the following steps: 

1. Select Edit>Pole Images>Add Images. 

2. Select additional images from the current Image Path. 

OR 

Select the Image Path Browse button and navigate to the 

location where the images to be associated with the current pole 

are located and click OK. 

3. Select the images to be associated to the current pole. 

Note: Hold down the ctrl key to select more than one image out of 

sequence.  Hold down the shift key to select a group of images that are 

next to each other. 

4. Select OK. 

Remove All Images 

To remove all the images that are displayed in the Measure Window 

for the current pole, complete the following steps: 

1. Select Edit>Pole Images>Remove All Images. 

Note: There is no option to remove individual images. 
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2. Select Yes to the confirmation message. 

Note: To undo the removal of all the images, select Edit>Undo. 

 

Remove Current Image 

To remove the current image that displays in the Measure Window 

for the current pole, complete the following steps: 

1. Select Edit>Pole Images>Remove Current Image. 

Remove all except current Image 

To remove all except the current image that displays in the Measure 

Window for the current pole, complete the following steps: 

1. Select Edit>Pole Images>Remove all except current Image. 

Print the Images that Display 

To print the images that display in the Measure Window for the 

current pole, complete the following steps: 

1. Select Edit>Pole Images>Print Current Image. 

OR 

To print all the images that are displayed in the Measure Window:  

1. Select Edit>Pole Images>Print All Images. 

Use the Current Image as the Primary Image 

To the currently displayed image as the primary image, complete the 

following steps: 

1. To use the currently selected image in the Measure Window as 

the primary image select Edit>Pole Images>Current Image as 

Primary. 

Reload Images  

To reload the images that display in the Measure Window for the 

current pole, complete the following steps: 

1. To reload the image in the Measure Window select Edit>Pole 

Images>Reload Image. 
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Set the Target Type  

Initially when the Measure Window is opened a Target Type is set by 

default.  The target type represents which Calibrated Visual Target (CVT) or 

Range Survey Pole was used when the image was captured.   

Set Default Target Type 

The default target type will display when you initially open the Measure tab. 

It is shown in the image below circled in red. Steps to change this target type 

follow. 

 

1. Under the Image drop-down list, select Set Default Target Type 

 

▪ Begin by choosing the type of target from the Type drop-down 

list; the types are Calibrated Reflectors, Range Pole, or Tip 

Groundline Mode 
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2. Select the specific target from the selected Type category 

▪ There are several options available under each Type category 

3. Click Select to set the new default target type 

Change Current Image’s Target Type 

 

To change the target type of only the current image being displayed in the 

Measure tab, complete the following steps: 

1. Under the Image drop-down list, select Change Current Image’s Target 

Type from the list 

2. Select the Type of target that will be used as the target for the current 

image. 

3. The types are Calibrated Reflectors, Range Pole, or Tip Groundline 

Mode 

4. Select the specific target from the list, and click Select to set the target 

type for the current image 

 

Understanding the Measure Window 

The Measure Window provides a variety of tools designed to allow the user 

to complete image measurements, review and enhance image data. 
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Toolbar Menu Options 

The toolbar menu provides you with a variety of operations and options. 
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Image.  The following options 

are available from the Image 

menu: 

Save Image As.  Select the Save 

Image As option to save the 

current image as a variety of file 

types (JPEG, BMP, GIF or PNG). 

Copy Image to Clipboard. Select 

the Copy Image to Clipboard 

option to copy the current 

selected image to the clipboard so 

that the image can be pasted 

directly to other applications such 

as Microsoft Word, E-mail, etc. 

Copy Viewport to Clipboard. 

Select the Copy Viewport to 

Clipboard option to copy the 

selected image as it is currently 

displayed to the clipboard.   The 

copied image can then be pasted 

directly to other applications such 

as Microsoft Word, E-mail, etc.  

Set Default Target Type. Select 

the Set Default Target Type 

option to select the Calibrated 

Visual Target (CVT) that was 

used in order to get accurate 

measurements. 

Change Current Image’s Target 

Type. Select the Change Current 

Image’s Target Type option to 

change the currently selected 

(displayed) images target type. 

Display EXIF Information.  

Select the Display EXIF 

Information option to display the 

metadata in the image. 
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View.  The following options are 

available from the View menu: 

Magnifier. Click the Mag option 

to show or hide the magnification 

window.  With the magnification 

window displayed, move the 

mouse anywhere in the image to 

view that area in the 

magnification window.   

X Magnification. Select the 

magnification level to use with 

the Magnification Window. 

Smooth. Click the Smooth option 

to smooth hard edges of the 

image. 

Reset. Click the Reset option to 

undo any display/enhancement 

options that were selected.   

Show Labels. Select the Show 

Labels option to toggle the labels 

on and off. 

Show Label Background.  

Select the Show Label 

Background option to outline and 

enhance the label backgrounds. 

 
Zoom to Fit. Click the Zoom to 

Fit option to reset the image to its 

original size. 

 
Bright. Click the Bright option to 

brighten the image. 

 
Dim. Click the Dim option to 

darken the image. 

 
Invert. Click the Invert option to 

invert the colors of the image. 

 
Grayscale. Click the Grayscale 

option to set the image to black 

and white. 
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Contr + Click the Contr + option 

to set the contrast higher.   

Increasing the contrast will make 

dark tones darker and the light 

tones brighter.  Using the 

Contrast option also affects the 

sharpness of the image. 

 
Contr - Click the Contr – option 

to set the contrast lower. 

 

Rotate.  Select the Rotate option 

to rotate the image 90 degrees to 

the right or left. 

 
Reload.  Select the Reload option 

to reload the images that display 

in the Measure Window. 

 

The Image Viewer also provides several ways to navigate within the image 

by providing the following tools: 

Mouse Wheel You can use the mouse wheel to interact 

with the image.  To zoom in or out scroll 

the mouse wheel forwards or backwards.   

To pan, click the mouse wheel down and 

drag the image to shift the location of the 

image.  

Associated Images All images that are associated or related to 

the selected feature are displayed as 

thumbnails on the upper right side of the 

Image View window.  Select a thumbnail to 

change which images measurements are 

going to be completed on. 

Navigation Pane Clicking a point in the Navigation Pane will 

center the image on that point in the Image 

View Window. 

Scale Tool   

Click different levels on the scale to zoom-

in or zoom-out to see more details in an 

image. 
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Measure Mode Selector 

 

Click a Measure Mode to activate the 

measurement tool for the selected mode.  

Only task of the selected type will be 

available to measure.  Note the Image must 

be Calibrated before the Measure Mode 

tools are available.  

 

Setting the Calibration  

When the Measure Window is initially opened the Calibration Mode is 

selected by default.  The Calibration measurement needs to be completed 

once on each image before any other measurements are taken on that image.  

To complete the Calibration measurement, complete the following steps:  

1. Select the image you will use to set the Calibration. 

Note: When setting the calibration, the cursor will change to a measurement 

sight   enabling you to get a precise measurement. 

2. The Calibration Mode requires 3 – 4 measurements, based on the target 

type (For a CVT Target).  Place the measurement sight where the first 

calibration point is and click the left mouse button.  A red plus sign  

marks your first calibration measurement. 

3. Using the measurement sight set the remaining calibration point 

locations.  

 

Once all the Calibration measurements are completed the next mode will 

automatically be selected.  At this point you can select any of the 

available modes to complete measurements on. 
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Note:  If you need to redo the calibration measurements after they have been 

set, select the Calibration Mode and complete steps 2 and 3 as directed above.  

At this time there is no cancel or undo options for the Calibration Mode.    

Note:  Changing the Calibration measurement does not affect any of the 

measurements that have already been completed.  If you change the Calibration 

measurement any measurements you have completed need to be redone.   

Note: When using IKE Images the Calibrate Mode is automatically changed to 

Select GL.  This mode only requires one point on the image before additional 

measurements can be taken.  If the ground line is not visible in the image an 

offset value can be entered by selecting File>Groundline Offset after the initial 

Select GL point has been added. 

Overview of the Measurements Mode Selector 

To complete measurements you will need to select the corresponding Mode.   

Each Mode uses a different visual tool to help you complete the 

measurements.   

Mode Selected Visual Tool 

Calibrate Calibrate.  Click the Calibrate Mode and the 

cursor will change to a measurement sight  

for an accurate measurement.  

Height Mode Height Mode. Click the Height Mode and the 

cursor will change to crosshairs  for an 

accurate measurement of height relative to 

groundline. 

Arbitrary 

(Arbitrary Length) 

Mode 

Arbitrary Mode. Click the Arbitrary Mode and 

the cursor will change to crosshairs   for an 

accurate measurement between two points in the 

plane of the target.  

Cond Dia 

(Conductor 

Diameter) Mode 

Cond Dia Mode. Click the Cond Dia Mode and 

draw a line to accurately determine the 

conductor size.  

Angle Mode Angle Mode. Click the Angle Mode and the 

cursor will change to crosshairs  to 

accurately calculate angles.   

 

Note: If a mode is selected that does not have any associated task an error message 

will be displayed. 

Height Mode Measurements  

The height is relative to the groundline of the pole.  To complete a Height 

measurement, complete the following steps:  

1. Select the equipment in the Inventory Window that you want to measure 

the height of. 
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2. Select the Height Mode. 

 

3. Place the crosshairs at the point you want the Height measurement to be 

taken at. 

4. Left click, a menu listing the Height Task to be performed is displayed.  

Select the Height Task you would like the measurement associated with.   

 

Note:  To trim the pole top but keep the taper and setting depth, select 

Advanced>Trim Top. 

5. The Inventory and Data Entry windows will automatically be updated 

to reflect your measurement. 

Note: To cancel the current Height measurement, select the Cancel Option.  If 

you need to retake the measurement after it has been set, completed steps 1 thru 

4 as directed above.   There is no undo option available. 

Using Control Points 

When there is no CVT Stick or Range Pole in the images, 

measurements can be taken using Control Points set in the image, if 

the Target Type has been set to no CVT. Control Points can be used 

in the following way: 

1. Set the Current Image’s Target Type to be None, under the 

type drop down option Tip Groundline Mode 

2. While in Calibrate mode, place a crosshair at the base the pole 

3. While in Calibrate mode, place a crosshair at the top of the pole 

4. While in Height mode, hold down the Ctrl on the keyboard, and 

click a point on the pole with a known height 

5. When Prompted to enter the control point height, type in the 

value that is known to be the height at that point 

 

6. Select OK 
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Note: Only one control point can be used at a time. Control points ensure 

greater accuracy of attachment heights near the control point, when no CVT 

or Range pole is available in the image.  

Arbitrary Mode Measurements  

To complete an Arbitrary measurement between two points in the plane of 

the target, complete the following steps:  

1. Select the equipment in the Inventory Window that you want to take an 

Arbitrary measurement of. 

2. Select the Arbitrary Mode. 

 

3. Place the crosshairs at the point you want the Arbitrary measurement to 

start. 

4. Hold down the left mouse button and draw a line to where the Arbitrary 

measurement ends. 

5. Left click and select the Arbitrary Task you would like the measurement 

associated with. 

 

6. The Inventory and Data Entry Windows will automatically be updated 

to reflect your measurement. 

Note: To cancel the current Arbitrary measurement select the Cancel Option.  If 

you need to retake the measurement after it has been set, completed steps 1 thru 

5 as directed above.   There is no undo option available. 



Osmose O-Calc® Pro 5.3                                    Confidential User’s Guide 

160                  ©2018 Osmose Utilities Services, Inc. 

Cond Diam Mode Measurements  

The Cond Diam (Conductor Diameter) is used to collect wire sizes.  To 

complete a Conductor Diameter measurement, complete the following steps:  

1. Select the equipment in the Inventory Window that you want to measure 

the diameter of. 

2. Select the Cond Diam Mode. 

 

3. Place the cursor on the middle of the Conductor whose diameter you 

want to measure. 

4. Hold down the left mouse button and drag along the conductor until the 

yellow line is the same width as the conductor then release the mouse 

button.  

5. Left click and select the Conductor Diameter Task you would like the 

measurement associated with. 

 

6. The Inventory and Data Entry Windows will automatically be updated 

to reflect your measurement. 

Note: To cancel the current Conductor Diameter measurement, select the 

Cancel Option.  If you need to retake the measurement after it has been set, 

completed steps 1 thru 5 as directed above.   There is no undo option available. 

Angle Mode Measurements  

Angle measurements need be entered into O-Calc® Pro manually.  To assist 

you in measuring an Angle, complete the following steps:  

1. Select the equipment in the Inventory Window that you want to measure 

the angle of. 

2. Select the Angle Mode. 
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3. Place the crosshairs at the point you want the Angle measurement to 

start. 

Note:  The Angle measurement is a three point process.  After the Angle 

measurement is complete the Angel measurement is displayed for reference 

purposes only. 

4. Click the left mouse button and draw your first line, click the left mouse 

button again and draw your second line. 

 

5. Left click and the Angle measurement is automatically displayed for 

reference purposes. 

Note: If you need to retake the measurement, completed steps 1 thru 5 as 

directed above.   There is no undo option available. 

Adding Measurement Information to a Note 

To add measurement information to an existing note, complete the following 

steps: 

1. Select a note object in the Inventory Window. 

  

2. Select the Mode you would like to use for the measurement.  

 

Note Object 
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3. Place the crosshairs at the point you want the measurement to be taken 

at and click the left mouse button.  You may want to use the Scale Tool 

or the mouse wheel to zoom into a specific area in the image. 

 

 

4. The selected note in the Inventory Window automatically is displayed. 

 

5. Complete any edits to the notes description, note context or spreadsheet. 
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6. Select Edit>Paste to incorporate the measurement into the note content 

area of the note.  The selected measurement is automatically inserted into 

the selected note. 

 

7. To have the measurement automatically pasted into the spreadsheet, 

select the cell you want to paste the measurement into and select one of 

the following options from the Sheet menu: 

Sheet>Paste>Value Only - Will exclude the measurement text and only 

paste the measurement value into the spreadsheet.  

Sheet>Paste>All Text - Will paste the complete measurement into the 

spreadsheet with nothing excluded.  

 

8. Select File>Save. 

Adding Specific Measurements to the Notes Data Grid 

To add specific measurements to the Data Grid while working in the 

Measurement Window you can create custom Measurement Labels in a 

Note’s Data Grid.  These Measurement Labels display each time the note is 

selected while completing measurement.  To create a Measurement Label in 
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a note and use them to paste measurements directly into the selected note, 

complete the following steps: 

1. Create a new note object or open an existing note object in Edit Mode. 

2. Enter a description and the note context. 

3. Select a cell in the Data Grid View and enter a Measurement Label. 

There is not limit as to the number of Measurement Labels you can enter.  

The only exception is that the measurement label needs to be entered 

with brackets around it <Measurement Label>. 

As there is no measurement value enter, place holder values of zero 

where you would like the measurement value to be entered.  Also, enter 

calculation formulas if they are needed.  

 

 

4. Select File>Save. 

5. Select the note object in the Inventory Window. 

6. Select the Measure Tab. 

7. Click the left mouse button where you would like each measurement 

taken from and select the appropriate Measurement Label. 

 
Measurement Labels 
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8. To return to the select note object left mouse click and select Show Note. 

 

Note: Additions and modified can be made to any area of the note at any time.  

The note can also be copied to a User Catalog to be used as a template for 

future use. 

Note: If measurements have been incorporated into the Data Grid using 

Measurement Labels and the Units Convention (English or Metric Convention) 

is changed the measurements that are displayed in the Notes Data Grid will not 

change. 
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Working with the Data Entry Window 

Data Entry Overview  

The Data Entry Window works in conjunction with the Inventory Window.  

When selecting an object(s) in the Inventory Window the object’s attributes 

are displayed in the Data Entry Window.  This provides a comprehensive 

way to review or make changes to editable attributes.   

Editing Attributes  

To edit an attribute, complete the following steps: 

1. Select the Data Entry tab. 

2. Select an object in the Inventory Window. 

 

 

3. The selected object displays in the Data Entry Window. 

  

4. Select the attribute to be edited in the Data Entry Window. 

Note:  If additional attributes are available a drop-down menu will display next 

to the selected object’s name in the Data Entry Window.  Select the drop-down 

menu to display additional attributes. 

5. Press the space bar and edit the selected attribute. 

Note: Certain attributes are only editable in Administrative User Mode.  If you 

are no in Administrative User Mode, the attribute will be grayed and not 

changeable. 
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Note: For a complete list of the editable icon’s descriptions Editing Equipment 

Attributes. 

6. Select Enter. 

 

Expand All Attributes  

By default, a list of standard, most commonly used, attributes are initially 

displayed in the Data Entry Window when an object is selected in the 

Inventory Window.  To change the default setting so that all the selected 

object’s attributes are displayed, complete the following steps: 

1. Select Options>Info Tips and Data>Expand all Attributes in Data 

Entry Panel. 

 

Note: When the Expand All Attributes in Data Entry Panel option is enabled a 

checkmark will display next to the menu option.  When the option is disabled the 

check mark is not displayed. 

Display Multiple Attributes  

To display multiple objects for review or editing from the Inventory 

Window, complete the following steps: 

1. Select the Data Entry Window. 
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2. Select several objects in the Inventory Window. 

 

Note: Hold down the ctrl key to select more than one object out of sequence.  

Hold down the shift key to select a group of objects that are next to each other. 

3. The selected objects are displayed in the Data Entry Window. 

 

Note:  When multiple objects are displayed in the Data Entry Window all like 

objects are automatically grouped together.  

Display Multiple Corresponding Attributes  

To display multiple objects that are of a specific type, that are all on the same 

hierarchy level, for review or editing from the Inventory Window, complete 

the following steps: 

1. Right click on the object you want to review in the Inventory Window. 

2. Select Select All of Type. 

 

3. The selected object and any like objects within that hierarchy level are 

displayed in the Data Entry Window. 
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Creating a Custom Attribute List 

To create a custom list of attributes to view in the Data Entry Window, 

complete the following steps: 

1. Select an object in the Inventory 

2. In the Data Entry Window, select the attributes filter box. 

 

3. From the filters drop down list, select Custom Filters. 

 

4. A Custom Filter Editor window will open; select the Add Filter option 

and name the custom filter, check boxes to create a new custom list of 

attributes for the filter. 
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5. Select the attributes to be included in this filter list from the available 

checklist of Attributes Displayed. 

6. Once Selections have been made, select OK. 

7. In the Data Entry Window, open the filters drop down list. 

8. The new custom list of attributes will display at the top of this list. 

 

Note: Custom Filter lists can be deleted in the Custom Filter Editor Window.  

 

Working with the Top View Window 

About the Top View Window  

The Top View Window displays a polar view of the pole with span angles. 

Changing the Ganged Geometry or the Line of Lead will automatically 

change all the spans.   
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Top View Display Options 

The Top View provides you with a variety of operations and options. 

Functionality Icons Description 

 
Zoom-Out.  Click the Zoom-Out 

option to zoom the display out. 

Zoom-In. Click the Zoom-In option 

to zoom the display in. 

 
Ganged Geometry Editor.  Click 

the Ganged Geometry Editor option 

to set of span direction or to change 

a span length.  Note this also 

automatically selections all the 

spans in this given direction. 

 
3D Compass.  Click the 3D 

Compass option to have the Top 

View Window track the 3D View 

Compass.  Check the 3D Compass 

box if you want this option to 

always be enabled. 



Osmose O-Calc® Pro 5.3                                    Confidential User’s Guide 

172                  ©2018 Osmose Utilities Services, Inc. 

 

Reset.  Check the Reset option to 

undo any display options that were 

selected.  

Note: This does not undo any changes 

completed in the Ganged Geometry 

Editor or to the Line of Lead. 

 Line of Lead.  Click the Line of 

Lead option to change the line of 

lead. 

 Angle Filter. Click and drag the 

Angle Filter button to set the area 

to be filtered. 

 Position the Angle Filter. Click and 

drag the Position Angle Filter 

button to reposition the Angle 

Filter. 

 

Change the Zoom Level 

To change the zoom level of the Top View display, complete the following 

steps: 

1. Click the Zoom In button  to zoom in the view of the spans.  Click 

the Zoom Out button  to zoom out the view of the spans.  

Note: To remove the display level select the Reset button . 

Change the Ganged Geometry 

 

   
 

To change the Ganged Geometry, complete the following steps: 

1. Select the Ganged Geometry object  to be changed.  
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Note: Selecting a span in the Inventory Window will highlight the span in the 

Top View Window. 

 

2. Select the Mode from the drop-down list. 

3. Enter an Add Offset Angle, modify the Span Length and End 

Drop/Rise. 

4. Check Rotate Entire Structure to rotate the entire structure. 

  

5. Select OK. 

   

Note:  To undo the Ganged Geometry change, select Edit>Undo.  

 

Incorporating the 3D Compass View  

To incorporate the 3D Compass direction into the Top View, so that the 

spans are displayed in the Top View in the same direction as the 3D View, 

complete the following steps: 
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1. Click the 3D Compass button .  The display is automatically rotated 

to match the 3D View.  

Note: To enable the 3D Compass tracking so that every time the 3D View is 

repositioned the Top View Window automatically tracks the change, check the 

3D Compass box .  Deselect the 3D Compass check box to disable 

tracking. 

Reset the Top View Display  

To undo any changes to the Top View display, complete the following steps: 

1. Click the Reset button . 

Note: Resetting the Top View display does not undo any changes that have been 

completed in the Ganged Geometry Editor or to the Line of Lead. 

Change the Line of Lead  

  

  

To change the line of lead, complete the following steps: 

1. Select the Line of Lead button  located in the center of the Top View.  

Note: The Line of Lead will rotate the complete pole and all the attachments on 

the pole. 

 

2. Enter a Main Angle. 
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3. Select OK.     

  

Note:  To undo the Line of Lead change, select Edit>Undo. 

Setting an Angle Filter  

When working with a pole that has numerous spans attached it may be 

beneficial to set an Angle Filter.  The Angle Filter allows you to set a filter so 

that only spans in a specific area are displayed.  

    

To set an Angle Filter, complete the following steps: 

 

1. To enable the Angle Filtering option, select Options>Options in 3D 

View>Angle Filtering. 
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2. Click and drag the purple icon to set the amount of area to be filtered. 

 

3. Click and drag the red icon to set the position of the filter. 

 

 

 

 

 

 

The area with the 
gray background 
will not be filtered. 

The area with the 
blue background 

will be filtered. 
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Note: To remove the Angle Filtering select the Rest button . 

Note: If you have multiple filters set you can remove just one or all of the filters 

by right clicking on the Filter Notification button  and selecting one of 

the Reset Filter options. 

 

Working with the Schematic Window 

About the Schematic Window  

The Schematic Window displays a side elevation view of the major 

equipment on the pole.  Within the Schematic Window you can change the 

height of the equipment or view basic information about the equipment. 

Note:  Hovering over the equipment height will display basic information about 

the equipment.   

Only the filter spans are 
displayed in 3D View. A filter notification icon is 

added to the 3D View. 
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Schematic Window Menu Display Options  

Right clicking on the Schematic Window background provides several 

options. 

 

Save Schematic View to 

File. Select the Save 

Schematic View to File 

option to save the current 

Schematic View as a variety 

of file types (JPEG, BMP, 

GIF or PNG) 



Osmose O-Calc® Pro 5.3                      Confidential                                                           User’s Guide 

©2018 Osmose Utilities Services, Inc.                                                                                                  179 

Copy Schematic View to 

Clipboard. Select the Copy 

Schematic View to 

Clipboard option to copy the 

current Schematic View to 

the clipboard so that the 

Schematic View can be 

pasted directly into other 

applications such as 

Microsoft Word, E-Mail, etc. 

Print Schematic View. 

Select the Print Schematic 

View option to print the 

currently displayed 

Schematic View. 

Cancel. Select the Cancel 

option to close the Schematic 

View menu option pop-up 

without taking any action. 

Display Above GL Portion Only  

To display only the portion of the pole above the groundline (GL), complete 

the following steps: 

1. Check the Above GL Portion Only option to display only the portion of 

the pole that is above the groundline.  Un-check the option to display the 

complete pole.  

Display Draft Pole Break  

To replaces a portion of the pole with no attachments with a drafting break, 

complete the following steps: 

1. Check the Draft Pole Break option to insert a temporary drafting break.  

Un-check the option to display the complete pole.  

 

Changing Equipment Height  

To change the equipment height, complete the following steps: 

1. Click on the equipment height you would like to change. 

  

Note: The current height of the equipment is automatically displayed.  
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2. Enter a new height for the equipment. 

3. Select OK. 

Note: To undo a height modification, select Edit>Undo. 

Setting a Height Filter  

To filter the spans on the pole according to height, complete the following 

steps: 

1. To enable the Height Filtering option, select Options>Options in 3D 

View>Height Filtering.  

  

 

2. Use the slider scale to set the filter height. 

 

 

 

 

 

 

 

Height Filtering 
Scale 
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Note: To remove the Height Filtering select the Reset button . 

Note: If you have multiple filters set you can remove just one or all of the filters 

by right clicking on the Filter Notification button  and selecting one of 

the Reset Filter options. 

 

 

 

 

 

 

 

 

 

 

Only the filter heights are 
displayed in 3D View. 

A filter notification icon is 
added to the 3D View. 

Constraints of 
the Height Filter 
scale. 
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Working With the O-Calc® Pro Data 

Viewing the Data in Charts  

Once a pole has been built in the Inventory Window you may want to 

perform a pole analysis.  Several predefined charts are available to help you 

complete a pole analysis.  

 

Note:  A pole needs to be displayed in the Inventory Window in order for data to 

display in the Charts. 

Toolbar Menu Options for Charts  

The charts toolbar menu provides you with a variety of operations and 

options.  

 

 

File. The following options are available 

from the File menu: 

Print Chart.  Select the Print Chart option 

to print the currently displayed chart. 

Page Setup. Select the Page Setup option to 

configure how the chart will be printed. 

Print Preview. Select the Print Preview 

option to preview the currently displayed 

chart exactly as it will be printed. 
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Condition Selector. Select MCU to see data 

at maximum capacity utilization or select 

GL to see data at groundline. 

 Select the appropriate Chart to display the 

pole analysis data in from the drop-down 

menu. 

 
Check the Ignore Sign option to ignore the 

Trans/Long values. 

 
Northing / Easting. Check the Northing / 

Easting option to plot the individual 

component vector lines in the selected chart. 

 
Check the Magnitude option to plot the 

Magnitude line in the selected chart. 

 Check the Capacity option to plot the 

Capacity line in the selected chart. 

 
Check the Total option to plot the sum of the 

individual components in the selected chart. 

 Select the left\ right arrow to scroll through 

and display the pole analysis data in a chart 

without having to use the chart drop down 

menu. 

Note: Available plotting options are dependent on the selected chart. 

Viewing Charts  

To perform a pole analysis using a Chart, complete the following steps:  

1. Load a pole that has a LoadCase in the Inventory Window. 

2. Select a Chart to be displayed from the available Charts drop down list. 

 

Once a Chart has been selected the Chart will automatically be loaded. 
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Note:  The chart uses the currently selected LoadCase when calculating and 

displaying a chart. 

Note:  Use the mouse wheel to zoom in and out on a specific area on the chart. 

To set the chart back to the default view, See Additional Menu Options for 

Charts. 

Additional Menu Options for Charts  

In addition to the basic menu options that are available, once a chart is 

displayed additional chart options are available.   Right clicking on the chart 

displays the additional chart options.  



Osmose O-Calc® Pro 5.3                      Confidential                                                           User’s Guide 

©2018 Osmose Utilities Services, Inc.                                                                                                  185 

 

Copy.  Select the Copy option to 

copy the current chart to the 

clipboard so that the chart can be 

pasted directly into other 

applications such as Microsoft 

Word, E-Mail, etc. 

Save Chart.  Select the Save 

Chart option to save the current 

chart as a variety of file types 

(JPEG, BMP, GIF, etc.). 

Show Point Values.  Select the 

Show Point Values option to 

display floating point values 

when hovering in a chart. 

Un-Zoom.   Select the Un-Zoom 

option to undo a previous zoom 

operation.  

Set Scale to Default.  Select the 

Set Scale to Default option to set 

the chart back to the default 

scale. 

Interpreting the Chart  

Each chart value is plotted using lines as identified by color in the chart 

legends. 

The line definitions are as follows:  

Capacity(Gray) The Capacity (Pole Fiber Stress X Strength Factor) is plotted on 

Moment and Stress Charts.   

Example: For a yellow southern pine (8,000 psi) under NESC 

Grade C (.85 strength factor) criteria, the pole’s allowable stress 

is plotted at 6,600 psi on a Total Stress chart. 

Easting (Blue) The Easting values are those perpendicular to the frame of 

reference and represent results in the 90°/270° direction.  

Easting values are plotted on all charts. 

Northing 

(Green) 

The Northing values are those in the direction of the northing 

value and represent results in the 0°/180° direction.  Northing 

values are plotted on all charts. 

Magnitude 

(Red) 

A non-directional value representing the summary of forces 

along the length of the pole.  This line is critical because it 

represents a combined value of the Easting and Northing 

directions.  This line represents the summary of forces acting on 

the pole. 
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Viewing the Data in Reports  

Once your pole has been built in the Inventory Window you may want to 

complete a pole analysis by generating a variety of reports.  An O-Calc ® 

Pro Analysis Report is provided to help you complete a pole analysis.  

 

Note:  A pole needs to display in the Inventory Window to enable the Reports option. 

Toolbar Menu Options for Reports  

The report’s toolbar menu provides you with a variety of operations and 

options.  

 

 

File. The following options are 

available from the File menu: 

Print Report. Select Print Report to 

print the current report. 

Page Setup. Select the Page Setup 

option configure how the report will be 

printed. 

Save to PDF.  Select Save to PDF to 

save the current report to edit an 

existing report template. 
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Save to RTF.  Select the Edit Report 

Template to edit an existing report 

template. 

E-Mail Report To.  Select the E-Mail 

Report To option to e-mail the currently 

viewed report.  

 Select the appropriate Report to display 

the pole analysis data in from the drop 

down menu. 

 
Click the Report Navigation Controls to 

navigate through the reports. 

 
Select the Refresh option to refresh the 

report window. 

 
Select the Batch Report option to open 

and work with the Batch Pole 

Reporting tool. 

 
Select the Custom Report option to 

create custom reports. 

 
Select the Manage Report option to 

manage what reports display in the 

Report drop down list. 

Note: Manage Report configurations are 

carried over to Bulk Reports 

 
Select the Auto option to automatically 

reload the currently displayed report 

after calculations have been performed.  
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Reports Toolbar Options 

Once a Report is displayed the report’s toolbar menu provides you with a 

variety of operation and options.   

 

Navigation Controls 

 

Click the Navigation Controls to 

navigate through the document. 

 
Select the Zoom drop down list to 

change the report magnification level.  

 
Zoom In/Zoom Out.  Click the Zoom 

In or Zoom Out buttons to manually 

zoom the currently selected report in or 

out.  

 
Zoom to Fit.  Click the Zoom to Fit 

option to automatically have the report 

fill the space provided. 

 
Page Count.  Displays the current 

page/the total pages in the report.    

 

Viewing Reports  

To view an existing report, complete the following steps:  

1. Load a pole that has a LoadCase in the Inventory Window. 

2. Select a Report to be displayed from the available Report drop down 

list.  

Note: The list of available reports is dependent on which reports are selected 

under Manage Report.  The list of available reports also corresponds with the 

currently loaded pole. (Example: The crossarm reports will not be displayed in 

the report list if there are no crossarms on the currently loaded pole). 
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Once a report has been selected the Report will automatically be loaded. 

Note: The report may take a moment to load. 

 

Note: The selected report uses the currently selected LoadCase when 

calculating and displaying a report. 
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Creating a Batch Pole Report  

The Batch Pole Report allows you to print report(s) against specific poles 

that you select.  To create a Batch Pole Report, complete the following steps:  

1. Select Tools>Batch Pole Report. 

Note: The Batch Pole Report option can also be accessed by selecting Batch 

Report in the Reports Window. 

  

 

 

 

Toolbar 

Pole to Process 

 

Display Layout 

 
Report 
Output 
Type 

 

PPLX File Options 

Bulk 
Reports 

 

Per-Pole 
Reports 
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Batch Report Workspace Description 

Toolbar Menu Options Add Poles. Select the Add Poles 

option to add poles that will be 

processed in the Batch Reports. 

Remove Poles. Select the 

Remove Poles option to remove 

poles that have been to the Poles 

to Process list.  

Printer Setup. Select the Printer 

Setup option to configure the 

printer that the Bulk Reports will 

utilize. 

Print Reports. Select the Print 

Reports option to print the 

currently selected batch reports. 

Display Layout Enables you to swiftly switch 

between different window 

layouts.   

Sort Files Select the Sort Files option to 

sort the PPLX files in 

alphabetical order when they are 

printed to files. 

All Versions Select the All Versions option to 

create a print to file report for 

each version within the selected 

PPLX files. 

Note: For additional information on 

pole versioning, see Create a New 

Version of the Existing Pole. 

All LoadCases Select the All LoadCases option 

to create a separate print to file 

report for each loadcase attached 

to a PPLX file. 
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Print to files Print to files. Select the Print to 

files option to print the currently 

selected batch reports into file 

format. 

File Per Report: Select the File 

Per Report option to create an 

individual file for each report 

selected.   

File Per Pole: Select the File Per 

Pole option to create one file per 

each processed pole.  

Single File: Select the Single File 

option to create a single file that 

includes all the selected Per-Pole 

Reports. 

Poles to Process Displays the poles that will be 

processed in the selected Batch 

Reports. 

(The order of the poles can be 

changed by using the drag-and-

drop option) 

Bulk Reports Displays a list of available Bulk 

Reports. 

(These reports print separate 

from the Per-Pole Reports) 

Per-Pole Reports Displays a list of available Per-

Pole Reports.   

(The order in which the reports 

will be printed can be changed by 

using the drag-and-drop option)  

 

2. Select the Add Poles button .   

3. Browse to the location of the pole(s) you wish to add to the Batch Report 

process and select the (pole name).pplx file and click Open. 

Note: Hold down the ctrl key to select more than one pole out of sequence.  

Hold down the shift key to select a group of poles that are next to each other. 
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Note:  To remove selected poles from Poles to Process area select the pole then 

select the Remove Poles button .  Hold down the ctrl key to select 

more than one pole out of sequence.  Hold down the shift key to select a group of 

poles that are next to each other. 

4. To change the order in which the (pole name).pplx file(s) will be printed 

click and drag the .pplx file. 

Note: When a. pplx file is being dragged to a new location the cursor will 

change to indicate a valid move  . 

5. Select the Bulk Report(s) to be include. 

 

6. Select the Per-Pole Report(s) to be included. 
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7. To change the order in which the Per-Pole Report(s) will be printed 

click and drag the report.  

  

Note: When a report is being dragged to a new location the cursor will change 

to indicate a valid move  .  To save the changed layout of the Batch Pole 

Reporting window see Save a Named View. 

 

8. Check the Sort Files to sort the PPLX files in alphabetical order when 

printed to file(s). 

 The O-Calc® Pro 
Clearance Report is 
repositioned to print 
before the Analysis 
Summary.  
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9. Check the All Versions to create a report for each version within the 

selected PPLX files. 

10. Check the All LoadCases to create a report for each loadcase attached to 

a PPLX files. 

11. Select the Print Reports button  to print the Batch Reports 

to your default printer. 

To print the Batch Reports to a different printer select the Printer Setup 

button  and select your printer of choice. 

OR 

Check the Print to files  option, select the Report Output 

Type then navigate to and select where you want the Batch Report files 

saved to. 

Note: Only the initial Pole Image will be included in the Batch Report.  

Subsequent images that are attached to the./pplx file will be printed or saved as 

individual PDF files as ‘pplx file name_image#’.  

Exporting Batch Pole Information  

The Export Batch Pole Information Report allows you to export specific pole 

attributes and calculation results to a .CSV file.  To export a Batch Pole 

Information, complete the following steps:  

1. Select Tools>Export Batch Pole Report Info. 

 

 

 

 

 

 

 

 



Osmose O-Calc® Pro 5.3                      Confidential                                                           User’s Guide 

©2018 Osmose Utilities Services, Inc.                                                                                                  197 

 

 

 

 

 

Pole Info Export Workspace Description 

Toolbar Menu Options Add Poles. Select the Add Poles 

option to add poles that will be 

processed in the export. 

Remove Poles. Select the 

Remove Poles option to remove 

poles that are listed in the Poles 

to Process list.  

Export Info. Select the Export 

Info option to export the selected 

items and calculations to a .CSV 

file. 

Check All Select the Check All option to 

select the entire Items to Export 

list. 

Uncheck All Select the Uncheck All option to 

uncheck the entire Items to 

Export list. 
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Display Layout Enables you to swiftly switch 

between different window 

layouts.   

All Versions Select the All Versions option to 

create a separate entry for each 

item and calculation based on 

each version within the selected 

PPLX files. 

Note: For additional information on 

pole versioning, see Create a New 

Version of the Existing Pole. 

All LoadCases Select the All LoadCases option 

to create a separate entry for each 

item and calculation based on the 

loadcase(s) attached to a PPLX 

file. 

Poles to Process Displays the poles that will be 

processed in the exported batch 

pole .CSV file. 

(The order of the poles can be 

changed by using the drag-and-

drop option) 

Items to Export Bulk Reports. Displays a list of 

available items (attributes) that 

can be exported. 

(The order of the items can be 

changed by using the drag-and-

drop option) 

Selected Items Displays a complete list of all the 

selected Items to Export. 

 

2. Select the Add Poles button .   

3. Browse to the location of the pole(s) you wish to add to the Batch Pole 

Information Export process and select the (pole name).pplx file and click 

Open. 

Note: Hold down the ctrl key to select more than one pole out of sequence.  

Hold down the shift key to select a group of poles that are next to each other. 
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Note:  To remove selected poles from Poles to Process area select the pole then 

select the Remove Poles button .  Hold down the ctrl key to select 

more than one pole out of sequence.  Hold down the shift key to select a group of 

poles that are next to each other. 

4. Select the Items to Export from the available list. 

 

5. To change the order in which the Items to Export will be displayed in 

the .CSV file click and drag an item to arrange the items placement.  

   

Note: When an item is being dragged to a new location the cursor will change 

to indicate a valid move  .  To save the changed layout of the Items to Export 

window see Save a Named View. 
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6. Select the Export Info button . 

7. Browse to the location you would like the Batch Pole Information Export 

saved to and enter a file name. 

8. Select Save. 

9. Select OK to the export confirmation message. 

Working with the Clearance Analysis Tool  

The Clearance Analysis Tool allows you to evaluate and report on clearance 

violations along the spans emanating from a pole.  Examples of clearance 

requirements that can be encoded and violations that might be found between 

them are: 

• Spans of different types (power to comm. for example) 

• Spans and structures or vehicles 

• Spans and surfaces 

• Spans and foliage 

 

The tool provides the ability to model actual field conditions accurately, 

giving you the ability to define elements arrayed under or interfering with the 

spans emanating from a pole. 

 

Creating a Clearance Analysis on a new or existing (transmission) pole 

allows you to take into effect field conditions such as surfaces (terrain), 

structures, foliage and wires.  The Clearance Analysis tool creates a 2D 

representation (model) of the spans and field conditions that you have input.  

A Clearance Analysis report is also available to easily detect any clearance 

issues.  
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Creating a Clearance Analysis is a four step process: 

 

1. Create Clearance Rules and Violations definitions. 

2. Using Clearance Group objects on specific spans to identify the 

category or categories that a span falls into. 

3. Recording the actual field conditions surrounding the pole (surfaces, 

structures and foliage). 

4. Running the Clearance Analysis report. 

 

Create Clearance Rules and Violations  

Before any Clearance Analysis can be completed Clearance Rules and 

Violations need to be set-up.  Creating these Clearance Rules and Violations 

should typically only be done once for any power company or division.   

Once the Clearance Rules or Violations have been established extreme 

caution is advised when removing or editing them after Clearance Analysis is 

configured.  Removing or editing existing Clearance Rules or Violations may 

invalidate existing clearance elements or rules.    

To create Clearance Rules and Violations, complete the following steps:  

1. Select Tools>Clearance Analysis>Edit Clearances Rules. 
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2. To add a Structure, Surface or Foliage element select the area you want 

to add an element to and either left click and select the Add button 

or right click and select Add from the popup menu. 

 

 

 

 

 

 

New Structure 
element is 
created 

Define the elements attributes 
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3. Enter the new element attributes. 

 

Note: Only the Structure area allows you to define a Shape.   

Note: When adding a Surface element a Default surface attribute is available if 

you would like to have a specific surface added by default when creating 

Clearance Analysis.   The default surface area can be changed at any time. 

4. Select File>Save. 

Note: Complete steps 2 – 4 to create additional elements for Structures, 

Surfaces and Foliage. 

Note: There is no undo for this operation.  To remove an element select the 

Structure, Surface or Foliage and select the Delete button   from the 

toolbar. The Delete option is also available by right clicking on the element and 

selecting Delete. 

5. Clearance Groups depict what categories spans can be a part of.   To add 

a Clearance Group either right click on Clearance Groups and select 

Add from the popup menu or left click Clearance Groups and select the 

Add button   . 
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6. Enter the new Clearance Group attributes. 

 

7. Select File>Save. 

Note: Complete steps 5 - 7 to create additional Clearance Group rules. 

Note: There is no undo for this operation.  To remove a Clearance Group rule 

select the Clearance Group to be removed and select the Delete button  

New Clearance 
Group is created 

Define the Clearance Group attributes 
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from the toolbar.  The Delete option is also available by right clicking on the 

rule and selecting Delete. 

8.  Rules and Violations define the rules and violations that will be used 

when completing a Clearance Analysis.  To add a Rule or Violation 

either right click on Rules and Violations and select Add from the 

popup menu or left click Rules and Violations and select the Add 

button . 

  

 

 

9. Enter the new Rules or Violations attributes. 

New Clearance 
Rule is created 

Define the Rule or Violation attributes 
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10. To set the Source and Target select the Source / Targets button . 

 

11. Check the Source(s) to be used. 

12. Check the Target(s) to be used. 

Note: Multiple Sources and Targets can be selected.  The only exception being 

that you cannot select the identical Source and Target. 

13. Select OK.  

14. Select File>Save. 
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Note: Complete steps 8 – 14 to create additional Rules and Violations. 

Note: There is no undo for this operation.  To remove a rule select the Rule and 

Violation item and select the Delete button  from the toolbar.  The Delete 

option is also available by right clicking on the rule and selecting Delete. 

 

Note: A comprehensive listing of all the current Clearance Rules is available by 

selecting File>Show Clearance Rules.  The O-Calc® Pro Clearance Analysis 

Rules report will display and is available for printing. 

Categorizing Spans  

Once the rules are in place you need to categorize the actual spans on the 

current pole.  To identify which spans go into specific categories you will 

need to place a Clearance object on each span.  To place a Clearance Objects 

on a span, complete the following steps:  

1. Select the Span to add a Clearance Object to. 

Note:  Spans can be selected from the Inventory Window, the 3D View or the 

User Catalog.  If a span is selected from the 3D View or the User Catalog use 

the right click menu to add a clearance object. 

2. Select the Add button . 

Note: The Add>Clearance option can also be accessed by right clicking on the 

span you need to add the Clearance Object to. 

3. Select the Clearance option. 

 

Note: Only one Clearance Object can be added at a time. 
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Note: Available tabs are dependent on corresponding equipment displayed in 

your Catalogs or Inventory window. 

4. To add a Clearance Object from one of the catalog tabs or the Inventory 

tab select the appropriate tab and select the clearance object you want to 

add. 

Note: For additional information on catalogs or the Inventory Window see 

Working With the Catalog Window or Working With the Inventory Window. 

5. Select the Attribute Value tab to modify the clearance object attribute 

values. 

 

Clearance attributes descriptions: 

➢ Description: A general description of the Clearance 

Object. 

➢ Clearance Group: The name of the Clearance 

Group. 

➢ Render in 3D View: A visualization of the vertical 

clearances. 

➢ Population Mode: Determines the method by which 

the midspan sag values are populated. 

Manual: Sag values are entered by the 

operator. 

Automatic: Sag values are populated 

automatically. 

External: An external process populates the 

values. 
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➢ Sag Minimum: Enter the minimum sag allowed at 

midspan. 

➢ Sag Nominal: Enter the nominal sag allowed at 

midspan. 

➢ Sag Maximum: Enter the maximum sag allowed at 

midspan. 

6. Click OK. 

 

Note: To undo the addition of the Clearance Object, select Edit>Undo.  

Create a Clearance Analysis Profile  

To model the actual field conditions surrounding the pole you need to create 

a Clearance Analysis Profile.  As you are creating the field conditions a 2D 

representation of the model will be displayed as a visual reference.  To create 

a Clearance Analysis Profile, complete the following steps:  

1. Select Tools>Clearance Analysis>Clearances and Violations. 
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2. The first step to modeling the actual field conditions is to set the vectors.  

Vectors are notional lines that extend outward from the pole at given 

angles and which describe the type and elevation changes of the surface 

under the pole.  Vectors may contain instances of structures and foliage 

that fall along that line.  Typically these vectors have a close 

correspondence with the spans attached to the pole, but this is not a 

requirement.   To set the Vectors select the Add Vectors button  

from the Vectors toolbar. 

Note: To automatically create a vector at each span angle select the Auto 

button from the Vector toolbar. 

 

3. Enter a Vector Angle. 

Note:  An overhead view of the pole with all the span angles is available by 

selecting the Overhead button .  The Overhead window utilizes 

some of the same features as the Top View window; see Top View Display 

Options  for a description of these options 

4. Select OK. 

Note: There is no undo or edit for this operation.  To remove a Vector Angle 

select the Vector Angle to be removed and either select the Delete button  

from the Vector toolbar or right click the Vector Angle and select Delete. 

5. To create a structure at a specific vector select the vector you want to 

add a structure object to. 
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6. Select the Add Structures / Surfaces / Foliage drop down menu and 

select Structure.  

 

 

7. Enter the structures attributes. 

 

8. Select OK. 

Note: Complete steps 5 – 8 to establish additional structures at a specific vector. 

Note: There is no undo for this operation.  To remove a Structure select the 

Structure to be removed and either select the Delete button  from the 

toolbar or right click the Structure and select Delete. 

9. To set the surface at a specific vector select the vector you want to add a 

surface object to. 

10. Select the Add Structures / Surfaces / Foliage drop down menu and 

select Surface. 
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11. Enter the surface attributes. 

12. Select OK. 

Note: Complete steps 9 –12 to establish additional surfaces at a specific vector. 

Note: There is no undo for this operation.  To Remove a Surface select the 

Surface to be removed and either select the Delete button  from the toolbar 

or right click the Surface and select Delete. 

13. To create the foliage at a specific vector select the vector you want to 

add a foliage object to. 

14. Select the Add Structures / Surfaces / Foliage drop down menu and 

select Foliage. 

 

 

15. Enter the foliage attributes. 

 

16. Select OK. 

Note: Complete steps 13 –16 to establish additional foliage at a specific vector. 
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Note: There is no undo for this operation.  To Remove Foliage select the 

Foliage to be removed and either select the Delete button  from the toolbar 

or right click the Foliage and select Delete. 

 

Note: Structures, Surfaces and Foliage can be edited at any time by selecting 

the object and either selecting the Edit button from the toolbar or right clicking 

on the object and selecting Edit. 

17. To Save the Clearance Analysis Profile select File>Exit.  Then in the O-

Calc® Pro main window select File>Save Pole. 

Running Clearance Analysis Reports  

The Clearance Analysis report displays any clearance violations along the 

spans you modeled.  A Clearance Analysis report can be run against all the 

vectors you’ve specified or just one vector. To run the Clearance Analysis 

report, complete the following steps:  

1. Select Tools>Clearance Analysis>Clearances and Violations. 
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2. Select the Clearance Analysis drop down menu. 

 

 

➢ Current Vector – Creates a Clearance Analysis report on the 

currently select vector in the Clearance Analysis window. 

➢ All Vectors – Creates a Clearance Analysis report on all the 

currently listed vectors in the Clearance Analysis window. 
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Clearance Analysis Reports Toolbar Options 

Once the Clearance Analysis report is displayed the toolbar menu provides 

you with a variety of options. 

  

 

File. The following options are 

available from the File menu: 

Print Report. Select the Print 

Report option to print the Clearance 

Analysis. 

Page Setup. Select the Page Setup 

option to configure how the 

Clearance Analysis will be printed. 

Save to PDF.  Select the Save to 

PDF option to save the Clearance 

Analysis as a PDF file. 

Save to RTF.  Select the Save to 

RTF option to save the Clearance 

Analysis as a RTF file. 

E-Mail Report To.  Select the E-

Mail Report To option to E-Mail the 

Clearance Analysis. 

Copy to Clipboard. Select the 

Copy to Clipboard option to copy 

the Clearance Analysis to the 

clipboard so that it can be pasted 

directly into other applications. 

Exit.  Select Exit to close the 

Clearance Analysis. 

Navigation Controls 

 

Click the Navigation Controls to 

easily navigate through the 

document. 

Zoom Controls 

 

Use the Zoom Controls to change 

the documents magnification level. 

 

Clearance Rules Maintenance  

The Clearance Analysis rules can be exported for use by other O-Calc® Pro 

users, preventing the need to develop a new set of Clearance Analysis rules.  

The export process makes a copy of the current Clearance Analysis rules and 

saves them in a location you specify.  The saved Clearance Analysis rules 

can then be imported into another users O-Calc® Pro application and be 

modified as needed.   
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Export Clearance Rules  

To export your Clearance Rules, complete the following steps: 

1. Select Tools>Clearance Analysis>Clearance Rules 

Maintenance> Export Clearance Rules. 

 

2. Browse to the location where you will save the Clearance Rules 

and click Save. 

3. Select OK to the export confirmation message. 

Import Clearance Rules  

To import Clearance Rules, complete the following steps: 

1. Select Tools>Clearance Analysis>Clearance Rules 

Maintenance> Import Clearance Rules. 

 

2. Browse to the location of the Clearance Rules file you want to 

import and select the (Clearance Rules name).crx file and click 

Open. 

3. Select OK to the import confirmation message. 

 

Viewing the LoadCase Comparison  

When several LoadCases are attached to a pole in the Inventory Window O-

Calc® Pro provides a LoadCase Comparison summary.  The LoadCase 

Comparison provides detailed calculations for each LoadCase and identifies 

and displays the worst LoadCase in the comparison.  

Create a LoadCase Comparison  

To create a LoadCase Comparison, complete the following steps:  

1. Select Tools>LoadCase Comparison. 
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Note: A pole with more than one LoadCase needs to be displayed in the 

Inventory Window to enable the LoadCase Comparison option.  The pole should 

also have the latest calculations displaying in the Capacity Window.  If the Auto 

Capacity Summary is disabled and calculations need to be performed the 

LoadCase Comparison option will be disabled.  See Manually Updating the 

Capacity Window to manually update the calculations. 
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LoadCase Comparison Toolbar Options 

Once the LoadCase Comparison is displayed the toolbar menu provides you 

with a variety of options. 
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File. The following options are 

available from the File menu: 

Print Report. Select the Print 

Report option to print the 

LoadCase Comparison. 

Page Setup. Select the Page 

Setup option to configure how 

the LoadCase Comparison will 

be printed. 

Save to PDF.  Select the Save 

to PDF option to save the 

LoadCase Comparison as a 

PDF file. 

Save to RTF.  Select the Save 

to RTF option to save the 

LoadCase Comparison in RTF 

format. 

E-Mail Report To.  Select the 

E-Mail Report To option to E-

Mail the LoadCase 

Comparison. 

Copy to Clipboard. Select the 

Copy to Clipboard option to 

copy the LoadCase 

Comparison to the clipboard so 

that it can be pasted directly 

into other applications. 

Exit.  Select Exit to close the 

LoadCase Comparison. 

Navigation Controls 

 

Click the Navigation Controls 

to easily navigate through the 

document. 

Zoom Controls 

 

Use the Zoom Controls to 

change the documents 

magnification level. 

 

Working with the Strength Reduction Calculator  

The Strength Reduction Calculator allows you to calculate and apply the 

effective groundline circumference using the Osmose industry accepted 

strength calculations.  

Create a Strength Reduction Calculation  

To create a Strength Reduction Calculation, complete the following steps:  
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1. Select Tools>Strength Reduction Calculator. 

   

Note:  When the Strength Reduction Calculator is initially opened some of the 

fields will already pre-populated with information from the pole.   

 

 

2. Adjust the Original GL Circumference (if necessary). 

3. Adjust the Shell Rot Circumference (if necessary). 

4. To include Heart Rot check Include Heart Rot. 

5. Adjust the Heart Rot Shell Thickness if Include Heart Rot is checked. 

For each instance of decay or damage perform steps 6 – 10: 

6. Select the Add button . 

 



Osmose O-Calc® Pro 5.3                      Confidential                                                           User’s Guide 

©2018 Osmose Utilities Services, Inc.                                                                                                  221 

 

7. Select the Reduction Type from the drop down list. 

 

8. Enter the Width or Thickness. 

9. Enter the Depth. 

10. Select the Direction from the drop down list.  

 

11. Select OK. 

 

Note:  Once a Strength Reduction Calculation has been added the Calculated 

Effective Circumference will automatically be updated.  This is the value that 

will be used in calculating the groundline capacity.  

Updated Effective 
Circumference  
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12. Select Apply Effective Circumference. 

Note: The Orig. Effective Circumf field is automatically updated to reflect the 

Applied Effective Circumference.  To set the Applied Effective Circumference 

back to the default value select the Clear Effective Circumference button

. 

13. Select Yes to apply the effective circumference. 

Edit a Damage Record in the Strength Reduction 

Calculation  

To edit a damage record in the Strength Reduction Calculation, complete the 

following steps:  

1. Select the damage record to be edited. 

Note: Double clicking on the damage record will also open the damage record 

in edit mode. 

 

2. Select the Edit button . 
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3. Complete any edits that need to be made. 

 

4. Select OK. 

 

Remove a Damage Record from the Strength Reduction 

Calculation  

To remove a damage record from the Strength Reduction Calculation, 

complete the following steps:  

1. Select the damage record to be removed. 
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2. Select the Remove button . 

Working with the Sag Tension Calculator  

The Sag Tension Calculator allows you to calculate and apply a Sag Tension 

to a span whose Tension Type is set to Static.   The Sag Tension Calculator 

can also be used for reference purposes without applying a sag tension 

calculation.  

Create and Apply a Sag Tension Calculation  

When working with a span that has a Tension Type of Static, complete the 

following steps to set the sag tension using the Sag Tension Calculator:  

1. Right click on the span you would like to set the sag tension for. 

2.  Select Tension (span display name). 

 

Note: To use the Sag Tension Calculator as a visual tool to alter the 

calculations but not apply them to the currently selected span open the Sag 

Tension Calculator by selecting Tools>Tension Calculator from the O-Calc®  

Pro toolbar. 
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Note:  When the Sag Tension Calculator is initially opened some of the fields 

will already pre-populated with information from the pole.   

Sag Tension Calculator Options 

 

The Sag Tension Calculator provides you with a variety of 

operations and options. 

 

 

Reference. The 

following options are 

available from the 

Reference menu: 

Reload References. 

Select the Reload 

References option to 

reload the pertinent 

values from the selected 

LC.   
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Select Alternate 

Reference LoadCase. 

Select the Select 

Alternate Reference 

LoadCase option to 

select a different 

loadcase to reference. 

Load Default Values. 

Select the Load Default 

Values option to load a 

set of nominal load 

parameters. 

Cancel. Select the 

Cancel option to close 

the Reference menu 

option pop-up without 

taking any action. 

 

 

Apply to Span. The 

Apply to Span options 

transfers selected 

attributes back to the 

original span and 

optionally changes the 

tension mode.  The 

menu items will reflect 

the tension mode of the 

original seed span  

Cancel. Select the 

Cancel option to close 

the Apply to Span menu 

option pop-up without 

taking any action. 

 

3. Complete your attribute modifications. 

4. Enter the Initial Sag measurement. 

5. Click Apply to Span to transfer selected attributes back to the original 

span and optionally change the tension mode. 

Note: For reference purposes the Modulus of Elasticity Calculator and the 

AWG to Diameter Conversions can also be accessed from the O-Calc ® Pro 

Tools> Misc toolbar menu. For additional information see Working with the 

Modulus of Elasticity Calculator or Viewing the AWG to Diameter Conversions. 

Working with Tension Tables 

To create a custom table with tension values for a specified span length, complete the 

following steps:  
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1. Select the span for which you are creating a custom tension table.  

2. In the Data Entry window, change the filter to Tension Sag.  

3. Under the Tension Type attribute, change the value to Table.  

4. Under the Tension Table attribute, select the blue dot to the right of the 

word “Tension”.  

5. In the Span Tension vs Length window, a graph is shown along with a 

list of values, where additional length values can be associated with an 

applied tension at a specified length along the span. 

 

6. Values can be Added or Removed under the Value dropdown list; 

additionally, this is where values can be sorted once they have been 

added to the list, and where values for the tension table can either be 

Imported or Exported, for use by other users or when imported from 

another source.  

7. Once a list of lengths is created and the tension values are set, the table 

can be saved using the save feature under the file dropdown list. Tension 

tables must be saved each time they are adjusted to apply changes in 

tension.  

Working with Sag Tension Table Generator 

To generate a Sag Tension Table, complete the following steps:  

8. Select the Tools drop-down list 

9. Select Tension Table Generator from the list to open the Sag Tension 

Table Generator winow 

10. In Step 1, Select the loadcase or loadcases to be considered in the 

generated tables using the Add Loadcase button 
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Note: Only one Loadcase can be added at a time. 

 

11. In Step 2, select the span or spans or span bundles to be considered in the 

generated table. 
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12. In Step 3, create the report by modifying the settings displayed: 

▪ Set a Start Length, or starting increment 

▪ Set an End Length, or ending increment 

▪ Set the Increment to be used 

▪ Set the Order method to either order by loadcase or span type 

▪ Select the temperature and sag values to display 

▪ Select the Output Format 

▪ Selet the Mode to be used to calculate the tables 

 

13. Select Create Tables to generate an output report. 

14. Close the tool when finished.  
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Appendix A – Installing Osmose O-Calc® Pro 
 

System Requirements  

System requirements for Osmose O-Calc® Pro include the following:  

▪ Supported Operating Systems: 

▪ Windows 7  - Windows 10 (64-bit version) 

▪ 8 GB system memory 

▪ 20 GB available storage space 

▪ DirectX 11compatible graphics subsystem 

▪ Microsoft .Net Framework version 4.5 or later 

Installing Osmose O-Calc® Pro  

Use the following procedure to install O-Calc® Pro: 

1. Double-click on OCalcPro_(version)_Setup.MSI to run the installation 

application. 

 

2. When the installer Welcome screen appears, click Next. 
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3. Review and check the “I accept the terms in the License Agreement”, 

then click Next. 

 

4. Click Next to use the default Destination Folder or click Change 

 to browse to a different Destination Folder then click Next. 

Check the License 
Agreement terms 
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5. Click Install to begin the installation process. 

 

6. When the installation is complete, click Finish to acknowledge the 

completed installation. 
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Registering Osmose O-Calc® Pro  

Once you have installed the Osmose O-Calc® Pro application you will need 

to enter a Product Registration Key to register the application and accept the 

License Agreement.  To register the Osmose O-Calc® Pro application, 

complete the following steps: 

1. Open O-Calc ® Pro. 

The O-Calc® Pro Product Key window is displayed. 

 

2. Enter the Registration Key Code that was provided in the email you 

received from Osmose. 

Note:  The Registration Key Code is not case sensitive. 
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Note:  If you have questions about the type of Product key needed for your 

installation, contact Customer Support at 716-319-3747 or 

technicalsupport@osmose.com. 

3. Click the Register O-Calc® Pro button. 

Note:  You can cancel out of the registration by clicking the X in the upper 

right corner.  However, you will not be able to use the Osmose O-Calc® 

Pro application until it has been successfully registered. 

Note:  The Demo Version of O-Calc® Pro restricts you from using the save, 

email or print options.  

4. When the O-Calc® Pro License Agreement window displays, scroll 

to the bottom of the license agreement while reading it carefully and 

check the “I have read and accept all of the terms of this 

agreement”. 

Note:  You must scroll to the bottom of the license text window to make the 

check box and the Accept button active.  

5. Click the appropriate button: 

➢ Accept – Indicates your acceptance of the license 

agreement and all its terms. 

➢ Decline – Does not acknowledge acceptance of the 

agreement.  The Osmose O-Calc® Pro application 

cannot be accessed if you do not accept the license 

agreement.  

O-Calc ® Pro Security Administration  

O-Calc® Pro limits what user levels are available based on the Windows 

User Group a person is in.  The following table lists what user levels are 

available to each Windows User Group. Users can select any User level with 

a  in it.  The default level is also indicated.  

 

 

 

mailto:technicalsupport@osmose.com
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  Windows User Groups 

  O-Calc 

Administrators 

All Others O-Calc 

Limited 

O
-C

al
c 

®
 P

ro
  

U
se

r 
L

ev
el

s 

Limited   default) 

Normal default) default)  

Administrative    

 

O-Calc Administrators and O-Calc Limited are the names of the actual 

Windows User Groups that need to be created to grant or limit privileges.  

When placing users into specific security groups they need to log off and 

then log back onto their computers to ensure the proper security group 

settings are enabled.  

O-Calc® Pro User Level Definitions  

O-Calc® Pro offers three different user levels: normal, limited and 

administrative.  These levels allow companies to grant or restrict access to 

individual features within O-Calc® Pro.  Below is a brief description of each 

user level.  

➢ Normal – This is the default user level.  All attributes except those in 

sealed LoadCases can be edited at this level.  At this level the user can 

also unseal LoadCases and manipulate the Catalog items.  The user will 

not be able to manipulate the Master Catalog directly.   

➢ Limited – Restricts access to certain attributes and operations that if 

changed could gravely effect the data within O-Calc® Pro.  Placing a 

user at the Limited level is intended to support training, inexperienced 

users and untrained data entry personnel.  

➢ Administrative – Users at this level have access to all the features within 

O-Calc® Pro including the option to manipulate Catalogs, re-seal 

LoadCases and edit read only attributes. 

Note:  If a user is in both O-Calc Administrators and O-Calc Limited groups, 

they will be considered a member of the O-Calc Administrators group. 

 

Change the Product Registration Key 

To change the initial Product Registration Key entry, complete the following 

steps: 

1. Open O-Calc ® Pro. 

2. Select Help>Enter or Change Product Key. 
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The O-Calc® Pro Product Key window is displayed. 

 

3. Enter or change the Registration Key Code. 

Note:  The Registration Key Code is not case sensitive. 

 

4. Click the Register O-Calc® Pro button. 

 

Additional Resources 

Additional sources of information for O-Calc Pro can be found in a number 

of sources. These sources can be easily accessed by following these steps: 

1. On the main toolbar, select the Help drop-down list 

2. Hover the mouse over the More Information option to see the 

resources available 
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3. The available resources are: View Informational Videos or read the O-

Calc Pro WIKI page.  
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Appendix B – Creating a Customized View 
 

Understanding the Default View  

 

Within O-Calc® Pro the placement of where the numerous windows are 

located can be changed at any time.  This allows you to create unlimited 

custom views that can also be saved for future use in the Named View 

dropdown in the right corner of the Tool Bar menu.  The O-Calc® Pro main 

view is broken into panels.  The windows within O-Calc® Pro can be moved 

into any of these panels.  

 

 

 

 

 

 

Repositioning a Window  

To change the location of a window, complete the following steps:  

1. Left click on the windows heading. 

 

Panel 1 Panel 2 
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The selected window is overlaid in blue.  

2. Hold down left mouse button and drag the blue overlaid window to the 

area you would like the window displayed.  

 

 

The actual window that you are moving will remain in its original 

location until after the blue overlay window has been positioned.  

 

 

Once the blue overlay window is near the center of a panel or the edge of 

a panel, placement directionals will automatically be displayed. 
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3. Drag the blue overlay window over the placement directional that best 

interprets where you would like the window placed. 

When placing a window over a placement directional the blue overlay 

window will display where the window will be placed within the panel.  

  

4. While still over the placement directional release the left mouse button to 

place the window. 

Window will 
be placed at 
the top of the 
panel 

Window will be placed 
either at the top, bottom, 
right, left or as a tab in 
the panel.  

Window will 
be placed at 
the bottom of 
the panel 
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Note: Undo is not available. 

Save a Named View  

To save the view that you’ve created and add it to the Named View list, 

complete the following steps:  

1. Enter a name in the Named View box.  

 

2. Press the enter key to save your Named View. 

3. Select Yes to the confirmation message. 

Delete a Named View 

To delete a Named View, complete the following steps:  

1. Select the Named View to be deleted from the Named View drop down 

list. 

 

2. Select the Delete Named View button . 

3. Select Yes to the confirmation message.  

Note:  Undo is not available for this operation. 

Return to the Default Docking Layout  

To return to the default docking layout, complete the following steps:  

1. Select View>Default Docking Layout.  
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Refresh All Views 

To refresh all views, complete the following steps:  

1. Select View>Refresh All Views.  

 

 

  



Osmose O-Calc® Pro 5.3                      Confidential                                                           User’s Guide 

©2018 Osmose Utilities Services, Inc.                                                                                                  243 

Appendix C – Other Tools & Functions  
 

Working with the Wizard Tool 

Wizard Tool Overview 

The O-Calc Pro Wizard Tool guides the basic O-Calc Pro user through the 

uncomplicated construction of a model utility pole.  The model includes the 

structure, the equipment attached and its environment.  

Enabling the Wizard Tool  

To enable the Wizard Tool, complete the following steps:  

1. Select File>New Pole>Wizard. 

 

Understanding the Wizard Workspace 

The Wizard provides you with a variety of options enabling you to interact 

with the Wizard.  

 

 

  

3D, Charts and 
Reports Tab Views 

Inventory 
Display 

Additional 
display 
options 

Data Entry 
Display 

Capacity 
Display Wizard Steps 

Bar 

Wizard 
Panel  
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Understanding the Wizard Display 

The following table describes the color representation in the Wizard Panel.  

Display Color Description 

 Illustrates a contracted folder. 

 Illustrates an expanded folder. 

 Illustrates the currently selected item. 

Selecting a Template 

The initial step requires you to select a pole template.  To select a pole 

template complete the following steps:  

1. Select One - Template button   from the Wizard 

Steps Bar. 

2. Expand a Template folder. 

 

3. Select the pole you would like to start with. 

 

4. Select the Edit button , at the bottom of the Wizard Panel, to 

modify the selected poles attributes in the Edit window.  

 

 

Template folder 
expanded 
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5. Select OK. 

Note:  To undo changes to the pole’s attributes, select the Undo button

. 

Selecting a LoadCase 

To change the LoadCase that is associated with the pole, complete the 

following steps:  

1. Select Two – Loadcase button   from the Wizard Steps 

Bar. 

 

Note: If a default LoadCase has been set it is automatically selected. 

2. Expand a LoadCase folder. 

Default LoadCase 
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3. Select a LoadCase. 

  

4. Select the Edit button  to modify the selected LoadCase’s 

attributes in the Edit window. 

Currently 
selected 
LoadCase 

Expanded LoadCase 
folder 
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5. Select OK. 

Note:  To undo the LoadCase modification, select the Undo button . 

Substituting the Current Pole 

To substitute the current pole with another pole, complete the following 

steps:  

1. Select Three - Pole button  from the Wizard Steps Bar. 

2. Select Substitute Pole. 

 

 

O-Calc® Pro provides you with three options when substituting a pole.  

You can either manually select the substitute pole, select the substitute 

pole from a Catalog or you can use the Pole Solver option to help you 

select the substitute pole.  The Pole Solver option will display the 

minimum pole class and the estimated capacity that would be used based 

on the pole’s current load.   For additional information on substituting a 

pole see Substituting a Pole. 

Substitute Pole 
Option 
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Note: Available tabs are dependent on corresponding structure types displayed 

in your catalogs. 

3. Use one of the following methods to select the substitute pole you want: 

A. Manually select the substitute poles attributes using the Attr values 

or Standards tab. 

B. Select the substitute pole from a Catalog select the appropriate tab 

and select the poly you want to use as a substitute.  The attributes can 

still be modified if needed. 

Note: For additional information on catalogs see Working With the Catalog 

Window. 

C. Select the Use Pole Solver button  to have O-Calc® Pro 

automatically select the minimum Pole Class that would provide you 

with a passing pole. 

4. Select OK. 

If there are primary attachments already on the pole the Height 

Adjustment window will automatically be displayed.  The Height 

Adjustment window allows you to adjust the substitute poles depth and 

the height of the primary attachments relative to groundline or the tip of 

the substitute pole. 
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5. Modify the Pole Depth if required. 

6. Verify and change each primary attachments height if required. 

7. Select OK. 

Note: To undo the pole substitution, select the Undo button . 

Performing Adjustments 

To complete adjustments to either span angles or the elevations of 

attachments, complete the following steps:  

1. Select Four - Adjust button  from the Wizard Steps 

Bar. 

 

2. Select the item you would like to adjust. 
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3. Complete any modifications. 

4. Select OK. 

Note: To undo any adjustments, select the Undo button . 

Adding Equipment 

To add additional equipment to the pole, complete the following steps:  

1. Select Five - Equipment button  from the Wizard Steps 

Bar. 

2. Expand an Equipment folder. 
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3. Select the Equipment you would like to add to the pole. 

 

Note: Only one piece of equipment can be added at a time. 

4. Enter the height of the attachment. 

  

5. Select OK. 

6. Modify the new equipment’s attributes. 

Expanded 
Equipment 
Folder 

 

Currently 
Selected 
Equipment 
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7. Select OK. 

Note: To undo the addition(s) of equipment, select the Undo button . 

 

Finalizing the Wizard Tool Process 

To finalize the work that has been completed in the Wizard, complete the 

following steps: 

1. Select step Six - Finish button   from the Wizard Steps 

Bar. 

 

 

 

 

Completed Pole in 3D View 
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Options Within the Finish Step 

The Finish step provides you with a variety of operation and options.  

 

Images. The following 

options are available from 

the Images menu. 

Add Images to Pole. Select 

the Add Images to Pole 

option to add images that 

are associated to the 

current pole. 

Remove All Images.  

Select the Remove All 

Images option to remove 

all images that are 

associated to the current 

pole. 

 

 

Actions. The following 

options are available from 

the Actions menu. 

Save Pole. Select the Save 

Pole option to save the 

current pole. 

Run Wizard Again.  Select 

the Run Wizard again 

option to restart the Wizard 

process. 

Save Pole and Run Wizard.  

Select the Save Pole and 

Run Wizard again option to 

save the current pole and 

restart the Wizard process. 

Go to O-Calc® Pro. Select 

the Go to O-Calc® Pro 

option to close the Wizard 

and return to O-Calc® Pro. 

Adding Images to the Pole  

To add images to the current pole in the Wizard, complete the 

following steps:  

1. Select Add Images to Pole. 

2. Select the Images Path Browse button and navigate to the 

location where the images to be associated with the current pole 

are located and click OK. 
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3. Select the images to be associated to the current pole. 

Note: Hold down the ctrl key to select more than one image out of 

sequence.  Hold down the shift key to select a group of images that are 

next to each other. 

4. Select OK. 

Note: To undo the addition(s) of images, select the Undo button 

. 

Removing Images From the Pole  

To remove all the images that are associated to the pole in the 

Wizard, complete the following steps:  

1. Select Remove All Images. 

Note: There is no option to remove individual images. 

2. Select Yes to the confirmation message. 

Note: To undo the removal of the images, select the Undo button 

. 

Save the Pole 

To save the pole in the Wizard, complete the following steps:  

1. Select Save Pole 
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2. Browse to the location where you will save the pole and click 

Save. 

3. Select OK to the confirmation message. 

Run Wizard Again 

To restart the Wizard again at step one, complete the following steps:  

1. Select Run Wizard Again. 

 

Note: If any changes have been made to the current pole you will be 

prompted to save your changes before the Wizard is restarted. 

Save the Pole and Run the Wizard Again 

To save the current pole and restart the Wizard at step one, complete 

the following steps:  

1. Select Save Pole and Run Wizard. 

 

2. Browse to the location where you will save the pole and click 

Save. 

3. Select OK to the confirmation message.  

Once the pole has been saved the Wizard will automatically be 

restarted. 

Close the Wizard Tool 

To close the Wizard and return to O-Calc® Pro, complete the 

following steps:  

1. Select Go to O-Calc® Pro. 

Note: The current pole in the Wizard will not be saved within the 

Wizard. 

Working with the Lens Calibration Tool 

 

The Lens Calibration Tool is used to determine the barrel / pin cushion 

distortion present for a particular brand of camera prior to its use in the 

Digital Measurement Technology (DMT) process. 
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Enabling the Lens Calibration Tool  

To enable the Lens Calibration Tool, complete the following steps:  

1. Select Tools>Misc>Photo Measurement>Lens Calibration. 

 

Working With the Lens Calibration Tool  

Lens Calibration is a four step process.  To complete the Lens Calibration 

process, complete the following steps:  

1. Select the Step 1 tab. 

2. Click the Click here to print calibration chart button and print the 

calibration chart. 

Note: You will need the printer calibration chart and the camera you need to 

calibrate to proceed to the next step. 

3. Click the Next button or select the Step 2 tab. 
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4. Using the camera that needs to be calibrated take a picture of the 

calibration chart that you printed out on the Step 1 tab. 

Note: Use the detailed directions provided on the Step 2 tab to get the best 

possible image.  Incorrectly taken images of the calibration chart will result in 

the lens calibration to be incorrect.  

5. Save the image you took of calibration chart. 

6. Click the Next button or select the Step 3 tab. 

 

7. Click the browse button  and navigate to and select the image you 

took of the calibration chart and click Open. 
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8. Your image should display in the Step 3 tab. 

 

9. Click the Next button or select the Step 4 tab. 

Note: Verify the Camera Make and Camera Modl that display are correct. 

 

10. Click the Click here to select points button. 

The Camera 
Make, Model 
and Sensor 
Ratio are 
automatically 
populated.  
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The Lens Calibration Pick Points window displays.  Using the detailed 

directions provided select each point until all points are selected on the 

chart. 

  

Select all outer 
points in a clockwise 
direction 
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11. When all points are selected, click the Done button. 

12. Click the Click here to calibrate button.  The calibration status bar will 

display the lens calibration progress. 

 

When the lens calibration is complete the Lens Distortion field will 

automatically be populated. 

    

13. Click the Click to update camera file button.  

Select all inner 
points in a 
clockwise direction 

Lens Distortion 
is automatically 
populated once 
the calibration is 
complete. 
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14. Select OK to the verification message that the camera has been added to 

the supported camera database.  

15. Select Finished to close the Lens Calibration Tool. 

Working with the Calculator  

A basic calculator is provided to help with simple calculation or conversions. 

To access the calculator, complete the following steps:  

1. Select Tools>Misc>Calculator. 

   

Working with the Modulus of Elasticity Calculator  

To create a Modulus of Elasticity (MOE) calculation for reference only, 

complete the following steps:  

1. Select Tools>Misc>Modulus of Elasticity Calculator. 

 

Note:  A pole does not need to be loaded in the Inventory Window in order to 

use the Modulus of Elasticity Calculator. 
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2. Select the Main Material from the drop down list. 

3. Select the Core Material from the drop down list. 

4. Enter the Core Radius %. 

The Modulus of Elasticity (MOE) is automatically calculated. 

  

5. Select the X in the upper right corner to close the window. 

Note:  The Modulus of Elasticity Calculation cannot be applied to a currently 

loaded pole.  This calculation is for reference only. 

Viewing the AWG to Diameter Conversions 

To display the AWG to Diameter conversions, complete the following steps:  

1. Select Tools>Misc>AWG to Diameter Conversion. 

 



Osmose O-Calc® Pro 5.3                      Confidential                                                           User’s Guide 

©2018 Osmose Utilities Services, Inc.                                                                                                  263 

Note:  A pole does not need to be loaded in the Inventory Window in order to 

display the AWG to Diameter Conversion window. 

  

2. Select OK to close the window. 

 

Viewing the Concrete Pole Class List 

To view the list of Concrete Pole Classes, for reference only, complete the 

following steps:  

1. Select Tools> Misc>Concrete Pole Class List. 
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Note: A pole does not need to be loaded in the Inventory Window in order to 

display the Concrete Pole Class List window. 

  

2. Adjust the Strength Factor. 

3. Select OK to close the window. 

 

 

Viewing the Soil Class List 

To view the list of Soil Classes, for reference only, complete the following 

steps:  

1. Select Tools> Misc>Soil Class List. 
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2. Select OK to close the window 

RUS-based Overturn Moment Calculation 

The RUS method (RUS Bulletin 1724E-200) will take into consideration pole length, 

setting depth, and soil type.  The user will have the option to change the soil 

classification based on local known conditions and/or field data.  The tool will 

automatically fill in the overturn moment value and the O-Calc Pro calculation 

engine will flag the pole if overturn is a limiting factor for the pole model. This 

functionality is in support of the CPUC GO95 Rule 94.11 (pole overturning 

calculation).  

Activating RUS-based Overturn Moment 

To enable the RUS-based overturn moment feature, complete the following 

steps:  

1. Select the pole from your 3D view or Inventory Window. 

2. In the Data Entry window, set the filter box to say Overturn. 
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3. Select a Soil Class from the list; the Overturn Moment sets to Auto. 

 

Note: The soil class number corresponds to a value for the Overturn 

Moment, referenced in the table below.  

Class Description Soil Constant 

Class 0 Sound hard rock; bedrock; un weathered Soil Constant 140 

Class 1 Very dense and/or cemented sands; coarse gravel and 
cobbles 

Soil Constant 140 

Class 2 Dense fine sand; very hard silts and clays (may be 
preloaded) 

Soil Constant 140 

Class 3 Dense sands and gravel; hard silts and clays Soil Constant 70 

Class 4 Medium dense sandy gravel; very stiff to hard silts and 
clays 

Soil Constant 70 

Class 5 Medium dense coarse sand and sandy gravels; stiff to 
very stiff silts and clays 

Soil Constant 70 

Class 6 Loose to medium dense fine to coarse sand; firm to stiff 
clays and silts 

Soil Constant 35 

Class 7 Loose fine sand; alluvium; loess clays; soft-firm clays; 
varied clays; fill 

Soil Constant 35 

Class 8 Peat; organic silts; inundated silts; fly ash; very loose 
sands; very soft to soft clays 

Soil Constant 35 

 

4. Verify that the Overturn Moment displays in the Analysis Report. 
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Deactivating RUS-based Overturn Moment 

To enable the RUS-based overturn moment feature, complete the following 

steps:  

1. Select the pole from your 3D view or Inventory Window. 

2. In the data entry window, set the filter to Overturn Moment. 

3. In the Overturn Moment (ft-lbs) attribute box, double-click within the 

box that says Auto, and type in the word Unset. 

 

4. Press Enter to deactivate RUS-based overturn moment calculations. 

In the Data Entry window, set the filter box to say Overturn. 

Working with the Ruling Span Calculator 

To calculate the ruling span for reference only, complete the following steps:  

1. Select more than one span in the Inventory Window or 3D View. 

2. Select Tools> Misc>Ruling Span Calculator. 

  

Note: The Ruling Span Calculation cannot be applied to the currently loaded 

pole.  This calculation is for reference only. 
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3. Select OK to close the window. 

 

Working with the Pole Section Evaluation 

To evaluate damage and decay on the pole for reference only, complete the 

following steps:  

1. Select Tools> Misc>Pole Section Evaluation. 

 

2. Select Add and select a damage or decay item from drop down list. 

Note: To remove a damage or decay item from your list select the item to be 

removed and select Remove from the toolbar. 

3. Modify the damage or decay attributes. 
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Note: The calculations are updated automatically and are not editable. 

Working with the Force Summary of Selection 

To display the force summary of the selected object(s) in the Inventory 

Window, complete the following steps:  

1. Select Tools> Misc>Force Summary of Selection. 

 

Note:  At least one object needs to be selected in the Inventory Window in order 

to display the Force Summary of Selection window. 
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2. Select OK to close the window. 

 

Working with the Fill Moment Table 

To display the Fill Moment Table for the pole currently displayed in the 

Inventory Window, complete the following steps:  

1. Select the Pole in the Inventory Window. 

2. Select Tools> Misc>Fill Moment Table. 

 

3. In the Data Entry Panel select the Pole’s Moment of Capacity. 
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Once the Moment Capacity vs Height table is displayed the toolbar menu 

provides you with a variety of options: 

 

File. The following options are 

available from the File menu: 

Save. Select the Save option to 

save any modifications. 

Cancel. Select the Cancel option 

to exit the table without saving 

any changes. 

 

Value. The following options are 

available from the Value menu: 

Add. Select the Add option to 

add a new row to the table. 

Remove. Select the Remove 

option to remove a selected row 

from the table. 

Sort. Select the Sort option to 

sort the table by height. 

Import. Select the Import option 

to import a CSV file. 

Export. Select the Export option 

to export the current table values 

to a CSV file. 

 

4. Select the Height or Moment Cap you would like to change and enter 

the new value you would like to use. 

5. Select File>Save. 
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Note: Select File>Cancel to close the Moment Capacity vs Height table without 

saving any modifications. 

Clean Temp Folder  

To clean the temp folder, complete the following steps:  

1. Select Tools> Misc>Clean Temp Folder. 

 

2. Select OK to the confirmation message. 

 

Changing Access Permission  

To change your access permission, complete the following steps:  

1. Select Tools>User Level. 

 

Note:  The User Level can also be updated by left clicking on the User Level in 

the Status Bar and selected the preferred User Level. 

2. Select the desired User Level.  
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3. Select OK to the confirmation message. 

Note:  The current User Level will automatically be updated at the bottom of the 

Status Bar.   

Note: Changes to the User Level are per O-Calc® Pro session.  Any changes to 

the User Level are not permanent. For additional information on O-Calc® Pro 

Security Level, see O-Calc ® Pro Security Administration. 

 

Change the Unit Convention  

To change the unit convention, complete the following steps:  

1. Select Options>Unit Convention. 
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Note:  English is the default unit convention when the application is initially 

installed.  

2. Select the unit convention from the options provided.   

Note:  A check mark will display next to the selected unit convention when it is 

enabled.  

Change the Pole Saved Confirmation Message  

To change if the “Pole Saved” confirmation message displays, complete the 

following steps:  

1. To enable\disable the Pole Saved confirmation message option, select 

Options>Misc Options>Display “Pole Saved” Confirmation. 
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Note:  The Display “Pole Saved” Confirmation option is enabled when the 

application is initially installed.  

Note:  When the Display “Pole Saved” Confirmation option is enabled a check 

mark will display next to the menu option.  When the option is disabled the 

check mark is not displayed.  

 

Divide Add Menu Items by Category 

To change how the “Add Element” menu is displayed, complete the 

following steps: 

1. To enable\disable the Divide Add Menu Items by category option, select 

Options> Misc Options>Divide Add Menu Items by Category 

 

Note: Disabling the divide add menu option displays all elements to be 

added to an item in one list.  
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Change the Inventory Window Toolbar Display  

To change if the Inventory Window toolbar displays text next to each image, 

complete the following steps:  

 

1. To enable\disable the text that displays next to each image in the 

Inventory Window toolbar, select Options>Misc Options>Show Text 

and Images in Inventory Menu. 

 

Note:  When the Show Text and Images in Inventory Menu option is enabled a 

check mark will display next to the menu option.  When the option is disabled 

the check mark is not displayed.  
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Change the Visual Style  

To display the O-Calc Pro interface in a flat visual style, complete the 

following steps: 

1. Select View>Theme>Flat Visual Style. 

 

Change the Mouse Wheel Functionality  

To reverse the mouse wheel direction, complete the following steps: 

1. Select Options>Misc Options>Invert Mouse Wheel. 

 

Note: The Invert Mouse Wheel function will be valid for the  3D View, Bird’s 

Eye View, Perspective Camera and Top View. 

Modifying Span’s Default Rated Strength Percentage  

When a span is copied from the Master Catalog where the tension mode is 

“Static” or “Manual” a default percentage of a spans rated strength is used to 

calculate the span’s tension.  The default percentage for each type of span 

can be changed at any time by completing the following steps: 

1. Select Options>Misc Options>Percent of Span Rated Strength to 

Apply as Tension. 
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2. Select the Span’s Percent you would like to change and enter the new 

default percentage you would like to use for the selected span. 

Note: To load a Save Percent of Tension Set select the Import button 

  and browse to the location of the file. 
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Note:  This value will not be applied if the span is a subcomponent of complex 

assembly. 

3. Select the Export button  to save the currently displayed 

percent of tensions set as a file. 

4. Select OK. 

Note:  To revert the entire listing of span percentages of Rated Strength back to 

their default values select Restore Default Values. 

Working with Pole History Archive  

The Pole History Archive provides an audit trail of the changes made at each 

save point.  When the Pole History Archive option is enabled, each time you 

save changes to a pole a snapshot of that pole is created and stored as a 

history record.  Each history entry records who made the changes and when 

they were made.  By retaining a history of each time a pole has been saved 

enables you to review previous revisions to a pole and even revert to a pole’s 

previous revision.  To enable and use the Pole History Archive, complete the 

following steps:  

1. Select Options>Misc Options>Save Pole History Archive. 

 

Note: When the Save Pole History Archive option is enabled a check mark will 

display next to the menu option.  When the option is disabled the check mark is 

not displayed. 

2. Create a new pole in the Inventory Window and save the pole using the 

File>Save Pole option. 

 

 New pole created 
in the Inventory 
Window 
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The first time the pole is saved a Pole History Archive file is created.   

3. To review the pole’s history archive, select File> More Options>Open 

Archived Pole.  Browse to the location of the saved pole and select the 

(pole name).pplx file. 

Note: The Open Archived Pole option is only visible when the Save Pole History 

Archive option is enabled. 

 

 

4. Complete modifications to the current pole in the Inventory Window and 

save the pole using the File>Save Pole option. 

 

 

The Revision History area is automatically updated. 

5. To review previous revision to a pole or to revert a pole to a previous 

version, select File>Open Archived Pole.  Browse to the location of the 

pole you wish to work with and select the (pole name).pplx file.  Select 

the Revision History record you would like work with. 

 

 

 

Saved pole’s initial 
Revision History entry 

Active pole with 
objects added  
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6. Select Open Archived Version. 

 

The selected Revision History snapshot is loaded in the Inventory 

Window and can be reviewed.  The pole is completely editable at this 

time and it can be modified and saved.  If the revision is saved, it will 

then become the active version of that pole and replace the .pplx file.  

For safety, a new revision history record will be added at that time that 

stores a snapshot of the previously saved version of the pole.  

 

 

 

 

 

 

Select the revision 
history file 
 

Select the (pole name).pplx file 
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Set the Idle Time Interval 

To set the idle time before calculations are calculated, complete the 

following steps:  

1. Select Options>Misc Options>Idle Timer Interval (currently set 

time). 

 

2. Enter the Idle Timer Interval. 

 

Note: The Idle Time Interval can be set to a minimum 1000 milliseconds and a 

maximum of 5000 milliseconds. 

Note: The Auto Capacity Summary option needs to be enabled in order for the 

Idle Timer to activate.   

3. Select OK. 

Display Assemblies in the Tree View  

By default, when adding or substituting a pole or attached equipment the 

assemblies are not displayed in the tree view unless they display directly 

under a folder.   
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Note: The example above displays using the Substitute option with the Display 

Assemblies in the Tree View by default disabled. 

 

To display assemblies without regard to where they display in the tree view, 

complete the following steps:  

1. Select Options>Misc Options>Assemblies Shown in New and Subst 

Trees. 

 

Note: When the Assemblies Shown in New and Subst Trees option is enabled a 

check mark will display next to the menu option.  When the option is disabled 

the check mark is not displayed. 

 With the option by 
default disabled the 
equipment needs to 
be directly under a 
folder.   If the 
equipment is not 
directly under the 
folder in the tree 
view the folder will 
not be displayed. 
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Setting Height After Assembly Drop 

To set the height of equipment or an assembly being dragged onto the current 

pole from a catalog, complete the following steps:  

1. Select Options>Misc Options>Set Height After Assembly Drop. 

 

Note: When the Set Height After Assembly Drop is selected the height 

adjustment window will display each time a drag-and-drop operation occurs 

from a catalog.  The height value displayed is the pole attachment height of the 

topmost item of the assembly.  All other items will be adjusted relative to the 

topmost attachment height. 

Buffering in Image Measurement 

O-Calc ® Pro uses an off-screen bitmap buffer to reduce redraws flicker of 

the photo measurement screen.  This option requires a large amount of 

system memory.  On computers where memory levels or CPU performance 

do not meet the stated O-Calc ® Pro requirements this option may be enabled 

in an attempt to reduce memory consumption and increate performance at the 

expense of increased image flickering.  To enable double buffering in the 

Measurement Window, complete the following steps:  

1. Select Options>Misc Options>Double Buffer in Image Measurement. 
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Note: When the Double Buffer in Image Measurement option is enabled a check 

mark will display next to the menu option.  When the option is disabled the 

check mark is not displayed. 

Note: To review a complete list of O-Calc ® Pro system requirements, see 

System Requirements. 

Enable 3D Hardware Acceleration 

O-Calc ® Pro uses the advanced graphical processing unit of the graphics 

card to accelerate 3D rendering and processing.  This feature requires that the 

graphics card meet WDDM 1.0 or higher and be fully Direct 3D compliant.  

If your graphics card does not meet those requirements you may disable the 

use of 3D hardware acceleration.  This will result in severely reduced 3D 

rendering performance. To enable the 3D Hardware Acceleration, complete 

the following steps:  

1. Select Options>Misc Options>Enable 3D Hardware Acceleration. 
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Note: When the Enable 3D Hardware Acceleration option is enabled a check 

mark will display next to the menu option.  When the option is disabled the 

check mark is not displayed. 

Change the Keyboard Delete Confirmation Message 

When deleting objects in the Inventory Window using the delete button on 

your keyboard a delete confirmation message is displayed.  This message can 

be enabled or disabled according to your needs.  To change if the delete 

confirmation message display, complete the following steps:  

1. To enable/disable the Delete confirmation message option select 

Options>Misc Options>Warn on Keyboard Delete. 

 

Note: The Warn on Keyboard Delete option is enabled when the application is 

initially installed. 
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Note: When the Warn on Keyboard Delete option is enabled a check mark will 

display next to the menu option.  When the option is disabled the check mark is 

not displayed. 

Copying Value from the Data Entry Window  

The copy value feature allows you to easily copy values or value sets from 

the Data Entry Window onto the clipboard.  To use this feature, complete the 

following steps:  

1. To enable/disable the copy to clipboard on item click option select 

Options>Misc Options>Automatic copy to clipboard on item click. 

 

2. Select the data entry header or selected an object or attribute value 

within the Data Entry Window. 

 

Note:  Only one object or attribute can be selected per copy.  To copy more than 

one object or attribute select the data entry header. 

3. Select ctrl + C to copy the value(s). 

Currently Displayed 
Category 

Data Entry Header 

  

Currently Displayed 
Category 

Data Entry Header 

Objects Within a 

Category 
Objects Attributes  
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Data Entry Header Selecting the Data Entry Header 

then selecting ctrl+c will copy all 

the objects and attribute values 

within the selected category to 

the clipboard. 

Object Selecting an object then selecting 

ctrl+c will copy the object value 

and the objects attribute value to 

the clipboard. 

Attribute Selecting an attribute then 

selecting ctrl+c will copy the 

attribute value to the clipboard. 

4. Select ctrl + V to paste the value(s) from the clipboard. 

Switching Views Using Function Keys  

To easily switch between the O-Calc ® Pro views keyboard shortcuts and 

function keys have been enabled.  To work with these features, complete the 

following steps:  

1. To enable/disable the Enable Shortcut and Function Keys option select 

Options>Misc Options>Enable Shortcut and Function Keys. 

 

Note: When the Enable Shortcut and Function Keys option is enabled a check 

mark will display next to the menu option.  When the option is disabled the 

check mark is not displayed. 

 

When Shortcuts and Function Keys are enabled the following are 

available: 



Osmose O-Calc® Pro 5.3                      Confidential                                                           User’s Guide 

©2018 Osmose Utilities Services, Inc.                                                                                                  289 

F1 Press F1 to switch to the 3D View. 

F2 Press F2 to switch to the Charts View. 

F3 Press F3 to switch to the Data Entry Window. 

F4 Press F4 to switch to the Measure Window. 

F5 Press F5 to switch to the Reports Window. 

F6 Press F6 to switch to the Inventory Window. 

F7 Press F7 to switch to the Heat Map Window. 

CTRL + F7 Press CTRL + F7 to switch to the Capacity 

Window. 

F8 Press F8 to switch to the Schematic Window. 

F9 Press F9 to switch to the Top View Window. 

F11 Press F11 to save the current changes. 

F12 Press F12 to switch the 3D View to the Bird’s Eye 

View.  

Insert Pressing the Insert button while an object is 

selected in the Inventory window will display a 

shortened list of convenient features.  

(Example: Add objects, select  multiple objects and 

add notes) 

CTRL + Insert Press CTRL + Insert to modify an insert. 

CTRL + ? Press CTRL + ? to switch to the Find Menu Item 

Window. 

Delete Press the Delete button to delete objects in the 

Inventory Window. 

 

Working with the Stub Pole Menu Options  

While performing analysis on stub poles several options are automatically 

enabled.  O-Calc ® Pro allows you to adjust which of these options you 

would like enabled or disabled.   

Enabling the Ability to Create a New Stub Pole  

To enable/disable the right click menu options to create a new stub pole as a 

new pole analysis, complete the following steps:  

1. To enable/disable the Create as New Pole option select Options>Misc 

Options>Stub Pole Options>Create as New Pole Enabled. 
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Note:  When the Create as New Pole Enabled option is enabled a check mark 

will display next to the menu option.  When the option is disabled the check 

mark is not displayed. 

Note: At least one of the Stub Pole “Create” options needs to be enabled. 

 

Enabling the Ability to Create a New Version of the Stub 

Pole  

To enable/disable the right click menu option to create a new version of the 

existing stub pole, complete the following steps:  

1. To enable/disable the Create as Version Enabled option select 

Options>Misc Options>Stub Pole Options>Create as Version 

Enabled. 
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Note:  When the Create as Version Enabled option is enabled a check mark will 

display next to the menu option.  When the option is disabled the check mark is 

not displayed. 

Note: At least one of the Stub Pole “Create” options needs to be enabled. 

Enabling the Ability to Auto Guy a New Stub Pole  

To enable/disable the right click menu option to automatically auto guy a 

new stub pole, complete the following steps:  

1. To enable/disable the Auto Guy Stub Pole option select Options>Misc 

Options>Stub Pole Options>Auto Guy Stub Pole Enabled. 
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Note:  When the Auto Guy Stub Pole Enabled option is enabled a check mark 

will display next to the menu option.  When the option is disabled the check 

mark is not displayed. 

Automatically Display Error Tab 

To display any error(s), in a separate tab, that causes the calculation engine 

not to complete, complete the following steps: 

1. Select Options>Misc Options>Show Error Tab Automatically. 
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Move Pole Segments Together  

To automatically have pole segments move together, complete the following 

steps: 

1. Select Options>Misc Options>Move Pole Segments Together. 

 

Manage Plugins 

To work with available plugins, complete the following steps: 

1. Select Options>Manage Plugins. 

Note: The available list of plugins is dependent on the customer’s installation.  

2. Select the plugin you would like to enable. 
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3. Select Apply. 

4. Select Yes to the Restart Required message. 

 

Working with Catalog Configurations 

 

O-Calc® Pro allows the user to configure and utilize multiple Master and 

User Catalogs.   Each catalog configuration displays independently within O-

Calc Pro.  The Catalog Configuration tool allows you to add, remove and edit 

any catalog configurations. 

Working with Catalog Configuration 

To open the catalog configuration window, complete the following steps:  

1. Select Tools>Catalog Maintenance>Configure Catalogs. 
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Note: A default Master and User Catalog are provided upon installation 

of O-Calc Pro - add additional Catalogs as desired. 

Adding a Catalog  

To add a catalog, complete the following steps:  

1. Select the Add Catalog button . 

 

2. Enter the catalog Name. 

3. Select the catalog Type from the drop down list. 

4. Select the Catalog Path browse button  to browse to and select the 

catalog file you would like to use and select Open.  

5. Select the State Path browse button  to browse to and select the 

catalog expansion file you would like to use and select Open. 
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6. Click OK to close the Add Catalog Entry window. 

Note: There is no undo for this operation. 

 

7. Click OK to close the Catalog Configuration window. 

Editing a Catalog  

To edit a catalog configuration, complete the following steps:  

1. Select Tools>Catalog Maintenance>Configure Catalogs. 

2. Select the Catalog you would like to edit. 

3. Select the Edit Catalog button . 

 

4. Complete any modifications to the catalog configuration. 

 

5. Click OK to close the Add Catalog Entry window. 

Note: There is no undo for this operation. 

6. Click OK to close the Catalog Configuration window. 

7. Click OK to the Restart Required message. 

New Master Catalog 
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Remove a Catalog 

To remove a catalog configuration, complete the following steps:  

1. Select Tools>Catalog Maintenance>Configure Catalogs. 

2. Select the Catalog you would like to delete. 

3. Select the Remove Catalog button .  

4. Select Yes to the remove confirmation message. 

Note: There is no undo for this operation. 

These customizations can only be restored by reverting to a previously saved backup 

of the Master Catalog.  

Note: Backup versions of the Master Catalog can be obtained by selecting 

Help>Folders>All Users Root Folder>CatalogBackup. For additional 

information on restoring a backup version of the Master Catalog see Working 

with Catalog Backups. 

Downloading New Catalogs 

To download the latest version of a catalog, complete the following steps: 

1. Select Tools>Catalog Maintenance>Configure Catalogs. 

2. In the Configure Catalogs Window, select Download Catalogs. 

3. Launches a Web Browser that navigates to www.o-

calcpro.com/CATALOGS/ 

4. Select a catalog to download – clicking on it will begin download 

5. User will be prompted to choose save location 

▪ If saving in same location as older versions of a catalog, will 

overwrite old version.  

6. Once downloaded, close web browser 

7. In O-Calc, again select Tools>Catalog Maintenance>Configure 

Catalogs 

8. Follow steps to add an additional catalog 

Working with Sealed LoadCases 

 

The LoadCase element contains the environmental and convention 

parameters required to codify such things as the standards body being used, 

the local wind and ice conditions, overload factors to be applied in different 

conditions, and to different element types, etc.  Arguably the LoadCase is the 

most critical element in O-Calc® Pro, and the one that must be controlled 

and manipulated with the most care, and by the most qualified personnel.  

For this reason O-Calc® Pro adds an extra layer of protection to LoadCase 

elements referred to as LoadCase Sealing. 

O-Calc® Pro provides a set of sealed LoadCases pre shipped in the Master 

Catalog that contain the correct parameters for all commonly encountered 

http://www.o-calcpro.com/CATALOGS/
http://www.o-calcpro.com/CATALOGS/
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NESC and GO95 conditions, including extreme wind and extreme load.  

These LoadCases cannot be modified by any user regardless of their user 

level.  They are “Sealed” against modification. 

A user of “Normal” or higher level can unseal a COPY of a sealed LoadCase 

and make modifications to that copy.  The resulting custom LoadCase can be 

placed in the User Catalog for future use or modification. 

A user of “Administrative” level can additionally re-seal a LoadCase and 

place the newly sealed LoadCase back into the Master Catalog for use by any 

other user(s).  Such a user may also re-seal a LoadCase that is located in the 

Catalog in an unsealed form. 

The remainder of this section details the steps involved in unsealing or re-

sealing LoadCases. 

Unsealing a LoadCase 

To unseal a LoadCase in the Inventory Window for modifications, complete 

the following steps:  

Note: LoadCases should only be unsealed and modified with extreme caution.  

Modifying LoadCase attributes will affect O-Calc® Pro calculations.  

1. Right click on the LoadCase to be unsealed in the Inventory Window and 

select Unseal this LoadCase. 

Note: LoadCases cannot be unsealed in the Master Catalog.  To add a 

LoadCase from the Master Catalog see Adding Load Cases to a Pole. 

 

2. Select Yes to the confirmation message. 

  

Note: To undo the unsealing of the LoadCase, select Edit>Undo. 

3. Select File>Save. 

Once the LoadCase is unsealed you can modify the LoadCase attributes 

using the Edit option in the Inventory Window.  For additional 

information on editing attributes see Editing Equipment Attributes. 

If you need to use the unsealed LoadCase for future use or modifications 

copy the LoadCase to a specific User Catalog folder.  To copy the 

unsealed LoadCase to a User Catalog folder left click on the LoadCase in 

the Inventory Window and drag it to a specific User Catalog folder. 
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Re-Sealing a LoadCase 

To re-seal a LoadCase to prevent additional modification to the LoadCase, 

complete the following steps:  

Note: Only a person with Administrative privileges can re-seal an unsealed 

LoadCase. 

1. Right click on the LoadCase to be re-sealed in the Inventory Window 

and select Re-seal this LoadCase. 

 

 

2. Select Yes to the confirmation message. 

  

Note: To undo the sealing of the LoadCase, select Edit>Undo. 

3. Select File>Save. 

To seal a LoadCase that is unsealed in a Catalog Window select the 

LoadCase in the Catalog then select Tools>Catalog 

Maintenance>LoadCase Sealer. 

Locating O-Calc® Pro Folders  

To easily access O-Calc ® Pro user and common folders, complete the 

following steps:  

1. Select Help>Folders. 

 

2. Select the folder you need access to. 
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Development Information 

Retrieving Reference Information 

O-Calc® Pro contains a number of reports containing reference information.  

Catalog and schema information is provided for developers.  Details of the 

values available to the reporting system are available for custom report 

authors.  Raw reports of data and calculated forces are all available to assist 

in the understanding of pole loading.  These utilities are intended for 

software and report architects and as such they are of limited use to general 

users.  To access the reference information, complete the following steps: 

1. Select Tools>Misc. 

There are four reference reports available: 

➢ Schema Explorer (PDF or HTML Format) 

➢ Dump Reporting Parameters 

➢ Dump Forces Detail Report 

➢ Dump Catalog 

  

2. Select the reference report you would like to run. 

Note: These schemas can be enabled by setting the ‘SchemaAndForces’ value to 

try in the registry.  The registry path is 

HKEY_CURRENT_USER>Software>PPL>Dump. 

Creating Custom Loading Districts  

In certain situations it may be necessary to use custom loading districts 

within the O-Calc® Pro application.  Creating a custom loading district file 

will replace the O-Calc® Pro default loading district values.  If you need any 

of the default loading district values you will need to manually add them to 

your custom loading district file.   

Any LoadCases that currently use the O-Calc® Pro default loading districts 

will not be overwritten when a custom loading district file is created.  If you 
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need pre-existing loading districts changed you will need to manually edit 

these LoadCases.  A LoadCase district can only be changed in an unsealed 

LoadCase.  

Note: For additional information on editing unsealed LoadCases see Working with 

Sealed LoadCases. 

To create a custom loading district file, complete the following steps: 

1. Open Notepad. 

2. Create a list within Notepad of the custom loading districts. 

 

3. Select File>Save. 

4. Save in \Documents and Settings\All Users\Application 

Data\OsmosePPL. 

Note: Read and write permission will be needed to the OsmosePPL directory. 

This directory can also be accessed by selecting Help>Folders>All Users Root 

Folder from within O-Calc Pro.  

5. Enter the File name as “customloadingdistricts.txt”. 
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Note:  Once the customloadingdistricts.txt file has been created and saved to the 

correct location the O-Calc® Pro application will automatically utilize this file.  

O-Calc® Pro will need to be restarted for the changes to take effect.   

 To restore the default loading district values simple remove the 

customloadingdistricts.txt file from the OsmosePPL directory. O-Calc® Pro will 

need to be restarted for the changes to take effect. 

Working with Catalog Backups 

Each time changes are made to a catalog a backup of the catalog is 

automatically created when the current session is closed.    O-Calc ® Pro 

retains up to 10 backups of each catalogs, automatically deleting the oldest as 

new ones are created. By retaining a backup of each time the catalog(s) are 

changed by session it allows you to revert to a previous catalog in case a 

change was done in error.  

Backups of the catalogs are easily accessible from within the O-Calc ® Pro 

application.  The backups are located in a CatalogBackup folder wherever 

catalog files are located.    

Some of your catalog backup files can quickly be located using the links 

under the Help>Folders. 

Each catalog backup file provides the date and time that the backup file was 

created right in the file name.   

(Catalog Name).pplc.02_12_2016_08_03_18.Backup 

 

 Catalog Name          Date  Time 

To revert to a previous version of a catalog, complete the following steps: 

Note: The steps below are for reverting to a previous catalog.   

1. Open the catalog folder that has the catalog that you need to revert. 

2. Open the CatalogBackup folder. 
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3. Select and copy the backup file you need to revert to. 

4. Edit (open) the Catalog Data Path that your current catalog resides in 

(the one you want to replace). 

Note: The Catalog’s Data Path is located in the Catalog Configuration window.  

The Catalog Configuration window can be accessed by opening Tools>Catalog 

Maintenance>Configure Catalogs. 

5. Rename the catalog that resides in this folder. 

6. Copy the Catalog Backup file you copies in step 4.  

7. Edit the catalogs name by removing the Date, Time and the word 

Backup. 

8. O-Calc® Pro application will need to be closed and reopened before the 

change will take effect.  

Catalog Maintenance Mode 

O-Calc® Pro provides a Catalog Maintenance Mode that enables 

administrators to complete modifications within a catalog.   The Catalog 

Maintenance Mode allows anyone with administrative privileges to have full 

editing capabilities to all catalogs.  All attributes included attributes that are 

normally un-editable can be edited in this mode. This mode should only be 

accessed by the most qualified personnel as all changes are permanent once 

they are saved.   When the Catalog Maintenance Mode is activated, only 

modifications within the Catalog Window are permitted.  All options within 

O-Calc ® Pro that do not pertain to the Catalog Window are disabled until 

you have exited the Catalog Maintenance Mode.   

To use the Catalog Maintenance Mode, complete the following steps: 

Note: Only a person with Administrative privileges can access the Catalog 

Maintenance Mode. 

1. Close any pole that is opened in the Inventory Window File>Close Pole. 

2. Select Tools>Catalog Maintenance>Maintenance (Bulk Edit) Mode. 

Note: When the Maintenance Mode is enabled a check mark will display next to 

the menu option. 

 

3. Select Yes to continue in Catalog Maintenance Mode. 

Note: The Status Bar will turn yellow and clearly indicate that the Catalog 

Maintenance Mode is active.   
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4. Complete your modifications to the catalogs. 

Note: There is no undo option available. 

5. Deselect the Tools>Catalog Maintenance>Maintenance Mode option. 

 

6. Select Yes to save your changes. 

 


